summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-09-21 21:06:41 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-09-21 21:06:41 +0000
commit10a1557d0fb7304795f023ddc8a67401ef9a882e (patch)
tree6ba2225cd25e382b946d7cf6bc13a4fbb64505cb /sys-fs/reiserfsprogs/reiserfsprogs-3.6.21-r1.ebuild
parentVersion bump (diff)
downloadgentoo-2-10a1557d0fb7304795f023ddc8a67401ef9a882e.tar.gz
gentoo-2-10a1557d0fb7304795f023ddc8a67401ef9a882e.tar.bz2
gentoo-2-10a1557d0fb7304795f023ddc8a67401ef9a882e.zip
[sys-fs/reiserfsprogs] Add patch to fix large >4T fs
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/reiserfsprogs/reiserfsprogs-3.6.21-r1.ebuild')
-rw-r--r--sys-fs/reiserfsprogs/reiserfsprogs-3.6.21-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-fs/reiserfsprogs/reiserfsprogs-3.6.21-r1.ebuild b/sys-fs/reiserfsprogs/reiserfsprogs-3.6.21-r1.ebuild
new file mode 100644
index 000000000000..ab980aef0dac
--- /dev/null
+++ b/sys-fs/reiserfsprogs/reiserfsprogs-3.6.21-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/reiserfsprogs/reiserfsprogs-3.6.21-r1.ebuild,v 1.1 2011/09/21 21:06:41 alexxy Exp $
+
+inherit eutils
+
+DESCRIPTION="Reiserfs Utilities"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/fs/reiserfs/"
+SRC_URI="mirror://kernel/linux/utils/fs/reiserfs/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-fsck-n.patch
+ epatch "${FILESDIR}"/${P}-fix_large_fs.patch
+}
+
+src_compile() {
+ econf --prefix=/ || die "Failed to configure"
+ emake || die "Failed to compile"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Failed to install"
+ dosym reiserfsck /sbin/fsck.reiserfs
+ dosym mkreiserfs /sbin/mkfs.reiserfs
+ dodoc ChangeLog INSTALL README
+}