summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-04-13 10:45:05 +0000
committerMike Frysinger <vapier@gentoo.org>2007-04-13 10:45:05 +0000
commite4656788cc36951aa67c95816f4e86b40b7992e6 (patch)
treed1181244cdc0b93e80585c8205ea92d59568b1e7 /sys-fs/quota
parentold (diff)
downloadgentoo-2-e4656788cc36951aa67c95816f4e86b40b7992e6.tar.gz
gentoo-2-e4656788cc36951aa67c95816f4e86b40b7992e6.tar.bz2
gentoo-2-e4656788cc36951aa67c95816f4e86b40b7992e6.zip
Dont install rpc stuf when USE=-rpc #174208 by Simon Arlott.
(Portage version: 2.1.2.3)
Diffstat (limited to 'sys-fs/quota')
-rw-r--r--sys-fs/quota/ChangeLog7
-rw-r--r--sys-fs/quota/files/digest-quota-3.14-r13
-rw-r--r--sys-fs/quota/quota-3.14-r1.ebuild82
3 files changed, 91 insertions, 1 deletions
diff --git a/sys-fs/quota/ChangeLog b/sys-fs/quota/ChangeLog
index ab1321af347d..19d26a49c541 100644
--- a/sys-fs/quota/ChangeLog
+++ b/sys-fs/quota/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/quota
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/ChangeLog,v 1.20 2007/04/06 20:53:11 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/ChangeLog,v 1.21 2007/04/13 10:45:05 vapier Exp $
+
+*quota-3.14-r1 (13 Apr 2007)
+
+ 13 Apr 2007; Mike Frysinger <vapier@gentoo.org> +quota-3.14-r1.ebuild:
+ Dont install rpc stuf when USE=-rpc #174208 by Simon Arlott.
06 Apr 2007; Brent Baude <ranger@gentoo.org> quota-3.13.ebuild:
Marking quota ppc for bug #172154
diff --git a/sys-fs/quota/files/digest-quota-3.14-r1 b/sys-fs/quota/files/digest-quota-3.14-r1
new file mode 100644
index 000000000000..e24c9b388848
--- /dev/null
+++ b/sys-fs/quota/files/digest-quota-3.14-r1
@@ -0,0 +1,3 @@
+MD5 e6ae17d4bf26012e820c3582ec7af487 quota-3.14.tar.gz 249016
+RMD160 2282bb8b14d6e61beea0841cac5a67eec9f3d85d quota-3.14.tar.gz 249016
+SHA256 e4226a5dc77303d417905658210ce861e1eb904bc2c7acd401c3a1373715942d quota-3.14.tar.gz 249016
diff --git a/sys-fs/quota/quota-3.14-r1.ebuild b/sys-fs/quota/quota-3.14-r1.ebuild
new file mode 100644
index 000000000000..34f3d9fb4235
--- /dev/null
+++ b/sys-fs/quota/quota-3.14-r1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/quota-3.14-r1.ebuild,v 1.1 2007/04/13 10:45:05 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="Linux quota tools"
+HOMEPAGE="http://sourceforge.net/projects/linuxquota/"
+SRC_URI="mirror://sourceforge/linuxquota/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE="nls tcpd ldap rpc"
+
+RDEPEND="ldap? ( net-nds/openldap )
+ tcpd? ( sys-apps/tcp-wrappers )
+ rpc? ( net-nds/portmap )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/quota-tools
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-3.13-configure-LANG.patch #131432
+ epatch "${FILESDIR}"/${PN}-3.14-headers.patch
+
+ # patch to prevent quotactl.2 manpage from being installed
+ # that page is provided by man-pages instead
+ epatch "${FILESDIR}"/${PN}-no-quotactl-manpage.patch
+
+ # Don't strip binaries (from Fedora)
+ epatch "${FILESDIR}"/quota-3.06-no-stripping.patch
+
+ sed -i -e "s:,LIBS=\"\$saved_LIBS=\":;LIBS=\"\$saved_LIBS\":" configure
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable ldap ldapmail) \
+ $(use_enable rpc) \
+ $(use_enable rpc rpcsetquota) \
+ || die
+ emake || die
+}
+
+src_install() {
+ dodir /{sbin,etc,usr/sbin,usr/bin,usr/share/man/man{1,3,8}}
+ emake ROOTDIR="${D}" install || die
+ rm -r "${D}"/usr/include #70938
+
+ insinto /etc
+ insopts -m0644
+ doins warnquota.conf quotatab
+
+ dodoc doc/*
+ dodoc README.*
+ dodoc Changelog
+
+ newinitd "${FILESDIR}"/quota.rc6 quota
+ newconfd "${FILESDIR}"/quota.confd quota
+
+ if use rpc ; then
+ newinitd "${FILESDIR}"/rpc.rquotad.initd rpc.rquotad
+ else
+ rm -f "${D}"/usr/sbin/rpc.rquotad
+ fi
+
+ if use ldap ; then
+ insinto /etc/openldap/schema
+ insopts -m0644
+ doins ldap-scripts/quota.schema
+
+ exeinto /usr/share/quota/ldap-scripts
+ doexe ldap-scripts/*.pl
+ doexe ldap-scripts/edquota_editor
+ fi
+}