summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-07-11 15:16:06 +0000
committerJustin Lecher <jlec@gentoo.org>2010-07-11 15:16:06 +0000
commita5cee2c77bcc602c4f688265c4c1869c78656613 (patch)
tree82dbddec35d88f093526fd6e0be8cef5b93b24c3 /sys-fs/pysize
parentDrop hppa keyword per bug #324511. (diff)
downloadgentoo-2-a5cee2c77bcc602c4f688265c4c1869c78656613.tar.gz
gentoo-2-a5cee2c77bcc602c4f688265c4c1869c78656613.tar.bz2
gentoo-2-a5cee2c77bcc602c4f688265c4c1869c78656613.zip
Import from sunrise
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/pysize')
-rw-r--r--sys-fs/pysize/ChangeLog11
-rw-r--r--sys-fs/pysize/files/0.2-setuptools-automagic.patch12
-rw-r--r--sys-fs/pysize/files/psyco-0.2-automagic.patch20
-rw-r--r--sys-fs/pysize/metadata.xml9
-rw-r--r--sys-fs/pysize/pysize-0.2.ebuild49
5 files changed, 101 insertions, 0 deletions
diff --git a/sys-fs/pysize/ChangeLog b/sys-fs/pysize/ChangeLog
new file mode 100644
index 000000000000..d990aa9cc914
--- /dev/null
+++ b/sys-fs/pysize/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sys-fs/pysize
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/pysize/ChangeLog,v 1.1 2010/07/11 15:16:05 jlec Exp $
+
+*pysize-0.2 (11 Jul 2010)
+
+ 11 Jul 2010; Justin Lecher <jlec@gentoo.org>
+ +files/0.2-setuptools-automagic.patch, +pysize-0.2.ebuild,
+ +files/psyco-0.2-automagic.patch, +metadata.xml:
+ Import from sunrise
+
diff --git a/sys-fs/pysize/files/0.2-setuptools-automagic.patch b/sys-fs/pysize/files/0.2-setuptools-automagic.patch
new file mode 100644
index 000000000000..3e27c889f1a5
--- /dev/null
+++ b/sys-fs/pysize/files/0.2-setuptools-automagic.patch
@@ -0,0 +1,12 @@
+diff --git a/setup.py b/setup.py
+index 5550188..123d22c 100755
+--- a/setup.py
++++ b/setup.py
+@@ -2,7 +2,6 @@
+
+ import sys
+
+-sys.path.append('setuptools-0.7a1dev_r53614-py2.4.egg')
+ from setuptools import setup, find_packages
+ from pysize.version import VERSION
+
diff --git a/sys-fs/pysize/files/psyco-0.2-automagic.patch b/sys-fs/pysize/files/psyco-0.2-automagic.patch
new file mode 100644
index 000000000000..696f81fa4feb
--- /dev/null
+++ b/sys-fs/pysize/files/psyco-0.2-automagic.patch
@@ -0,0 +1,20 @@
+--- pysize/main.py 2007-03-11 16:09:53.000000000 +0100
++++ pysize/main.py.new 2009-01-02 00:08:43.384827054 +0100
+@@ -69,17 +69,8 @@
+ stats.print_stats(40)
+ os.remove(prof_file)
+
+-def _try_psyco():
+- try:
+- # Try to use psyco if available
+- import psyco
+- psyco.full()
+- except ImportError:
+- pass
+-
+ def main():
+ install_sigquit_traceback()
+- _try_psyco()
+ locale.setlocale(locale.LC_ALL, '')
+ usage = '%s [OPTIONS] [DIRECTORIES...]' % (sys.argv[0])
+ parser = optparse.OptionParser(usage=usage, version='pysize ' + VERSION)
diff --git a/sys-fs/pysize/metadata.xml b/sys-fs/pysize/metadata.xml
new file mode 100644
index 000000000000..7585c56085fc
--- /dev/null
+++ b/sys-fs/pysize/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+<maintainer><email>jlec@gentoo.org</email></maintainer>
+ <use>
+ <flag name='psyco'>Adds psyco support</flag>
+ </use>
+</pkgmetadata>
diff --git a/sys-fs/pysize/pysize-0.2.ebuild b/sys-fs/pysize/pysize-0.2.ebuild
new file mode 100644
index 000000000000..5ab9c34460d6
--- /dev/null
+++ b/sys-fs/pysize/pysize-0.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/pysize/pysize-0.2.ebuild,v 1.1 2010/07/11 15:16:05 jlec Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils eutils
+
+DESCRIPTION="A graphical and console tool for exploring the size of directories"
+HOMEPAGE="http://guichaz.free.fr/pysize/"
+SRC_URI="http://guichaz.free.fr/${PN}/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk ncurses psyco"
+
+DEPEND="
+ gtk? ( dev-python/pygtk )
+ ncurses? ( sys-libs/ncurses )
+ psyco? ( dev-python/psyco )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ if ! use gtk; then
+ sed -e '/^from pysize.ui.gtk/d' \
+ -e "s~'gtk': ui_gtk.run,~~g" \
+ -e 's:ui_gtk.run,::g' \
+ -i pysize/main.py || die "Failed to remove gtk support"
+ rm -rf pysize/ui/gtk || die "Failed to remove gtk support"
+ fi
+
+ if ! use ncurses; then
+ sed -e '/^from pysize.ui.curses/d' \
+ -e "s~'curses': ui_curses.run,~~g" \
+ -e 's:ui_curses.run,::g' \
+ -i pysize/main.py || die "Failed to remove ncurses support"
+ rm -rf pysize/ui/curses || die "Failed to remove ncurses support"
+ fi
+
+ use psyco || epatch "${FILESDIR}/psyco-${PV}"-automagic.patch
+
+ epatch "${FILESDIR}"/${PV}-setuptools-automagic.patch
+ distutils_src_prepare
+}