summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2008-03-22 17:53:35 +0000
committerWolfram Schlich <wschlich@gentoo.org>2008-03-22 17:53:35 +0000
commitba3a05b40fbcdbff01fe251a78d0e84d20f428c4 (patch)
tree41cbd66002ac6881f4c93eabd348cd59776ecbc0 /sys-fs/owfs
parentNew version for GNOME-2.22 with various code cleanups, string fixes and more (diff)
downloadgentoo-2-ba3a05b40fbcdbff01fe251a78d0e84d20f428c4.tar.gz
gentoo-2-ba3a05b40fbcdbff01fe251a78d0e84d20f428c4.tar.bz2
gentoo-2-ba3a05b40fbcdbff01fe251a78d0e84d20f428c4.zip
version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-fs/owfs')
-rw-r--r--sys-fs/owfs/ChangeLog7
-rw-r--r--sys-fs/owfs/owfs-2.7_p4.ebuild116
2 files changed, 122 insertions, 1 deletions
diff --git a/sys-fs/owfs/ChangeLog b/sys-fs/owfs/ChangeLog
index 615754ca1303..27ffa566d5bb 100644
--- a/sys-fs/owfs/ChangeLog
+++ b/sys-fs/owfs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/owfs
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/owfs/ChangeLog,v 1.7 2008/02/24 22:58:38 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/owfs/ChangeLog,v 1.8 2008/03/22 17:53:35 wschlich Exp $
+
+*owfs-2.7_p4 (22 Mar 2008)
+
+ 22 Mar 2008; Wolfram Schlich <wschlich@gentoo.org> +owfs-2.7_p4.ebuild:
+ version bump
24 Feb 2008; Wolfram Schlich <wschlich@gentoo.org> files/owfs.initd:
fix variable name in owfs init script wrt bug #203642
diff --git a/sys-fs/owfs/owfs-2.7_p4.ebuild b/sys-fs/owfs/owfs-2.7_p4.ebuild
new file mode 100644
index 000000000000..d9cac99135ad
--- /dev/null
+++ b/sys-fs/owfs/owfs-2.7_p4.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/owfs/owfs-2.7_p4.ebuild,v 1.1 2008/03/22 17:53:35 wschlich Exp $
+
+inherit eutils depend.php
+
+MY_P=${P/_/}
+
+DESCRIPTION="Access 1-Wire devices like a filesystem"
+SRC_URI="mirror://sourceforge/owfs/${MY_P}.tar.gz"
+HOMEPAGE="http://www.owfs.org/ http://owfs.sourceforge.net/"
+LICENSE="GPL-2"
+DEPEND="fuse? ( sys-fs/fuse )
+ perl? ( dev-lang/perl dev-lang/swig )
+ php? ( dev-lang/php dev-lang/swig )
+ python? ( dev-lang/python dev-lang/swig )
+ tcl? ( dev-lang/tcl )
+ usb? ( dev-libs/libusb )
+ zeroconf? ( || ( net-dns/avahi net-misc/mDNSResponder ) )"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="debug fuse ftpd httpd parport perl php python server tcl usb zeroconf"
+
+S=${WORKDIR}/${MY_P}
+
+OWUID=${OWUID:-owfs}
+OWGID=${OWGID:-owfs}
+
+pkg_setup() {
+ if use php; then
+ require_php_cli
+ fi
+ if use zeroconf && has_version net-dns/avahi && ! built_with_use net-dns/avahi mdnsresponder-compat; then
+ eerror "You need to recompile net-dns/avahi with mdnsresponder-compat USE flag"
+ die "net-dns/avahi is missing required mdnsresponder-compat support for USE=zeroconf"
+ fi
+ enewgroup ${OWGID} 150
+ enewuser ${OWUID} 150 -1 -1 ${OWGID}
+}
+
+src_compile() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable fuse owfs) \
+ $(use_enable ftpd owftpd) \
+ $(use_enable httpd owhttpd) \
+ $(use_enable parport) \
+ $(use_enable perl owperl) \
+ $(use_enable php owphp) \
+ $(use_enable python owpython) \
+ $(use_enable server owserver) \
+ $(use_enable tcl owtcl) \
+ $(use_enable zeroconf zero) \
+ $(use_enable usb) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README NEWS ChangeLog AUTHORS
+ if use server || use httpd || use ftpd || use fuse; then
+ diropts -m 0750 -o ${OWUID} -g ${OWGID}
+ dodir /var/run/owfs
+ for i in server httpd ftpd; do
+ if use ${i}; then
+ newinitd "${FILESDIR}"/ow${i}.initd ow${i}
+ newconfd "${FILESDIR}"/ow${i}.confd ow${i}
+ fi
+ done
+ if use fuse; then
+ dodir /var/lib/owfs
+ dodir /var/lib/owfs/mnt
+ newinitd "${FILESDIR}"/owfs.initd owfs
+ newconfd "${FILESDIR}"/owfs.confd owfs
+ fi
+ fi
+}
+
+pkg_postinst() {
+ if use server || use httpd || use ftpd || use fuse; then
+ echo
+ einfo
+ einfo "Be sure to check/edit the following files,"
+ einfo "e.g. to fit your 1 wire bus controller"
+ einfo "device or daemon network settings:"
+ for i in server httpd ftpd; do
+ if use ${i}; then
+ einfo "- ${ROOT%/}/etc/conf.d/ow${i}"
+ fi
+ done
+ if use fuse; then
+ einfo "- ${ROOT%/}/etc/conf.d/owfs"
+ fi
+ einfo
+ echo
+ if [[ ${OWUID} != root ]]; then
+ ewarn
+ ewarn "In order to allow the OWFS daemon user '${OWUID}' to read"
+ ewarn "from and/or write to a 1 wire bus controller device, make"
+ ewarn "sure the user has appropriate permission to access the"
+ ewarn "corresponding device node/path (e.g. /dev/ttyS0), for example"
+ ewarn "by adding the user to the group 'uucp' (for serial devices)"
+ ewarn "or 'usb' (for USB devices accessed via usbfs on /proc/bus/usb)."
+ ewarn
+ if use fuse; then
+ ewarn "In order to allow regular users to read from and/or write to"
+ ewarn "1 wire bus devices accessible via the owfs FUSE filesystem"
+ ewarn "client and its filesystem mountpoint, make sure the user is"
+ ewarn "a member of the group '${OWGID}'."
+ ewarn
+ fi
+ echo
+ fi
+ fi
+}