summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-03-20 15:12:49 +0000
committerJustin Lecher <jlec@gentoo.org>2015-03-20 15:12:49 +0000
commit681e47ab97fe8144060b10e896d73edb18157be0 (patch)
tree4c3359744a9e9ff684f6bd09fcf8de849e375c00 /sys-fs/owfs
parentx86 stable, see bug 498156 (diff)
downloadgentoo-2-681e47ab97fe8144060b10e896d73edb18157be0.tar.gz
gentoo-2-681e47ab97fe8144060b10e896d73edb18157be0.tar.bz2
gentoo-2-681e47ab97fe8144060b10e896d73edb18157be0.zip
Fix tcl/tk slotting; drop old
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sys-fs/owfs')
-rw-r--r--sys-fs/owfs/ChangeLog8
-rw-r--r--sys-fs/owfs/owfs-2.7_p21-r2.ebuild186
-rw-r--r--sys-fs/owfs/owfs-2.7_p21-r3.ebuild15
3 files changed, 13 insertions, 196 deletions
diff --git a/sys-fs/owfs/ChangeLog b/sys-fs/owfs/ChangeLog
index 02260ca10154..ee4613ed6b63 100644
--- a/sys-fs/owfs/ChangeLog
+++ b/sys-fs/owfs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/owfs
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/owfs/ChangeLog,v 1.26 2014/12/26 11:42:05 mgorny Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/owfs/ChangeLog,v 1.27 2015/03/20 15:12:49 jlec Exp $
+
+ 20 Mar 2015; Justin Lecher <jlec@gentoo.org> -owfs-2.7_p21-r2.ebuild,
+ owfs-2.7_p21-r3.ebuild:
+ Fix tcl/tk slotting; drop old
*owfs-2.7_p21-r3 (26 Dec 2014)
diff --git a/sys-fs/owfs/owfs-2.7_p21-r2.ebuild b/sys-fs/owfs/owfs-2.7_p21-r2.ebuild
deleted file mode 100644
index 123525d37f68..000000000000
--- a/sys-fs/owfs/owfs-2.7_p21-r2.ebuild
+++ /dev/null
@@ -1,186 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/owfs/owfs-2.7_p21-r2.ebuild,v 1.2 2014/11/17 23:23:33 dilfridge Exp $
-
-EAPI="5"
-
-PYTHON_DEPEND="python? 2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-
-inherit depend.php distutils eutils perl-module autotools user
-
-MY_P=${P/_/}
-
-DESCRIPTION="Access 1-Wire devices like a filesystem"
-SRC_URI="mirror://sourceforge/owfs/${MY_P}.tar.gz"
-HOMEPAGE="http://www.owfs.org/ http://owfs.sourceforge.net/"
-
-KEYWORDS="~amd64 ~arm ~x86"
-SLOT="0"
-LICENSE="GPL-2"
-
-RDEPEND="fuse? ( sys-fs/fuse )
- perl? ( dev-lang/perl )
- php? ( dev-lang/php )
- tcl? ( dev-lang/tcl )
- usb? ( virtual/libusb:0 )
- zeroconf? ( net-dns/avahi[mdnsresponder-compat] )"
-
-DEPEND="${RDEPEND}
- perl? ( dev-lang/swig )
- php? ( dev-lang/swig )
- python? ( dev-lang/swig )"
-
-IUSE="debug fuse ftpd httpd parport perl php python server tcl usb zeroconf"
-
-S=${WORKDIR}/${MY_P}
-
-OWUID=${OWUID:-owfs}
-OWGID=${OWGID:-owfs}
-
-PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
-PYTHON_MODNAME="ow ownet"
-
-pkg_setup() {
- if use php; then
- require_php_cli
- fi
-
- if use python; then
- python_pkg_setup
- fi
-
- enewgroup ${OWGID} 150
- enewuser ${OWUID} 150 -1 -1 ${OWGID}
-}
-
-src_prepare() {
- sed -e 's/ \$(OWNET_SUBDIRPYTHON)//' -i module/ownet/Makefile.{am,in} || die
- sed -e 's/ \$(SWIG_SUBDIRPYTHON)//' -i module/swig/Makefile.{am,in} || die
- sed \
- -e "s/@PYCFLAGS@//" \
- -e "s/@PYLDFLAGS@//" \
- -i module/swig/python/setup.py.in || die "sed failed"
-
- # Support user's CFLAGS and LDFLAGS.
- sed -i "s/@CPPFLAGS@/@CPPFLAGS@ ${CFLAGS}/" \
- module/swig/perl5/OW/Makefile.linux.in || die
- sed -i "s/@LIBS@/@LIBS@ ${LDFLAGS}/" \
- module/swig/perl5/OW/Makefile.linux.in || die
-
- epatch "${FILESDIR}/${PN}-vendordir.patch"
-
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_enable debug) \
- $(use_enable fuse owfs) \
- $(use_enable ftpd owftpd) \
- $(use_enable httpd owhttpd) \
- $(use_enable parport) \
- $(use_enable perl owperl) \
- $(use_enable php owphp) \
- $(use_enable python owpython) \
- $(use_enable server owserver) \
- $(use_enable tcl owtcl) \
- $(use_enable zeroconf zero) \
- $(use_enable usb)
-}
-
-src_compile() {
- default
-
- if use python; then
- pushd module/ownet/python > /dev/null
- distutils_src_compile
- popd > /dev/null
-
- pushd module/swig/python > /dev/null
- emake ow_wrap.c
- distutils_src_compile
- popd > /dev/null
- fi
-}
-
-src_test() { :; }
-
-src_install() {
- default
-
- if use server || use httpd || use ftpd || use fuse; then
- diropts -m 0750 -o ${OWUID} -g ${OWGID}
- dodir /var/run/owfs
-
- for i in server httpd ftpd; do
- if use ${i}; then
- newinitd "${FILESDIR}"/ow${i}.initd ow${i}
- newconfd "${FILESDIR}"/ow${i}.confd ow${i}
- fi
- done
-
- if use fuse; then
- dodir /var/lib/owfs
- dodir /var/lib/owfs/mnt
- newinitd "${FILESDIR}"/owfs.initd owfs
- newconfd "${FILESDIR}"/owfs.confd owfs
- fi
- fi
- use perl && perl_delete_localpod
-
- if use python; then
- pushd module/ownet/python > /dev/null
- distutils_src_install
- popd > /dev/null
-
- pushd module/swig/python > /dev/null
- distutils_src_install
- popd > /dev/null
- fi
-}
-
-pkg_postinst() {
- if use server || use httpd || use ftpd || use fuse; then
- echo
- einfo
- einfo "Be sure to check/edit the following files,"
- einfo "e.g. to fit your 1 wire bus controller"
- einfo "device or daemon network settings:"
- for i in server httpd ftpd; do
- if use ${i}; then
- einfo "- ${ROOT%/}/etc/conf.d/ow${i}"
- fi
- done
- if use fuse; then
- einfo "- ${ROOT%/}/etc/conf.d/owfs"
- fi
- einfo
- echo
- if [[ ${OWUID} != root ]]; then
- ewarn
- ewarn "In order to allow the OWFS daemon user '${OWUID}' to read"
- ewarn "from and/or write to a 1 wire bus controller device, make"
- ewarn "sure the user has appropriate permission to access the"
- ewarn "corresponding device node/path (e.g. /dev/ttyS0), for example"
- ewarn "by adding the user to the group 'uucp' (for serial devices)"
- ewarn "or 'usb' (for USB devices accessed via usbfs on /proc/bus/usb)."
- ewarn
- if use fuse; then
- ewarn "In order to allow regular users to read from and/or write to"
- ewarn "1 wire bus devices accessible via the owfs FUSE filesystem"
- ewarn "client and its filesystem mountpoint, make sure the user is"
- ewarn "a member of the group '${OWGID}'."
- ewarn
- fi
- echo
- fi
- fi
-
- use python && distutils_pkg_postinst
-}
-
-pkg_postrm() {
- use python && distutils_pkg_postrm
-}
diff --git a/sys-fs/owfs/owfs-2.7_p21-r3.ebuild b/sys-fs/owfs/owfs-2.7_p21-r3.ebuild
index 9c02c8750f71..51f763dc82b3 100644
--- a/sys-fs/owfs/owfs-2.7_p21-r3.ebuild
+++ b/sys-fs/owfs/owfs-2.7_p21-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/owfs/owfs-2.7_p21-r3.ebuild,v 1.1 2014/12/26 11:42:05 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/owfs/owfs-2.7_p21-r3.ebuild,v 1.2 2015/03/20 15:12:49 jlec Exp $
EAPI="5"
@@ -19,11 +19,12 @@ KEYWORDS="~amd64 ~arm ~x86"
SLOT="0"
LICENSE="GPL-2"
-RDEPEND="fuse? ( sys-fs/fuse )
+RDEPEND="
+ fuse? ( sys-fs/fuse )
perl? ( dev-lang/perl )
- php? ( dev-lang/php )
+ php? ( dev-lang/php:= )
python? ( ${PYTHON_DEPS} )
- tcl? ( dev-lang/tcl )
+ tcl? ( dev-lang/tcl:= )
usb? ( virtual/libusb:0 )
zeroconf? ( net-dns/avahi[mdnsresponder-compat] )"
@@ -41,9 +42,7 @@ OWUID=${OWUID:-owfs}
OWGID=${OWGID:-owfs}
pkg_setup() {
- if use php; then
- require_php_cli
- fi
+ use php && require_php_cli
enewgroup ${OWGID} 150
enewuser ${OWUID} 150 -1 -1 ${OWGID}