summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-07-14 17:27:52 +0000
committerMike Frysinger <vapier@gentoo.org>2007-07-14 17:27:52 +0000
commit2687eeac04dd64119bfc6ac8f282d13351b4f4be (patch)
treea537b0fa0153403e2d48c3fe90aca23b8f426fb9 /sys-fs/ntfsprogs/ntfsprogs-1.13.1-r1.ebuild
parentFix versioning bug#185183 (again) (diff)
downloadgentoo-2-2687eeac04dd64119bfc6ac8f282d13351b4f4be.tar.gz
gentoo-2-2687eeac04dd64119bfc6ac8f282d13351b4f4be.tar.bz2
gentoo-2-2687eeac04dd64119bfc6ac8f282d13351b4f4be.zip
Fix problems with resizing Vista partitions #185241 by Harald van Dijk.
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'sys-fs/ntfsprogs/ntfsprogs-1.13.1-r1.ebuild')
-rw-r--r--sys-fs/ntfsprogs/ntfsprogs-1.13.1-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-fs/ntfsprogs/ntfsprogs-1.13.1-r1.ebuild b/sys-fs/ntfsprogs/ntfsprogs-1.13.1-r1.ebuild
new file mode 100644
index 000000000000..8ea619b0059e
--- /dev/null
+++ b/sys-fs/ntfsprogs/ntfsprogs-1.13.1-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfsprogs/ntfsprogs-1.13.1-r1.ebuild,v 1.1 2007/07/14 17:27:51 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="User tools for NTFS filesystems"
+HOMEPAGE="http://www.linux-ntfs.org/"
+SRC_URI="mirror://sourceforge/linux-ntfs/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="crypt debug fuse gnome"
+
+RDEPEND="fuse? ( >=sys-fs/fuse-2.3.0 )
+ crypt? ( >=dev-libs/libgcrypt-1.2.0 >=net-libs/gnutls-1.2.8 )
+ gnome? (
+ >=dev-libs/glib-2.0
+ >=gnome-base/gnome-vfs-2.0
+ )"
+DEPEND="${RDEPEND}
+ !=sys-fs/ntfs3g-0.1_beta20070714
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-resize-vista.patch
+ sed -i -e 's:-ggdb3::' configure
+}
+
+src_compile() {
+ econf \
+ $(use_enable crypt crypto) \
+ $(use_enable debug) \
+ $(use_enable fuse fuse-module) \
+ $(use_enable gnome gnome-vfs) \
+ || die "Configure failed"
+ emake || die "Make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Install failed"
+ dodoc AUTHORS CREDITS ChangeLog NEWS README TODO.* \
+ doc/attribute_definitions doc/*.txt doc/tunable_settings
+}