summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2008-07-10 15:45:13 +0000
committerPatrick McLean <chutzpah@gentoo.org>2008-07-10 15:45:13 +0000
commitfeded456be8798758971ee4499caf70914d9d6a1 (patch)
treea1fdf9e1b23090ffe0891ff3cdf1e711749dc77f /sys-fs/ntfs3g
parentdev-cpp/libgnomeuimm: update HOMEPAGE (diff)
downloadgentoo-2-feded456be8798758971ee4499caf70914d9d6a1.tar.gz
gentoo-2-feded456be8798758971ee4499caf70914d9d6a1.tar.bz2
gentoo-2-feded456be8798758971ee4499caf70914d9d6a1.zip
Add "hal" USE flag to install .fdi file so hal will mount NTFS with ntfs-3g rather than the kernel NTFS driver. Thanks to Malte Starostik <m-starostik@versanet.de> (bug #231376). Stabilize ntfs3g-1.2531 on amd64 (bug #231422).
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-gentoo-r6 x86_64)
Diffstat (limited to 'sys-fs/ntfs3g')
-rw-r--r--sys-fs/ntfs3g/ChangeLog11
-rw-r--r--sys-fs/ntfs3g/files/10-ntfs3g.fdi10
-rw-r--r--sys-fs/ntfs3g/ntfs3g-1.2531-r1.ebuild52
-rw-r--r--sys-fs/ntfs3g/ntfs3g-1.2531.ebuild4
4 files changed, 74 insertions, 3 deletions
diff --git a/sys-fs/ntfs3g/ChangeLog b/sys-fs/ntfs3g/ChangeLog
index ff4af4588cdd..9ceb89692349 100644
--- a/sys-fs/ntfs3g/ChangeLog
+++ b/sys-fs/ntfs3g/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-fs/ntfs3g
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.66 2008/06/03 17:58:13 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.67 2008/07/10 15:45:12 chutzpah Exp $
+
+*ntfs3g-1.2531-r1 (10 Jul 2008)
+
+ 10 Jul 2008; Patrick McLean <chutzpah@gentoo.org> +files/10-ntfs3g.fdi,
+ ntfs3g-1.2531.ebuild, +ntfs3g-1.2531-r1.ebuild:
+ Add "hal" USE flag to install .fdi file so hal will mount NTFS with
+ ntfs-3g rather than the kernel NTFS driver. Thanks to Malte Starostik
+ <m-starostik@versanet.de> (bug #231376). Stabilize ntfs3g-1.2531 on amd64
+ (bug #231422).
*ntfs3g-1.2531 (03 Jun 2008)
diff --git a/sys-fs/ntfs3g/files/10-ntfs3g.fdi b/sys-fs/ntfs3g/files/10-ntfs3g.fdi
new file mode 100644
index 000000000000..488f47bb72cd
--- /dev/null
+++ b/sys-fs/ntfs3g/files/10-ntfs3g.fdi
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<deviceinfo version="0.2">
+ <device>
+ <match key="volume.fstype" string="ntfs">
+ <merge key="volume.fstype" type="string">ntfs-3g</merge>
+ <merge key="volume.policy.mount_filesystem" type="string">ntfs-3g</merge>
+ <append key="volume.mount.valid_options" type="strlist">locale=</append>
+ </match>
+ </device>
+</deviceinfo>
diff --git a/sys-fs/ntfs3g/ntfs3g-1.2531-r1.ebuild b/sys-fs/ntfs3g/ntfs3g-1.2531-r1.ebuild
new file mode 100644
index 000000000000..efbc613f9e5f
--- /dev/null
+++ b/sys-fs/ntfs3g/ntfs3g-1.2531-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-1.2531-r1.ebuild,v 1.1 2008/07/10 15:45:12 chutzpah Exp $
+
+MY_PN="${PN/3g/-3g}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Open source read-write NTFS driver that runs under FUSE"
+HOMEPAGE="http://www.ntfs-3g.org"
+SRC_URI="http://www.ntfs-3g.org/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug hal suid"
+
+RDEPEND="hal? ( sys-apps/hal )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ --enable-ldscript \
+ --disable-ldconfig \
+ $(use_enable debug)
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ prepalldocs
+ dodoc AUTHORS ChangeLog CREDITS
+
+ use suid && fperms u+s "/bin/${MY_PN}"
+
+ if use hal; then
+ insinto /etc/hal/fdi/policy/
+ doins "${FILESDIR}/10-ntfs3g.fdi"
+ fi
+}
+
+pkg_postinst() {
+ if use suid; then
+ ewarn
+ ewarn "You have chosen to install ${PN} with the binary setuid root. This"
+ ewarn "means that if there any undetected vulnerabilities in the binary,"
+ ewarn "then local users may be able to gain root access on your machine."
+ ewarn
+ fi
+}
diff --git a/sys-fs/ntfs3g/ntfs3g-1.2531.ebuild b/sys-fs/ntfs3g/ntfs3g-1.2531.ebuild
index 7ee94a5dc3ea..07b4fa95dbc1 100644
--- a/sys-fs/ntfs3g/ntfs3g-1.2531.ebuild
+++ b/sys-fs/ntfs3g/ntfs3g-1.2531.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-1.2531.ebuild,v 1.1 2008/06/03 17:58:13 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-1.2531.ebuild,v 1.2 2008/07/10 15:45:12 chutzpah Exp $
MY_PN="${PN/3g/-3g}"
MY_P="${MY_PN}-${PV}"
@@ -11,7 +11,7 @@ SRC_URI="http://www.ntfs-3g.org/${MY_P}.tgz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="debug suid"
RDEPEND=""