summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2008-10-06 14:57:36 +0000
committerPatrick McLean <chutzpah@gentoo.org>2008-10-06 14:57:36 +0000
commitb50868fc49977f8d2da09befff140ab575a6b9cc (patch)
tree64b9209f18c224753cd778b5d30d68991cc997c9 /sys-fs/ntfs3g
parentversion bump (diff)
downloadgentoo-2-b50868fc49977f8d2da09befff140ab575a6b9cc.tar.gz
gentoo-2-b50868fc49977f8d2da09befff140ab575a6b9cc.tar.bz2
gentoo-2-b50868fc49977f8d2da09befff140ab575a6b9cc.zip
Version bump (bug #239306)
(Portage version: 2.2_rc11/cvs/Linux 2.6.27-rc8-00084-gfec6ed1 x86_64)
Diffstat (limited to 'sys-fs/ntfs3g')
-rw-r--r--sys-fs/ntfs3g/ChangeLog7
-rw-r--r--sys-fs/ntfs3g/ntfs3g-1.2918.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/sys-fs/ntfs3g/ChangeLog b/sys-fs/ntfs3g/ChangeLog
index f57fd0536195..3d4a59018935 100644
--- a/sys-fs/ntfs3g/ChangeLog
+++ b/sys-fs/ntfs3g/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/ntfs3g
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.72 2008/08/20 19:17:01 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.73 2008/10/06 14:57:36 chutzpah Exp $
+
+*ntfs3g-1.2918 (06 Oct 2008)
+
+ 06 Oct 2008; Patrick McLean <chutzpah@gentoo.org> +ntfs3g-1.2918.ebuild:
+ Version bump (bug #239306)
*ntfs3g-1.2812 (20 Aug 2008)
diff --git a/sys-fs/ntfs3g/ntfs3g-1.2918.ebuild b/sys-fs/ntfs3g/ntfs3g-1.2918.ebuild
new file mode 100644
index 000000000000..ba9944e9e99a
--- /dev/null
+++ b/sys-fs/ntfs3g/ntfs3g-1.2918.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-1.2918.ebuild,v 1.1 2008/10/06 14:57:36 chutzpah Exp $
+
+MY_PN="${PN/3g/-3g}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Open source read-write NTFS driver that runs under FUSE"
+HOMEPAGE="http://www.ntfs-3g.org"
+SRC_URI="http://www.ntfs-3g.org/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug hal suid"
+
+RDEPEND="hal? ( sys-apps/hal )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ --enable-ldscript \
+ --disable-ldconfig \
+ $(use_enable debug)
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ prepalldocs
+ dodoc AUTHORS ChangeLog CREDITS
+
+ use suid && fperms u+s "/bin/${MY_PN}"
+
+ if use hal; then
+ insinto /etc/hal/fdi/policy/
+ doins "${FILESDIR}/10-ntfs3g.fdi"
+ fi
+}
+
+pkg_postinst() {
+ if use suid; then
+ ewarn
+ ewarn "You have chosen to install ${PN} with the binary setuid root. This"
+ ewarn "means that if there any undetected vulnerabilities in the binary,"
+ ewarn "then local users may be able to gain root access on your machine."
+ ewarn
+ fi
+}