summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2006-11-20 16:43:02 +0000
committerPatrick McLean <chutzpah@gentoo.org>2006-11-20 16:43:02 +0000
commitaddc9eb9388d777f93d75fd1e717b1bd7a21a113 (patch)
tree87cdc72d2bd7c5f0625d6bb2edd299add65b02ac /sys-fs/ntfs3g
parentStable on sparc (diff)
downloadgentoo-2-addc9eb9388d777f93d75fd1e717b1bd7a21a113.tar.gz
gentoo-2-addc9eb9388d777f93d75fd1e717b1bd7a21a113.tar.bz2
gentoo-2-addc9eb9388d777f93d75fd1e717b1bd7a21a113.zip
Revision bump, add check to see if FUSE is compiled in the kernel sources, and die with instructions on making sure that you have the module from the FUSE package (bug #155637).
(Portage version: 2.1.2_rc1-r6)
Diffstat (limited to 'sys-fs/ntfs3g')
-rw-r--r--sys-fs/ntfs3g/ChangeLog10
-rw-r--r--sys-fs/ntfs3g/files/digest-ntfs3g-0.20061115-r13
-rw-r--r--sys-fs/ntfs3g/ntfs3g-0.20061115-r1.ebuild54
3 files changed, 66 insertions, 1 deletions
diff --git a/sys-fs/ntfs3g/ChangeLog b/sys-fs/ntfs3g/ChangeLog
index d37139db7012..ccde49bcc24f 100644
--- a/sys-fs/ntfs3g/ChangeLog
+++ b/sys-fs/ntfs3g/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-fs/ntfs3g
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.15 2006/11/15 03:23:23 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.16 2006/11/20 16:43:02 chutzpah Exp $
+
+*ntfs3g-0.20061115-r1 (20 Nov 2006)
+
+ 20 Nov 2006; Patrick McLean <chutzpah@gentoo.org>
+ +ntfs3g-0.20061115-r1.ebuild:
+ Revision bump, add check to see if FUSE is compiled in the kernel sources,
+ and die with instructions on making sure that you have the module from the
+ FUSE package (bug #155637).
*ntfs3g-0.20061115 (15 Nov 2006)
diff --git a/sys-fs/ntfs3g/files/digest-ntfs3g-0.20061115-r1 b/sys-fs/ntfs3g/files/digest-ntfs3g-0.20061115-r1
new file mode 100644
index 000000000000..e6e2f692e6d2
--- /dev/null
+++ b/sys-fs/ntfs3g/files/digest-ntfs3g-0.20061115-r1
@@ -0,0 +1,3 @@
+MD5 9a0c1a3d2a27deaeda6c39003e9f57c4 ntfs-3g-0.20061115-BETA.tgz 559073
+RMD160 01cc67da61b4405a7a136a7c429a58958b1d717b ntfs-3g-0.20061115-BETA.tgz 559073
+SHA256 07688def198062931fab960e3c44bfd083e109e5e15f4c9d429b824d7c83c2cb ntfs-3g-0.20061115-BETA.tgz 559073
diff --git a/sys-fs/ntfs3g/ntfs3g-0.20061115-r1.ebuild b/sys-fs/ntfs3g/ntfs3g-0.20061115-r1.ebuild
new file mode 100644
index 000000000000..e6ae6ec44749
--- /dev/null
+++ b/sys-fs/ntfs3g/ntfs3g-0.20061115-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-0.20061115-r1.ebuild,v 1.1 2006/11/20 16:43:02 chutzpah Exp $
+
+inherit linux-info
+
+MY_PN="${PN/3g/-3g}"
+MY_PV="${PV}-BETA"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Open source read-write NTFS driver that runs under FUSE"
+HOMEPAGE="http://www.ntfs-3g.org"
+SRC_URI="http://www.ntfs-3g.org/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=sys-fs/fuse-2.6.0"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+CONFIG_CHECK="!FUSE_FS"
+ERR=" ${BAD}*${NORMAL} "
+ERROR_FUSE_FS="For this version of ntfs-3g to work properly, you need to use the
+$ERR kernel module included in the package, not the kernel version. To do this
+$ERR remove FUSE from your kernel, recompile it then remerge FUSE.
+$ERR
+$ERR emerge -a1 sys-fs/fuse
+$ERR
+$ERR You will need to reboot if you had FUSE in your kernel, if it was a module, this
+$ERR should be enough:
+$ERR
+$ERR modprobe -r fuse
+$ERR modprobe fuse
+$ERR
+$ERR If either of these commands have an error, you will need to reboot.
+$ERR"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # default makefile calls ldconfig
+ sed -ie '/ldconfig$/ d' src/Makefile.*
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS ChangeLog CREDITS NEWS README
+}