summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2007-06-22 19:29:21 +0000
committerPatrick McLean <chutzpah@gentoo.org>2007-06-22 19:29:21 +0000
commit8ce7b9ef050c37bc8ae64d0f1862c37bf6cbe053 (patch)
tree81370d4c75648fbc762710138a6b6415aef73008 /sys-fs/ntfs3g
parentFix dts configuration, bug 182914 (diff)
downloadgentoo-2-8ce7b9ef050c37bc8ae64d0f1862c37bf6cbe053.tar.gz
gentoo-2-8ce7b9ef050c37bc8ae64d0f1862c37bf6cbe053.tar.bz2
gentoo-2-8ce7b9ef050c37bc8ae64d0f1862c37bf6cbe053.zip
Move *.a and *.la files to /usr (fixes bug #182922).
(Portage version: 2.1.3_rc4)
Diffstat (limited to 'sys-fs/ntfs3g')
-rw-r--r--sys-fs/ntfs3g/ChangeLog5
-rw-r--r--sys-fs/ntfs3g/ntfs3g-1.616.ebuild10
2 files changed, 13 insertions, 2 deletions
diff --git a/sys-fs/ntfs3g/ChangeLog b/sys-fs/ntfs3g/ChangeLog
index 3ed14cca7d66..a7466496faf5 100644
--- a/sys-fs/ntfs3g/ChangeLog
+++ b/sys-fs/ntfs3g/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-fs/ntfs3g
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.34 2007/06/22 15:20:20 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.35 2007/06/22 19:29:21 chutzpah Exp $
+
+ 22 Jun 2007; Patrick McLean <chutzpah@gentoo.org> ntfs3g-1.616.ebuild:
+ Move *.a and *.la files to /usr (fixes bug #182922).
*ntfs3g-1.616 (22 Jun 2007)
diff --git a/sys-fs/ntfs3g/ntfs3g-1.616.ebuild b/sys-fs/ntfs3g/ntfs3g-1.616.ebuild
index dca36f4e2349..76ca63f7d9c1 100644
--- a/sys-fs/ntfs3g/ntfs3g-1.616.ebuild
+++ b/sys-fs/ntfs3g/ntfs3g-1.616.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-1.616.ebuild,v 1.1 2007/06/22 15:20:20 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-1.616.ebuild,v 1.2 2007/06/22 19:29:21 chutzpah Exp $
+
+inherit multilib toolchain-funcs
MY_PN="${PN/3g/-3g}"
MY_P="${MY_PN}-${PV}"
@@ -27,8 +29,14 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" install || die "install failed"
+
+ dodir /usr/$(get_libdir)/
+ mv "${D}"/$(get_libdir)/*.{,l}a "${D}"/usr/$(get_libdir)/
+
dodoc AUTHORS ChangeLog CREDITS NEWS README
+ gen_usr_ldscript libntfs-3g.so
+
use suid && fperms u+s /usr/bin/${MY_PN}
}