summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2008-07-13 16:27:31 +0000
committerPatrick McLean <chutzpah@gentoo.org>2008-07-13 16:27:31 +0000
commit20d71fe7d0d10476faf4b78a65b8300cb96a25ef (patch)
tree2d432acdc15cb631d6be65ccd6cbd6d6834a5515 /sys-fs/ntfs3g
parentFix installation for nagios-3 (diff)
downloadgentoo-2-20d71fe7d0d10476faf4b78a65b8300cb96a25ef.tar.gz
gentoo-2-20d71fe7d0d10476faf4b78a65b8300cb96a25ef.tar.bz2
gentoo-2-20d71fe7d0d10476faf4b78a65b8300cb96a25ef.zip
Version bump.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-gentoo-r6 x86_64)
Diffstat (limited to 'sys-fs/ntfs3g')
-rw-r--r--sys-fs/ntfs3g/ChangeLog7
-rw-r--r--sys-fs/ntfs3g/ntfs3g-1.2712.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/sys-fs/ntfs3g/ChangeLog b/sys-fs/ntfs3g/ChangeLog
index 9ceb89692349..cb4b08d53418 100644
--- a/sys-fs/ntfs3g/ChangeLog
+++ b/sys-fs/ntfs3g/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/ntfs3g
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.67 2008/07/10 15:45:12 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.68 2008/07/13 16:27:31 chutzpah Exp $
+
+*ntfs3g-1.2712 (13 Jul 2008)
+
+ 13 Jul 2008; Patrick McLean <chutzpah@gentoo.org> +ntfs3g-1.2712.ebuild:
+ Version bump.
*ntfs3g-1.2531-r1 (10 Jul 2008)
diff --git a/sys-fs/ntfs3g/ntfs3g-1.2712.ebuild b/sys-fs/ntfs3g/ntfs3g-1.2712.ebuild
new file mode 100644
index 000000000000..14f9a17f9207
--- /dev/null
+++ b/sys-fs/ntfs3g/ntfs3g-1.2712.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-1.2712.ebuild,v 1.1 2008/07/13 16:27:31 chutzpah Exp $
+
+MY_PN="${PN/3g/-3g}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Open source read-write NTFS driver that runs under FUSE"
+HOMEPAGE="http://www.ntfs-3g.org"
+SRC_URI="http://www.ntfs-3g.org/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug hal suid"
+
+RDEPEND="hal? ( sys-apps/hal )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ --enable-ldscript \
+ --disable-ldconfig \
+ $(use_enable debug)
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ prepalldocs
+ dodoc AUTHORS ChangeLog CREDITS
+
+ use suid && fperms u+s "/bin/${MY_PN}"
+
+ if use hal; then
+ insinto /etc/hal/fdi/policy/
+ doins "${FILESDIR}/10-ntfs3g.fdi"
+ fi
+}
+
+pkg_postinst() {
+ if use suid; then
+ ewarn
+ ewarn "You have chosen to install ${PN} with the binary setuid root. This"
+ ewarn "means that if there any undetected vulnerabilities in the binary,"
+ ewarn "then local users may be able to gain root access on your machine."
+ ewarn
+ fi
+}