summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2007-01-01 23:12:27 +0000
committerPatrick McLean <chutzpah@gentoo.org>2007-01-01 23:12:27 +0000
commit18a473fca178e4352a3bb316591d3ef18663686a (patch)
treef921f0584d5d068646148bc253c81c625f7803c8 /sys-fs/ntfs3g
parentcheck for qt3support has to be done, even without jingle enabled (diff)
downloadgentoo-2-18a473fca178e4352a3bb316591d3ef18663686a.tar.gz
gentoo-2-18a473fca178e4352a3bb316591d3ef18663686a.tar.bz2
gentoo-2-18a473fca178e4352a3bb316591d3ef18663686a.zip
Version bump, newer version than mentioned in bump bug #159631. Clean out older version.
(Portage version: 2.1.2_rc4-r1)
Diffstat (limited to 'sys-fs/ntfs3g')
-rw-r--r--sys-fs/ntfs3g/ChangeLog11
-rw-r--r--sys-fs/ntfs3g/files/digest-ntfs3g-0.200701023
-rw-r--r--sys-fs/ntfs3g/ntfs3g-0.20070102.ebuild54
3 files changed, 66 insertions, 2 deletions
diff --git a/sys-fs/ntfs3g/ChangeLog b/sys-fs/ntfs3g/ChangeLog
index 3e1af5f61f53..cf350460258a 100644
--- a/sys-fs/ntfs3g/ChangeLog
+++ b/sys-fs/ntfs3g/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/ntfs3g
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.17 2006/12/13 15:22:32 chutzpah Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.18 2007/01/01 23:12:27 chutzpah Exp $
+
+*ntfs3g-0.20070102 (01 Jan 2007)
+
+ 01 Jan 2007; Patrick McLean <chutzpah@gentoo.org>
+ -ntfs3g-0.20061115-r1.ebuild, +ntfs3g-0.20070102.ebuild:
+ Version bump, newer version than mentioned in bump bug #159631. Clean out
+ older version.
*ntfs3g-0.20061212 (13 Dec 2006)
diff --git a/sys-fs/ntfs3g/files/digest-ntfs3g-0.20070102 b/sys-fs/ntfs3g/files/digest-ntfs3g-0.20070102
new file mode 100644
index 000000000000..2f04a4fb5403
--- /dev/null
+++ b/sys-fs/ntfs3g/files/digest-ntfs3g-0.20070102
@@ -0,0 +1,3 @@
+MD5 3f03bae2ef34c7adb7a3aece6c921f94 ntfs-3g-0.20070102-BETA.tgz 561276
+RMD160 54e5504ebe624e180e9aadf8d1826e5844e46ed8 ntfs-3g-0.20070102-BETA.tgz 561276
+SHA256 28f1fc26257802055275976dd9c606ac913d3caedd3c0a7b28538d234da8fee6 ntfs-3g-0.20070102-BETA.tgz 561276
diff --git a/sys-fs/ntfs3g/ntfs3g-0.20070102.ebuild b/sys-fs/ntfs3g/ntfs3g-0.20070102.ebuild
new file mode 100644
index 000000000000..798be406b37a
--- /dev/null
+++ b/sys-fs/ntfs3g/ntfs3g-0.20070102.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-0.20070102.ebuild,v 1.1 2007/01/01 23:12:27 chutzpah Exp $
+
+inherit linux-info
+
+MY_PN="${PN/3g/-3g}"
+MY_PV="${PV}-BETA"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Open source read-write NTFS driver that runs under FUSE"
+HOMEPAGE="http://www.ntfs-3g.org"
+SRC_URI="http://www.ntfs-3g.org/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=sys-fs/fuse-2.6.0"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+CONFIG_CHECK="!FUSE_FS"
+ERR=" ${BAD}*${NORMAL} "
+ERROR_FUSE_FS="For this version of ntfs-3g to work properly, you need to use the
+$ERR kernel module included in the package, not the kernel version. To do this
+$ERR remove FUSE from your kernel, recompile it then remerge FUSE.
+$ERR
+$ERR emerge -a1 sys-fs/fuse
+$ERR
+$ERR You will need to reboot if you had FUSE in your kernel, if it was a module, this
+$ERR should be enough:
+$ERR
+$ERR modprobe -r fuse
+$ERR modprobe fuse
+$ERR
+$ERR If either of these commands have an error, you will need to reboot.
+$ERR"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # default makefile calls ldconfig
+ sed -ie '/ldconfig$/ d' src/Makefile.*
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS ChangeLog CREDITS NEWS README
+}