summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2009-08-21 20:49:53 +0000
committerPatrick McLean <chutzpah@gentoo.org>2009-08-21 20:49:53 +0000
commitb96632c4ad20971791fb72adbdd769765094c834 (patch)
tree801e6b85e8325251fb0cb47b5adbd24094b78bd0 /sys-fs/ntfs3g/ntfs3g-2009.4.4.ebuild
parentremove old (diff)
downloadgentoo-2-b96632c4ad20971791fb72adbdd769765094c834.tar.gz
gentoo-2-b96632c4ad20971791fb72adbdd769765094c834.tar.bz2
gentoo-2-b96632c4ad20971791fb72adbdd769765094c834.zip
Migrate to EAPI=2. Add a default-on USE flag for external FUSE, as the internal FUSE must be used for unpriviliged mounting to work (bug #282222).
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/ntfs3g/ntfs3g-2009.4.4.ebuild')
-rw-r--r--sys-fs/ntfs3g/ntfs3g-2009.4.4.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/sys-fs/ntfs3g/ntfs3g-2009.4.4.ebuild b/sys-fs/ntfs3g/ntfs3g-2009.4.4.ebuild
index 65b07fd3d687..25d05be4173f 100644
--- a/sys-fs/ntfs3g/ntfs3g-2009.4.4.ebuild
+++ b/sys-fs/ntfs3g/ntfs3g-2009.4.4.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-2009.4.4.ebuild,v 1.2 2009/08/21 15:49:21 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-2009.4.4.ebuild,v 1.3 2009/08/21 20:49:53 chutzpah Exp $
+
+EAPI=2
MY_PN="${PN/3g/-3g}"
MY_P="${MY_PN}-${PV}"
@@ -12,7 +14,7 @@ SRC_URI="http://www.ntfs-3g.org/${MY_P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="debug hal suid"
+IUSE="debug hal suid +external-fuse"
RDEPEND=">=sys-fs/fuse-2.6.0
hal? ( sys-apps/hal )"
@@ -20,14 +22,13 @@ DEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_P}"
-src_compile() {
+src_configure() {
econf \
--docdir="/usr/share/doc/${PF}" \
--enable-ldscript \
--disable-ldconfig \
- --with-fuse=external \
+ --with-fuse=$(use external-fuse && echo external || echo internal) \
$(use_enable debug)
- emake || die "emake failed"
}
src_install() {