summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-02-08 00:46:26 +0000
committerMike Frysinger <vapier@gentoo.org>2006-02-08 00:46:26 +0000
commitee85ceafdecfca8599bc4125f2ecd99c382a0813 (patch)
tree6f3df11a1d0e6ab7de63a140184a09a54dca36f5 /sys-fs/multipath-tools
parentVersion bump from upstream (diff)
downloadgentoo-2-ee85ceafdecfca8599bc4125f2ecd99c382a0813.tar.gz
gentoo-2-ee85ceafdecfca8599bc4125f2ecd99c382a0813.tar.bz2
gentoo-2-ee85ceafdecfca8599bc4125f2ecd99c382a0813.zip
touchups
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'sys-fs/multipath-tools')
-rw-r--r--sys-fs/multipath-tools/metadata.xml3
-rw-r--r--sys-fs/multipath-tools/multipath-tools-0.4.6.1.ebuild21
2 files changed, 9 insertions, 15 deletions
diff --git a/sys-fs/multipath-tools/metadata.xml b/sys-fs/multipath-tools/metadata.xml
index 2c427493585d..96a2d586367d 100644
--- a/sys-fs/multipath-tools/metadata.xml
+++ b/sys-fs/multipath-tools/metadata.xml
@@ -2,7 +2,4 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>base-system</herd>
-<maintainer>
- <email>base-system@gentoo.org</email>
-</maintainer>
</pkgmetadata>
diff --git a/sys-fs/multipath-tools/multipath-tools-0.4.6.1.ebuild b/sys-fs/multipath-tools/multipath-tools-0.4.6.1.ebuild
index d668c9e0ab8e..62468728d0e5 100644
--- a/sys-fs/multipath-tools/multipath-tools-0.4.6.1.ebuild
+++ b/sys-fs/multipath-tools/multipath-tools-0.4.6.1.ebuild
@@ -1,40 +1,37 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/multipath-tools/multipath-tools-0.4.6.1.ebuild,v 1.1 2006/01/26 21:41:10 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/multipath-tools/multipath-tools-0.4.6.1.ebuild,v 1.2 2006/02/08 00:46:26 vapier Exp $
inherit toolchain-funcs
-DESCRIPTION="Device mapper target autoconfig."
+DESCRIPTION="Device mapper target autoconfig"
HOMEPAGE="http://christophe.varoqui.free.fr/wiki/wakka.php?wiki=Home"
SRC_URI="http://christophe.varoqui.free.fr/${PN}/${P}.tar.bz2"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~amd64"
-
IUSE=""
RDEPEND=">=sys-fs/device-mapper-1.00.19
sys-fs/udev
sys-fs/sysfsutils"
-
DEPEND="${RDEPEND}"
src_unpack() {
- unpack ${A}; cd ${S}
- sed -i -e 's:^bindir.*:bindir = /usr/sbin:' \
- ${S}/multipathd/Makefile
- sed -i -e 's:rules.d/.*:rules.d/40-multipath.rules:' \
- ${S}/multipath/Makefile
+ unpack ${A}
+ cd "${S}"
+ sed -i -e 's:^bindir.*:bindir = /usr/sbin:' multipathd/Makefile
+ sed -i -e 's:rules.d/.*:rules.d/40-multipath.rules:' multipath/Makefile
}
src_compile() {
- emake -j1 \
- CC=$(tc-getCC) || die "emake failed"
+ emake -j1 CC=$(tc-getCC) || die "emake failed"
}
src_install() {
dodir /sbin /usr/share/man/man8
- make DESTDIR=${D} install || die "install failed"
+ make DESTDIR="${D}" install || die "install failed"
insinto /etc
newins ${S}/multipath.conf.annotated multipath.conf