summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2006-05-22 10:16:54 +0000
committerMartin Schlemmer <azarah@gentoo.org>2006-05-22 10:16:54 +0000
commit1ea7381c68a1210f0b4797695ca79d9a97596fbe (patch)
treeea8f2ebc4644975fd5a204d42f416bed6e6c1d06 /sys-fs/multipath-tools
parentremoved old version. added patch to fix compilation with gcc-4.1 as per bug #... (diff)
downloadgentoo-2-1ea7381c68a1210f0b4797695ca79d9a97596fbe.tar.gz
gentoo-2-1ea7381c68a1210f0b4797695ca79d9a97596fbe.tar.bz2
gentoo-2-1ea7381c68a1210f0b4797695ca79d9a97596fbe.zip
Bump version to work with latest sysfsutils.
(Portage version: 2.1_rc1-r4)
Diffstat (limited to 'sys-fs/multipath-tools')
-rw-r--r--sys-fs/multipath-tools/ChangeLog8
-rw-r--r--sys-fs/multipath-tools/files/digest-multipath-tools-0.4.73
-rw-r--r--sys-fs/multipath-tools/multipath-tools-0.4.7.ebuild54
3 files changed, 64 insertions, 1 deletions
diff --git a/sys-fs/multipath-tools/ChangeLog b/sys-fs/multipath-tools/ChangeLog
index 1a00b86ecae3..a2e38c6ad2d1 100644
--- a/sys-fs/multipath-tools/ChangeLog
+++ b/sys-fs/multipath-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/multipath-tools
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/multipath-tools/ChangeLog,v 1.11 2006/04/27 23:08:39 antarus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/multipath-tools/ChangeLog,v 1.12 2006/05/22 10:16:54 azarah Exp $
+
+*multipath-tools-0.4.7 (22 May 2006)
+
+ 22 May 2006; Martin Schlemmer <azarah@gentoo.org>
+ +multipath-tools-0.4.7.ebuild:
+ Bump version to work with latest sysfsutils.
27 Apr 2006; Alec Warner <antarus@gentoo.org>
files/digest-multipath-tools-0.4.6.1, Manifest:
diff --git a/sys-fs/multipath-tools/files/digest-multipath-tools-0.4.7 b/sys-fs/multipath-tools/files/digest-multipath-tools-0.4.7
new file mode 100644
index 000000000000..57225a5b6b98
--- /dev/null
+++ b/sys-fs/multipath-tools/files/digest-multipath-tools-0.4.7
@@ -0,0 +1,3 @@
+MD5 0a7574f0dd85f2b50f6aff91d83633ad multipath-tools-0.4.7.tar.bz2 139312
+RMD160 b9ecd84e01e03fe631e9ee9953ea7dbadb04c01d multipath-tools-0.4.7.tar.bz2 139312
+SHA256 1b48684c9ce956bb2294640a92f1da8ddea4e991e4d7b974697660de5e44a9d7 multipath-tools-0.4.7.tar.bz2 139312
diff --git a/sys-fs/multipath-tools/multipath-tools-0.4.7.ebuild b/sys-fs/multipath-tools/multipath-tools-0.4.7.ebuild
new file mode 100644
index 000000000000..81aedc0bee5a
--- /dev/null
+++ b/sys-fs/multipath-tools/multipath-tools-0.4.7.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/multipath-tools/multipath-tools-0.4.7.ebuild,v 1.1 2006/05/22 10:16:54 azarah Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Device mapper target autoconfig"
+HOMEPAGE="http://christophe.varoqui.free.fr/wiki/wakka.php?wiki=Home"
+SRC_URI="http://christophe.varoqui.free.fr/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+RDEPEND=">=sys-fs/device-mapper-1.00.19
+ sys-fs/udev
+ sys-fs/sysfsutils"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e 's:^bindir.*:bindir = /usr/sbin:' multipathd/Makefile
+ sed -i -e 's:rules.d/.*:rules.d/40-multipath.rules:' multipath/Makefile
+}
+
+src_compile() {
+ emake -j1 CC=$(tc-getCC) || die "emake failed"
+}
+
+src_install() {
+ dodir /sbin /usr/share/man/man8
+ make DESTDIR="${D}" install || die "install failed"
+
+ insinto /etc
+ newins ${S}/multipath.conf.annotated multipath.conf
+ fperms 644 /etc/udev/rules.d/40-multipath.rules
+ newinitd ${FILESDIR}/rc-multipathd multipathd
+
+ # The dev.d script was previously wrong and is now removed (the udev rules
+ # file does the job instead), but it won't be removed from live systems due
+ # to cfgprotect.
+ # This should help out a little...
+ if [[ -e "${ROOT}"/etc/dev.d/block/multipath.dev ]] ; then
+ mkdir -p "${D}"/etc/dev.d/block
+ echo "# Please delete this file. It is obsoleted by /etc/udev/rules.d/40-multipath.rules" \
+ > "${D}"/etc/dev.d/block/multipath.dev
+ fi
+
+ dodoc AUTHOR COPYING ChangeLog FAQ README TODO
+ docinto dmadm; dodoc README
+ docinto kpartx; dodoc ChangeLog README
+}