summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-09-24 02:11:19 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-09-24 02:11:19 +0000
commit96604068b15adc21f76cfadf72793d88298f99b1 (patch)
tree12dd41e40edb46c21ebb69f32c5cc67a8efdec04 /sys-fs/mtd-utils
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-96604068b15adc21f76cfadf72793d88298f99b1.tar.gz
gentoo-2-96604068b15adc21f76cfadf72793d88298f99b1.tar.bz2
gentoo-2-96604068b15adc21f76cfadf72793d88298f99b1.zip
Fix inverted xattr logic per bug #238435 and also parallel build.
(Portage version: 2.2_rc8/cvs/Linux 2.6.27-rc1-10246-gca5de40 x86_64)
Diffstat (limited to 'sys-fs/mtd-utils')
-rw-r--r--sys-fs/mtd-utils/ChangeLog6
-rw-r--r--sys-fs/mtd-utils/files/mtd-utils-fixup.patch32
-rw-r--r--sys-fs/mtd-utils/mtd-utils-20080907.ebuild7
3 files changed, 41 insertions, 4 deletions
diff --git a/sys-fs/mtd-utils/ChangeLog b/sys-fs/mtd-utils/ChangeLog
index cc953c8ee360..6bd5a8741c0f 100644
--- a/sys-fs/mtd-utils/ChangeLog
+++ b/sys-fs/mtd-utils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/mtd-utils
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/mtd-utils/ChangeLog,v 1.15 2008/09/21 07:02:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/mtd-utils/ChangeLog,v 1.16 2008/09/24 02:11:18 robbat2 Exp $
+
+ 24 Sep 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +files/mtd-utils-fixup.patch, mtd-utils-20080907.ebuild:
+ Fix inverted xattr logic per bug #238435 and also parallel build.
*mtd-utils-20080907 (21 Sep 2008)
diff --git a/sys-fs/mtd-utils/files/mtd-utils-fixup.patch b/sys-fs/mtd-utils/files/mtd-utils-fixup.patch
new file mode 100644
index 000000000000..08991500a462
--- /dev/null
+++ b/sys-fs/mtd-utils/files/mtd-utils-fixup.patch
@@ -0,0 +1,32 @@
+Fix up the parallel building. Without this fix, each instance of the NTARGETS
+will try to build the libraries seperately, and on a suitably fast machine this
+can lead to overwriting. Add a specific instance to build the libraries first.
+
+Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
+
+diff -Nuar mtd-utils.orig/ubi-utils/Makefile mtd-utils/ubi-utils/Makefile
+--- mtd-utils.orig/ubi-utils/Makefile 2008-09-23 18:51:00.129193374 -0700
++++ mtd-utils/ubi-utils/Makefile 2008-09-23 18:54:04.097290355 -0700
+@@ -34,7 +34,10 @@
+ IGNORE=${wildcard .*.c.dep}
+ -include ${IGNORE}
+
+-$(NTARGETS):
++nlibs:
++ $(MAKE) -C new-utils libs
++
++$(NTARGETS): nlibs
+ $(MAKE) -C new-utils $@
+ mv new-utils/$@ $@
+
+diff -Nuar mtd-utils.orig/ubi-utils/new-utils/Makefile mtd-utils/ubi-utils/new-utils/Makefile
+--- mtd-utils.orig/ubi-utils/new-utils/Makefile 2008-09-23 18:51:00.179204851 -0700
++++ mtd-utils/ubi-utils/new-utils/Makefile 2008-09-23 18:53:32.513881545 -0700
+@@ -19,6 +19,7 @@
+ vpath %.c src
+
+ all: $(UTILS)
++libs: $(addsuffix .a,$(LIBS))
+
+ # The below cancels existing implicite rule to make programs from .c files,
+ # in order to force make using our rule defined below
diff --git a/sys-fs/mtd-utils/mtd-utils-20080907.ebuild b/sys-fs/mtd-utils/mtd-utils-20080907.ebuild
index 7e9c3510d7d6..a39d8cbe1fd8 100644
--- a/sys-fs/mtd-utils/mtd-utils-20080907.ebuild
+++ b/sys-fs/mtd-utils/mtd-utils-20080907.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/mtd-utils/mtd-utils-20080907.ebuild,v 1.1 2008/09/21 07:02:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/mtd-utils/mtd-utils-20080907.ebuild,v 1.2 2008/09/24 02:11:18 robbat2 Exp $
-inherit toolchain-funcs
+inherit toolchain-funcs eutils
# Git ID for the snapshot
MY_PV="${PV}-41c53b6f2d756ae995c3ffa4455576515427c5e0"
@@ -29,13 +29,14 @@ src_unpack() {
unpack ${A}
cd "${S}"
sed -i 's:-Werror::' $(find . -name Makefile)
+ epatch "${FILESDIR}"/mtd-utils-fixup.patch
}
src_compile() {
emake \
CC="$(tc-getCC)" \
OPTFLAGS="${CFLAGS}" \
- $(use xattr && echo WITHOUT_XATTR=1) \
+ $(use xattr || echo WITHOUT_XATTR=1) \
|| die
}