summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-08-02 06:59:02 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-08-02 06:59:02 +0000
commite51c979d32e4564dfac853fd49b78f4e5f93c070 (patch)
tree8fc4711b2271a3f564dae76a9cd8f4f402a89ba2 /sys-fs/lvm2
parentversion bump thanks to slepnoga (diff)
downloadgentoo-2-e51c979d32e4564dfac853fd49b78f4e5f93c070.tar.gz
gentoo-2-e51c979d32e4564dfac853fd49b78f4e5f93c070.tar.bz2
gentoo-2-e51c979d32e4564dfac853fd49b78f4e5f93c070.zip
More systemd related fixups
(Portage version: 2.2.0_alpha191/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'sys-fs/lvm2')
-rw-r--r--sys-fs/lvm2/ChangeLog5
-rw-r--r--sys-fs/lvm2/lvm2-2.02.99.ebuild28
2 files changed, 13 insertions, 20 deletions
diff --git a/sys-fs/lvm2/ChangeLog b/sys-fs/lvm2/ChangeLog
index b501b6f199bd..215bc3fa2ee1 100644
--- a/sys-fs/lvm2/ChangeLog
+++ b/sys-fs/lvm2/ChangeLog
@@ -1,9 +1,10 @@
# ChangeLog for sys-fs/lvm2
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/ChangeLog,v 1.307 2013/08/02 06:46:03 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/ChangeLog,v 1.308 2013/08/02 06:59:02 ssuominen Exp $
02 Aug 2013; Samuli Suominen <ssuominen@gentoo.org> lvm2-2.02.99.ebuild:
- Pass --with-default-pid-dir=/run wrt #453594
+ Pass --with-default-pid-dir=/run and build lvm2_activation_generator_systemd
+ _red_hat wrt #453594 by Alexander Tsoy
01 Aug 2013; Samuli Suominen <ssuominen@gentoo.org> -lvm2-2.02.95-r4.ebuild,
-lvm2-2.02.97.ebuild:
diff --git a/sys-fs/lvm2/lvm2-2.02.99.ebuild b/sys-fs/lvm2/lvm2-2.02.99.ebuild
index f1a8ff5a5762..4251958dd490 100644
--- a/sys-fs/lvm2/lvm2-2.02.99.ebuild
+++ b/sys-fs/lvm2/lvm2-2.02.99.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/lvm2-2.02.99.ebuild,v 1.2 2013/08/02 06:46:03 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/lvm2-2.02.99.ebuild,v 1.3 2013/08/02 06:59:02 ssuominen Exp $
EAPI=5
inherit eutils multilib toolchain-funcs autotools linux-info udev systemd
@@ -19,7 +19,7 @@ IUSE="readline static static-libs clvm cman +lvm1 selinux +udev +thin"
DEPEND_COMMON="readline? ( sys-libs/readline )
clvm? ( =sys-cluster/libdlm-3*
cman? ( =sys-cluster/cman-3* ) )
- udev? ( virtual/udev[static-libs?] )"
+ udev? ( >=virtual/udev-200[static-libs?] )"
# /run is now required for locking during early boot. /var cannot be assumed to
# be available.
RDEPEND="${DEPEND_COMMON}
@@ -164,13 +164,12 @@ src_configure() {
}
src_compile() {
- einfo "Doing symlinks"
pushd include >/dev/null
emake
popd >/dev/null
- einfo "Starting main build"
emake AR="$(tc-getAR)"
+ emake CC="$(tc-getCC)" -C scripts lvm2_activation_generator_systemd_red_hat
}
src_install() {
@@ -222,24 +221,17 @@ src_install() {
sed -i \
-e "s|/lib/rcscripts/|/$(get_libdir)/rcscripts/|" \
"${ED}"/etc/init.d/* || die
-
- elog "USE flag nocman is deprecated and replaced"
- elog "with the cman USE flag."
- elog ""
- elog "USE flags clvm and cman are masked"
- elog "by default and need to be unmasked to be used"
- elog ""
- elog "If you are using genkernel and root-on-LVM, rebuild the initramfs."
}
pkg_postinst() {
- elog "lvm volumes are no longer automatically created for"
- elog "baselayout-2 users. If you are using baselayout-2, be sure to"
- elog "run: # rc-update add lvm boot"
- elog "Do NOT add it if you are still using baselayout-1."
+ ewarn "Make sure the \"lvm\" init script is in the runlevels:"
+ ewarn "# rc-update add lvm boot"
+ ewarn
+ ewarn "Make sure to enable lvmetad in /etc/lvm/lvm.conf if you want"
+ ewarn "to enable lvm autoactivation and metadata caching."
}
src_test() {
- einfo "Testcases disabled because of device-node mucking"
- einfo "If you want them, compile the package and see ${S}/tests"
+ einfo "Tests are disabled because of device-node mucking, if you want to"
+ einfo "run tests, compile the package and see ${S}/tests"
}