summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2014-02-04 02:46:32 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2014-02-04 02:46:32 +0000
commit489428f23783cf9d1f2818979245478710e85eba (patch)
tree1923ada1d38d95a0cd3eb0fe1e682c5ee44ab5cb /sys-fs/lvm2
parentRemove old. (diff)
downloadgentoo-2-489428f23783cf9d1f2818979245478710e85eba.tar.gz
gentoo-2-489428f23783cf9d1f2818979245478710e85eba.tar.bz2
gentoo-2-489428f23783cf9d1f2818979245478710e85eba.zip
Bug #448354: Fix cross-compile with thin.
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sys-fs/lvm2')
-rw-r--r--sys-fs/lvm2/ChangeLog5
-rw-r--r--sys-fs/lvm2/lvm2-2.02.105-r2.ebuild11
2 files changed, 13 insertions, 3 deletions
diff --git a/sys-fs/lvm2/ChangeLog b/sys-fs/lvm2/ChangeLog
index 27d321a405f4..3a065c5dc31f 100644
--- a/sys-fs/lvm2/ChangeLog
+++ b/sys-fs/lvm2/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-fs/lvm2
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/ChangeLog,v 1.345 2014/02/04 02:43:14 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/ChangeLog,v 1.346 2014/02/04 02:46:32 robbat2 Exp $
+
+ 04 Feb 2014; Robin H. Johnson <robbat2@gentoo.org> lvm2-2.02.105-r2.ebuild:
+ Bug #448354: Fix cross-compile with thin.
04 Feb 2014; Robin H. Johnson <robbat2@gentoo.org>
files/lvm2-2.02.105-pthread-pkgconfig.patch:
diff --git a/sys-fs/lvm2/lvm2-2.02.105-r2.ebuild b/sys-fs/lvm2/lvm2-2.02.105-r2.ebuild
index ae2c6f6a6500..2bb2d15a6e59 100644
--- a/sys-fs/lvm2/lvm2-2.02.105-r2.ebuild
+++ b/sys-fs/lvm2/lvm2-2.02.105-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/lvm2-2.02.105-r2.ebuild,v 1.4 2014/02/04 02:27:45 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/lvm2-2.02.105-r2.ebuild,v 1.5 2014/02/04 02:46:32 robbat2 Exp $
EAPI=5
inherit autotools eutils linux-info multilib systemd toolchain-funcs udev flag-o-matic
@@ -118,7 +118,14 @@ src_configure() {
# so we cannot disable them
myconf="${myconf} --with-mirrors=${dmbuildmode}"
myconf="${myconf} --with-snapshots=${dmbuildmode}"
- myconf="${myconf} --with-thin=$(use thin && echo internal || echo none)"
+ if use thin; then
+ myconf="${myconf} --with-thin=internal"
+ myconf="${myconf} --with-thin-check=${EPREFIX}/sbin/thin_check"
+ myconf="${myconf} --with-thin-dump=${EPREFIX}/sbin/thin_dump"
+ myconf="${myconf} --with-thin-repair=${EPREFIX}/sbin/thin_repair"
+ else
+ myconf="${myconf} --with-thin=none"
+ fi
if use lvm1; then
myconf="${myconf} --with-lvm1=${buildmode}"