summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Cox <steel300@gentoo.org>2004-04-17 04:29:21 +0000
committerJason Cox <steel300@gentoo.org>2004-04-17 04:29:21 +0000
commit5c219849c295efbf34ba4978091e2a3fd8747d61 (patch)
treeed965fd4aac4c5d65a0a85c5a6b4eb8202369d32 /sys-fs/lufs
parentFix build issue (Manifest recommit) (diff)
downloadgentoo-2-5c219849c295efbf34ba4978091e2a3fd8747d61.tar.gz
gentoo-2-5c219849c295efbf34ba4978091e2a3fd8747d61.tar.bz2
gentoo-2-5c219849c295efbf34ba4978091e2a3fd8747d61.zip
Fix lufs build issue.
Diffstat (limited to 'sys-fs/lufs')
-rw-r--r--sys-fs/lufs/ChangeLog5
-rw-r--r--sys-fs/lufs/lufs-0.9.7-r1.ebuild60
2 files changed, 38 insertions, 27 deletions
diff --git a/sys-fs/lufs/ChangeLog b/sys-fs/lufs/ChangeLog
index 1da443668994..dbaf2eddb40e 100644
--- a/sys-fs/lufs/ChangeLog
+++ b/sys-fs/lufs/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-fs/lufs
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/lufs/ChangeLog,v 1.5 2004/04/17 04:16:35 steel300 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lufs/ChangeLog,v 1.6 2004/04/17 04:29:21 steel300 Exp $
+
+ 16 Apr 2004; <coxj@gentoo.org> lufs-0.9.7-r1.ebuild:
+ Fix lufs once and for all.
16 Apr 2004; <coxj@gentoo.org> lufs-0.9.7-r1.ebuild:
Fix for build on amd64
diff --git a/sys-fs/lufs/lufs-0.9.7-r1.ebuild b/sys-fs/lufs/lufs-0.9.7-r1.ebuild
index 55f0635fc92d..f5a831e2dfce 100644
--- a/sys-fs/lufs/lufs-0.9.7-r1.ebuild
+++ b/sys-fs/lufs/lufs-0.9.7-r1.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/lufs/lufs-0.9.7-r1.ebuild,v 1.2 2004/04/17 04:16:35 steel300 Exp $
-
-inherit eutils
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lufs/lufs-0.9.7-r1.ebuild,v 1.3 2004/04/17 04:29:21 steel300 Exp $
S="${WORKDIR}/${P}"
DESCRIPTION="User-mode filesystem implementation"
@@ -14,51 +12,63 @@ RDEPEND=""
KEYWORDS="~x86 ~amd64"
SLOT="0"
IUSE="lufsusermount"
+RESTRICT="nouserpriv"
src_unpack() {
- unpack ${A} ; cd ${S}
-
- epatch ${FILESDIR}/${P}-fPIC.patch
+ unpack ${A}
# Fix some sandbox failures
- sed -i -e's/install-data-hook//' \
- lufsd/Makefile.in util/Makefile.in kernel/Linux/2.4/Makefile.in
+ cd ${S}/lufsd
+ mv Makefile.in Makefile.in.orig
+ sed -e 's/install-exec-hook//' Makefile.in.orig > Makefile.in || die
+
+ cd ${S}/util
+ mv Makefile.in Makefile.in.orig
+ sed -e 's/install-exec-hook//' Makefile.in.orig > Makefile.in || die
+
+ cd ${S}/kernel/Linux/2.4
+ mv Makefile.in Makefile.in.orig
+ sed -e 's/install-data-hook//' Makefile.in.orig > Makefile.in || die
# Fix GCC 3.3.2 build failure (see also
# http://gcc.gnu.org/bugzilla/show_bug.cgi?id=13192)
+ cd ${S}
epatch ${FILESDIR}/gentoo-gcc332fix-${PV}.patch
}
-src_compile() {
- local myconf
-
- [ "$ARCH" == "x86" ] && export ARCH="i386"
- [ "$ARCH" == "amd64" ] && export ARCH="x86_64"
- econf ${myconf} || die
-
- emake || die
- [ "$ARCH" == "i386" ] && export ARCH="x86"
- [ "$ARCH" == "x86_64" ] && export ARCH="amd64"
+src_compile () {
+ econf || die
+ [ -d /lib/modules/$(uname -r)/build ] || die "Cannot find kernel sources at /lib/modules/$(uname -r)/build.
+This ebuild will only compile against the running kernel."
+ # In case package dereferences.
+ addwrite $(readlink -f /lib/modules/$(uname -r)/build) || die "Could not enable write access to kernel sources. Check your sandbox settings."
+ addwrite /lib/modules/$(uname -r)/build || die "Could not enable write access to kernel sources. Check your sandbox settings."
+ env -u ARCH emake || die
}
src_install () {
dodoc AUTHORS COPYING ChangeLog Contributors INSTALL \
NEWS README THANKS TODO
dohtml docs/lufs.html
- make DESTDIR=${D} install
+ # In case package dereferences.
+ addwrite $(readlink -f /lib/modules/$(uname -r)/build)
+ addwrite /lib/modules/$(uname -r)/build
+ env -u ARCH make DESTDIR=${D} install
dosym /usr/bin/auto.sshfs /etc/auto.sshfs
dosym /usr/bin/auto.ftpfs /etc/auto.ftpfs
dodir /sbin
dosym /usr/bin/lufsd /sbin/mount.lufs
use lufsusermount && chmod +s ${D}/usr/bin/lufs{mnt,umount}
+ if expr match $(uname -r) 2.6; then
+ insinto /lib/modules/$(uname -r)/kernel/fs/lufs
+ doins kernel/Linux/2.6/lufs.ko
+ fi
}
pkg_postinst() {
- if [ ! "$( egrep "^CONFIG_LUFS_FS=[ym]" /usr/src/linux-${KV}/.config )" ]; then
- /usr/sbin/update-modules
- fi
-
+ depmod
+ /usr/sbin/update-modules
if ! use lufsusermount
then
einfo If you want regular users to be able to mount lufs filesystems,
@@ -70,7 +80,5 @@ pkg_postinst() {
}
pkg_postrm() {
- if [ ! "$( egrep "^CONFIG_LUFS_FS=[ym]" /usr/src/linux-${KV}/.config )" ]; then
- /sbin/modprobe -r lufs
- fi
+ /sbin/modprobe -r lufs
}