summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-01-16 13:44:23 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-01-16 13:44:23 +0000
commitf0a49b2cb1f2469157ac378951528d2d4d1008c0 (patch)
tree2c619bf024c2e8c816f58872563addcce5b80d40 /sys-fs/lessfs
parentMask lessfs-1.3.1 (diff)
downloadgentoo-2-f0a49b2cb1f2469157ac378951528d2d4d1008c0.tar.gz
gentoo-2-f0a49b2cb1f2469157ac378951528d2d4d1008c0.tar.bz2
gentoo-2-f0a49b2cb1f2469157ac378951528d2d4d1008c0.zip
Version bump but will remain masked for a while
(Portage version: 2.1.9.31/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/lessfs')
-rw-r--r--sys-fs/lessfs/ChangeLog14
-rw-r--r--sys-fs/lessfs/files/lessfs-implicit-declaration.patch29
-rw-r--r--sys-fs/lessfs/files/lessfs.confd11
-rw-r--r--sys-fs/lessfs/files/lessfs.initd22
-rw-r--r--sys-fs/lessfs/lessfs-1.3.1.ebuild53
5 files changed, 98 insertions, 31 deletions
diff --git a/sys-fs/lessfs/ChangeLog b/sys-fs/lessfs/ChangeLog
index c852f3155928..266082787eee 100644
--- a/sys-fs/lessfs/ChangeLog
+++ b/sys-fs/lessfs/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sys-fs/lessfs
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/lessfs/ChangeLog,v 1.24 2010/12/23 22:02:16 hwoarang Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lessfs/ChangeLog,v 1.25 2011/01/16 13:44:23 hwoarang Exp $
+
+ 16 Jan 2011; Markos Chandras <hwoarang@gentoo.org> +lessfs-1.3.1.ebuild,
+ +files/lessfs.confd, +files/lessfs.initd,
+ -files/lessfs-implicit-declaration.patch:
+ Version bump but will remain masked for a while
+
+*lessfs-1.3.1 (16 Jan 2011)
+
+ 16 Jan 2011; Markos Chandras <hwoarang@gentoo.org> +lessfs-1.3.1.ebuild:
+ Version bump
*lessfs-1.2.2.6 (23 Dec 2010)
diff --git a/sys-fs/lessfs/files/lessfs-implicit-declaration.patch b/sys-fs/lessfs/files/lessfs-implicit-declaration.patch
deleted file mode 100644
index 7454f7c25f8b..000000000000
--- a/sys-fs/lessfs/files/lessfs-implicit-declaration.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-Index: lessfs-1.1.9.10/file_io.c
-===================================================================
---- lessfs-1.1.9.10.orig/file_io.c
-+++ lessfs-1.1.9.10/file_io.c
-@@ -86,6 +86,8 @@ extern unsigned int dbu_qcount;
-
- #define die_dataerr(f...) { LFATAL(f); exit(EXIT_DATAERR); }
-
-+// missing declarations
-+void write_trunc_todolist(struct truncate_thread_data *trunc_data);
- INUSE *file_get_inuse(unsigned char *stiger)
- {
- INUSE *inuse;
-Index: lessfs-1.1.9.10/lessfs.c
-===================================================================
---- lessfs-1.1.9.10.orig/lessfs.c
-+++ lessfs-1.1.9.10/lessfs.c
-@@ -84,6 +84,11 @@
-
- #include "commons.h"
-
-+//missing declarations
-+void invalidate_p2i(char *filename);
-+int send_backlog();
-+void restart_truncation();
-+
- void segvExit()
- {
- LFATAL("Exit caused by segfault!, exitting\n");
diff --git a/sys-fs/lessfs/files/lessfs.confd b/sys-fs/lessfs/files/lessfs.confd
new file mode 100644
index 000000000000..271a93996d06
--- /dev/null
+++ b/sys-fs/lessfs/files/lessfs.confd
@@ -0,0 +1,11 @@
+# Gentoo configuration file for lessfs
+
+# CONFIG: Full path to your configuration file
+CONFIG="/etc/lessfs.cfg"
+
+# MOUNTPOINT: Destination mountpoint
+MOUNTPOINT="/fuse"
+
+# MKLESSFS: Binary to create lessfs filesystems
+# You really don't want to change that
+MKLESSFS="/usr/bin/mklessfs"
diff --git a/sys-fs/lessfs/files/lessfs.initd b/sys-fs/lessfs/files/lessfs.initd
new file mode 100644
index 000000000000..15b8e3097a0d
--- /dev/null
+++ b/sys-fs/lessfs/files/lessfs.initd
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lessfs/files/lessfs.initd,v 1.1 2011/01/16 13:44:23 hwoarang Exp $
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting lessfs"
+ start-stop-daemon --start --exec /usr/bin/lessfs \
+ --pidfile /var/run/lessfs.pid --make-pidfile -- ${CONFIG} ${MOUNTPOINT}
+ eend $?
+}
+
+stop() {
+ ebegin "Starting lessfs"
+ start-stop-daemon --stop --exec /usr/bin/lessfs \
+ --pidfile /var/run/lessfs.pid
+ eend $?
+}
diff --git a/sys-fs/lessfs/lessfs-1.3.1.ebuild b/sys-fs/lessfs/lessfs-1.3.1.ebuild
new file mode 100644
index 000000000000..0ee848c2cca6
--- /dev/null
+++ b/sys-fs/lessfs/lessfs-1.3.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lessfs/lessfs-1.3.1.ebuild,v 1.1 2011/01/16 13:44:23 hwoarang Exp $
+
+EAPI="2"
+
+MY_PV="${PV/_/-}"
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="A high performance inline data deduplicating filesystem"
+HOMEPAGE="http://www.lessfs.com"
+SRC_URI="http://downloads.sourceforge.net/project/${PN}/${PN}/${P/_beta*/-beta}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lzo crypt debug"
+
+DEPEND=">=dev-db/tokyocabinet-1.4.42
+ app-crypt/mhash
+ >=sys-fs/fuse-2.8.0
+ crypt? ( dev-libs/openssl )
+ lzo? ( dev-libs/lzo )"
+
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ econf \
+ $(use_enable debug) $(use_enable debug lckdebug) \
+ $(use_with crypt crypto) $(use_with lzo)
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog FAQ README.* || die "dodpc failed"
+ insinto /etc
+ newins examples/lessfs.cfg-master ${PN}.cfg || die "newins failed"
+ dodoc examples/lessfs.* etc/lessfs.* || die "dodoc failed"
+ newconfd "${FILESDIR}"/${PN}.confd ${PN} || die "newconfd failed"
+ newinitd "${FILESDIR}"/${PN}.initd ${PN} || die "newinitd failed"
+
+}
+
+pkg_postinst() {
+ elog
+ elog "Default configuration file: /etc/${PN}.cfg"
+ elog "If your host is a client consult the following configuration"
+ elog "file: /usr/share/doc/${PF}/${PN}.cfg-slave.bz2"
+ elog
+ elog "${PN} new installs an init script. Adjust /etc/conf.d/${PN}"
+ elog "to fit your needs"
+}