summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-10-18 16:03:22 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-10-18 16:03:22 +0000
commitf52b8574e4f1a73a03b377922d853d897ec53313 (patch)
treef28035f6ba6b54c2e0696e9f648567a10f97faef /sys-fs/fuse
parentRemoved virtual/libstdc++ from all 9.5* ebuilds (fixing bug #196190). (diff)
downloadgentoo-2-f52b8574e4f1a73a03b377922d853d897ec53313.tar.gz
gentoo-2-f52b8574e4f1a73a03b377922d853d897ec53313.tar.bz2
gentoo-2-f52b8574e4f1a73a03b377922d853d897ec53313.zip
version bump
(Portage version: 2.1.3.13)
Diffstat (limited to 'sys-fs/fuse')
-rw-r--r--sys-fs/fuse/ChangeLog7
-rw-r--r--sys-fs/fuse/files/digest-fuse-2.7.13
-rw-r--r--sys-fs/fuse/fuse-2.7.1.ebuild85
3 files changed, 94 insertions, 1 deletions
diff --git a/sys-fs/fuse/ChangeLog b/sys-fs/fuse/ChangeLog
index e55bf81e418c..f8c20e30f4cd 100644
--- a/sys-fs/fuse/ChangeLog
+++ b/sys-fs/fuse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/fuse
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.107 2007/10/13 10:35:39 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.108 2007/10/18 16:03:21 genstef Exp $
+
+*fuse-2.7.1 (18 Oct 2007)
+
+ 18 Oct 2007; Stefan Schweizer <genstef@gentoo.org> +fuse-2.7.1.ebuild:
+ version bump
13 Oct 2007; Markus Rothe <corsair@gentoo.org> fuse-2.7.0.ebuild:
Stable on ppc64; bug #193329
diff --git a/sys-fs/fuse/files/digest-fuse-2.7.1 b/sys-fs/fuse/files/digest-fuse-2.7.1
new file mode 100644
index 000000000000..2f89af472beb
--- /dev/null
+++ b/sys-fs/fuse/files/digest-fuse-2.7.1
@@ -0,0 +1,3 @@
+MD5 f95b4a238a3df5a92e9013ecb55c2c17 fuse-2.7.1.tar.gz 506312
+RMD160 2d0fcc475590f7c2d2d62261c370f7fa6eadb51a fuse-2.7.1.tar.gz 506312
+SHA256 e4639f9e08f0b8cc9f4a0bb8cbe47da06fa57cb310b2c5a82221e0a9ba969e9a fuse-2.7.1.tar.gz 506312
diff --git a/sys-fs/fuse/fuse-2.7.1.ebuild b/sys-fs/fuse/fuse-2.7.1.ebuild
new file mode 100644
index 000000000000..a41f80474a30
--- /dev/null
+++ b/sys-fs/fuse/fuse-2.7.1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.7.1.ebuild,v 1.1 2007/10/18 16:03:21 genstef Exp $
+
+inherit linux-mod eutils libtool
+
+MY_P=${P/_/-}
+DESCRIPTION="An interface for filesystems implemented in userspace."
+HOMEPAGE="http://fuse.sourceforge.net"
+SRC_URI="mirror://sourceforge/fuse/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="kernel_linux kernel_FreeBSD"
+S=${WORKDIR}/${MY_P}
+PDEPEND="kernel_FreeBSD? ( sys-fs/fuse4bsd )"
+
+pkg_setup() {
+ if use kernel_linux ; then
+ if kernel_is ge 2 6 23; then
+ CONFIG_CHECK="FUSE_FS"
+ FUSE_FS_ERROR="You need to build the FUSE module from the kernel source, because your kernel is too new"
+ else
+ MODULE_NAMES="fuse(fs:${S}/kernel)"
+ CONFIG_CHECK="@FUSE_FS:fuse"
+ FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
+ We will continue, but we wont build the module this time."
+
+ fi
+ linux-mod_pkg_setup
+ kernel_is 2 4 && die "kernel 2.4 is not supported by this ebuild. Get an
+ older version from viewcvs"
+
+ BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR}
+ fusemoduledir=${ROOT}/lib/modules/${KV_FULL/\ }/fs"
+ BUILD_TARGETS="all"
+ ECONF_PARAMS="--with-kernel=${KV_DIR} --with-kernel-build=${KV_OUT_DIR}"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/fuse-fix-lazy-binding.patch
+ elibtoolize
+}
+
+src_compile() {
+ econf \
+ --disable-kernel-module \
+ --disable-example \
+ || die "econf failed for fuse userland"
+ emake || die "emake failed"
+
+ if use kernel_linux ; then
+ cd "${S}"
+ sed -i -e 's/.*depmod.*//g' kernel/Makefile.in
+ convert_to_m kernel/Makefile.in
+ linux-mod_src_compile
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog Filesystems README \
+ README.NFS NEWS doc/how-fuse-works \
+ doc/kernel.txt FAQ
+ docinto example
+ dodoc example/*
+
+ if use kernel_linux ; then
+ linux-mod_src_install
+ newinitd ${FILESDIR}/fuse.init fuse
+ else
+ insinto /usr/include/fuse
+ doins include/fuse_kernel.h
+ newinitd ${FILESDIR}/fuse-fbsd.init fuse
+ fi
+
+ rm -rf "${D}/dev"
+}
+
+pkg_postinst() {
+ use kernel_linux && linux-mod_pkg_postinst
+}