summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-12-01 13:43:42 +0000
committerTim Harder <radhermit@gentoo.org>2012-12-01 13:43:42 +0000
commit744f6c89bc8094075310aecdaae805545619c3ce (patch)
tree133f740226b8b43cf52655305dbd7ae5d6d042e5 /sys-fs/fuse
parentVersion bump. (diff)
downloadgentoo-2-744f6c89bc8094075310aecdaae805545619c3ce.tar.gz
gentoo-2-744f6c89bc8094075310aecdaae805545619c3ce.tar.bz2
gentoo-2-744f6c89bc8094075310aecdaae805545619c3ce.zip
Version bump (bug #439308).
(Portage version: 2.2.0_alpha143/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'sys-fs/fuse')
-rw-r--r--sys-fs/fuse/ChangeLog7
-rw-r--r--sys-fs/fuse/fuse-2.9.2.ebuild84
2 files changed, 90 insertions, 1 deletions
diff --git a/sys-fs/fuse/ChangeLog b/sys-fs/fuse/ChangeLog
index fbe0ab54f480..eaa6f3ab8969 100644
--- a/sys-fs/fuse/ChangeLog
+++ b/sys-fs/fuse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/fuse
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.167 2012/11/07 04:20:56 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.168 2012/12/01 13:43:42 radhermit Exp $
+
+*fuse-2.9.2 (01 Dec 2012)
+
+ 01 Dec 2012; Tim Harder <radhermit@gentoo.org> +fuse-2.9.2.ebuild:
+ Version bump (bug #439308).
07 Nov 2012; Jeroen Roovers <jer@gentoo.org> fuse-2.9.1-r1.ebuild:
Stable for HPPA (bug #437568).
diff --git a/sys-fs/fuse/fuse-2.9.2.ebuild b/sys-fs/fuse/fuse-2.9.2.ebuild
new file mode 100644
index 000000000000..78e75b4055f7
--- /dev/null
+++ b/sys-fs/fuse/fuse-2.9.2.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.9.2.ebuild,v 1.1 2012/12/01 13:43:42 radhermit Exp $
+
+EAPI=5
+inherit eutils libtool linux-info toolchain-funcs
+
+MY_P=${P/_/-}
+DESCRIPTION="An interface for filesystems implemented in userspace."
+HOMEPAGE="http://fuse.sourceforge.net"
+SRC_URI="mirror://sourceforge/fuse/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="kernel_linux kernel_FreeBSD static-libs"
+
+PDEPEND="kernel_FreeBSD? ( sys-fs/fuse4bsd )"
+DEPEND="virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ if use kernel_linux ; then
+ if kernel_is lt 2 6 9 ; then
+ die "Your kernel is too old."
+ fi
+ CONFIG_CHECK="~FUSE_FS"
+ FUSE_FS_WARNING="You need to have FUSE module built to use user-mode utils"
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ local UDEV_PATH=/lib/udev
+ has_version sys-fs/udev && UDEV_PATH="$($(tc-getPKG_CONFIG) --variable=udevdir udev)"
+
+ econf \
+ INIT_D_PATH="${EPREFIX}/etc/init.d" \
+ MOUNT_FUSE_PATH="${EPREFIX}/sbin" \
+ UDEV_RULES_PATH="${EPREFIX}/${UDEV_PATH}/rules.d" \
+ $(use_enable static-libs static) \
+ --disable-example
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS ChangeLog Filesystems README \
+ README.NFS NEWS doc/how-fuse-works \
+ doc/kernel.txt FAQ
+ docinto example
+ dodoc example/*
+
+ if use kernel_linux ; then
+ newinitd "${FILESDIR}"/fuse.init fuse
+ elif use kernel_FreeBSD ; then
+ insinto /usr/include/fuse
+ doins include/fuse_kernel.h
+ newinitd "${FILESDIR}"/fuse-fbsd.init fuse
+ else
+ die "We don't know what init code install for your kernel, please file a bug."
+ fi
+
+ prune_libtool_files
+ rm -rf "${D}/dev"
+
+ dodir /etc
+ cat > "${ED}"/etc/fuse.conf <<-EOF
+ # Set the maximum number of FUSE mounts allowed to non-root users.
+ # The default is 1000.
+ #
+ #mount_max = 1000
+
+ # Allow non-root users to specify the 'allow_other' or 'allow_root'
+ # mount options.
+ #
+ #user_allow_other
+ EOF
+}