summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-08-13 18:40:16 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-08-13 18:40:16 +0000
commitf4967945e092fe0ef90c222a641605695b22f471 (patch)
tree5068bbce93d4b2bd70638768a1885b1cbe4b8902 /sys-fs/fuse-zip
parentversion bump (diff)
downloadgentoo-2-f4967945e092fe0ef90c222a641605695b22f471.tar.gz
gentoo-2-f4967945e092fe0ef90c222a641605695b22f471.tar.bz2
gentoo-2-f4967945e092fe0ef90c222a641605695b22f471.zip
Version bump
(Portage version: 2.1.13.7/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'sys-fs/fuse-zip')
-rw-r--r--sys-fs/fuse-zip/ChangeLog10
-rw-r--r--sys-fs/fuse-zip/fuse-zip-0.3.0.ebuild39
2 files changed, 46 insertions, 3 deletions
diff --git a/sys-fs/fuse-zip/ChangeLog b/sys-fs/fuse-zip/ChangeLog
index 63126d7b017c..ab2fa5bf8f93 100644
--- a/sys-fs/fuse-zip/ChangeLog
+++ b/sys-fs/fuse-zip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/fuse-zip
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse-zip/ChangeLog,v 1.5 2011/10/19 20:05:18 hwoarang Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse-zip/ChangeLog,v 1.6 2013/08/13 18:40:16 hwoarang Exp $
+
+*fuse-zip-0.3.0 (13 Aug 2013)
+
+ 13 Aug 2013; Markos Chandras <hwoarang@gentoo.org> +fuse-zip-0.3.0.ebuild:
+ Version bump
19 Oct 2011; Markos Chandras <hwoarang@gentoo.org> fuse-zip-0.2.13.ebuild,
+files/libzip-fix-0.10.patch:
@@ -35,4 +40,3 @@
+metadata.xml:
Initial commit, bug #241202. Thanks to Sergey Dryabzhinsky for proposal of
ebuild.
-
diff --git a/sys-fs/fuse-zip/fuse-zip-0.3.0.ebuild b/sys-fs/fuse-zip/fuse-zip-0.3.0.ebuild
new file mode 100644
index 000000000000..fa6f41de399d
--- /dev/null
+++ b/sys-fs/fuse-zip/fuse-zip-0.3.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse-zip/fuse-zip-0.3.0.ebuild,v 1.1 2013/08/13 18:40:16 hwoarang Exp $
+
+EAPI=5
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="FUSE file system to navigate, extract, create and modify ZIP archives"
+HOMEPAGE="http://code.google.com/p/fuse-zip/"
+SRC_URI="http://fuse-zip.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/libzip
+ sys-fs/fuse"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+src_prepare() {
+ # Fix strip than installing fuse-zip
+ sed -i -e 's/install -m 755 -s/install -m 755/' Makefile || die "sed failed"
+ # fix broken makefile
+ epatch "${FILESDIR}"/"${PN}"-0.2.13-as-needed.patch
+ #enable parallel build
+ sed -i -e "s:make :\$\(MAKE\) :" Makefile || die "sed failed"
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ emake INSTALLPREFIX="${D}"/usr install
+}