summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2009-05-29 17:17:02 +0000
committerDaniel Pielmeier <billie@gentoo.org>2009-05-29 17:17:02 +0000
commitcef73c2984473d16a34829b0c4ad4180249d1e23 (patch)
tree32fe3ccc3e305d28f19af02652a5c889cc04ad48 /sys-fs/fatsort
parentamd64 stable (diff)
downloadgentoo-2-cef73c2984473d16a34829b0c4ad4180249d1e23.tar.gz
gentoo-2-cef73c2984473d16a34829b0c4ad4180249d1e23.tar.bz2
gentoo-2-cef73c2984473d16a34829b0c4ad4180249d1e23.zip
Taking the ebuild, thanks to darkside for proxy committing. Adding a new revision to make use of EAPI 2.
(Portage version: 2.1.6.11/cvs/Linux i686)
Diffstat (limited to 'sys-fs/fatsort')
-rw-r--r--sys-fs/fatsort/ChangeLog11
-rw-r--r--sys-fs/fatsort/fatsort-0.9.10.187-r1.ebuild35
-rw-r--r--sys-fs/fatsort/metadata.xml14
3 files changed, 52 insertions, 8 deletions
diff --git a/sys-fs/fatsort/ChangeLog b/sys-fs/fatsort/ChangeLog
index 6a80d60a64a2..3198b74d2a4c 100644
--- a/sys-fs/fatsort/ChangeLog
+++ b/sys-fs/fatsort/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/fatsort
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fatsort/ChangeLog,v 1.2 2008/12/08 23:15:32 darkside Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fatsort/ChangeLog,v 1.3 2009/05/29 17:17:02 billie Exp $
+
+*fatsort-0.9.10.187-r1 (29 May 2009)
+
+ 29 May 2009; Pielmeier Daniel <billie@gentoo.org> metadata.xml,
+ +fatsort-0.9.10.187-r1.ebuild:
+ Taking the ebuild, thanks to darkside for proxy committing. Adding a new
+ revision to make use of EAPI 2.
*fatsort-0.9.10.187 (08 Dec 2008)
diff --git a/sys-fs/fatsort/fatsort-0.9.10.187-r1.ebuild b/sys-fs/fatsort/fatsort-0.9.10.187-r1.ebuild
new file mode 100644
index 000000000000..5759a311c2c9
--- /dev/null
+++ b/sys-fs/fatsort/fatsort-0.9.10.187-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fatsort/fatsort-0.9.10.187-r1.ebuild,v 1.1 2009/05/29 17:17:02 billie Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs versionator
+
+MY_PV=$(replace_version_separator 3 '-')
+
+DESCRIPTION="Sorts files on FAT16/32 partitions, ideal for basic audio players."
+HOMEPAGE="http://fatsort.berlios.de/"
+SRC_URI="mirror://berlios/${PN}/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_prepare() {
+ sed -i -e 's:/usr/local/sbin:/usr/sbin:g' src/Makefile || die "sed failed!"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) LD=$(tc-getCC) CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ DESTDIR="${D}" || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ doman man/fatsort.8 || die "doman failed"
+ dodoc CHANGES README TODO || die "dodoc failed"
+}
diff --git a/sys-fs/fatsort/metadata.xml b/sys-fs/fatsort/metadata.xml
index 2df80e869c5b..06582bdb9deb 100644
--- a/sys-fs/fatsort/metadata.xml
+++ b/sys-fs/fatsort/metadata.xml
@@ -3,12 +3,14 @@
<pkgmetadata>
<herd>no-herd</herd>
<maintainer>
- <email>daniel.pielmeier@googlemail.com</email>
+ <email>billie@gentoo.org</email>
<name>Daniel Pielmeier</name>
- <description>Proxy maintainer, please assign bugs</description>
- </maintainer>
- <maintainer>
- <email>darkside@gentoo.org</email>
- <description>Proxy committer, CC on bugs</description>
</maintainer>
+ <longdescription>
+ <pkg>sys-fs/fatsort</pkg> is a utility that sorts FAT16 and FAT32 partitions. It even can
+ handle long file name entries. It reads the boot sector and sorts the
+ directory structure recursively. The main use case is to sort files on an
+ Audio player that does not implement the sorting function itself but plays
+ the files in the same order as they were copied to the disk.
+ </longdescription>
</pkgmetadata>