summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2013-12-12 17:27:41 +0000
committerDaniel Pielmeier <billie@gentoo.org>2013-12-12 17:27:41 +0000
commit23fa437e1f30d3b95baa0cd65a2d83e41f82207a (patch)
tree249ae77511088811ed499e7fd868ad009e1a0c48 /sys-fs/fatsort
parentCleanup, bug#494066 (diff)
downloadgentoo-2-23fa437e1f30d3b95baa0cd65a2d83e41f82207a.tar.gz
gentoo-2-23fa437e1f30d3b95baa0cd65a2d83e41f82207a.tar.bz2
gentoo-2-23fa437e1f30d3b95baa0cd65a2d83e41f82207a.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 215AD14D)
Diffstat (limited to 'sys-fs/fatsort')
-rw-r--r--sys-fs/fatsort/ChangeLog8
-rw-r--r--sys-fs/fatsort/fatsort-1.2.ebuild41
-rw-r--r--sys-fs/fatsort/files/fatsort-1.2-tests.patch30
3 files changed, 78 insertions, 1 deletions
diff --git a/sys-fs/fatsort/ChangeLog b/sys-fs/fatsort/ChangeLog
index dd3e6a5b1a63..5841902b4f66 100644
--- a/sys-fs/fatsort/ChangeLog
+++ b/sys-fs/fatsort/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/fatsort
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fatsort/ChangeLog,v 1.36 2013/10/13 14:03:38 billie Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fatsort/ChangeLog,v 1.37 2013/12/12 17:27:41 billie Exp $
+
+*fatsort-1.2 (12 Dec 2013)
+
+ 12 Dec 2013; Daniel Pielmeier <billie@gentoo.org> +fatsort-1.2.ebuild,
+ +files/fatsort-1.2-tests.patch:
+ Version bump.
13 Oct 2013; Daniel Pielmeier <billie@gentoo.org> fatsort-1.1.1.ebuild,
+files/fatsort-1.1.1-test-results.patch:
diff --git a/sys-fs/fatsort/fatsort-1.2.ebuild b/sys-fs/fatsort/fatsort-1.2.ebuild
new file mode 100644
index 000000000000..d70267656366
--- /dev/null
+++ b/sys-fs/fatsort/fatsort-1.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fatsort/fatsort-1.2.ebuild,v 1.1 2013/12/12 17:27:41 billie Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+SVN_REV=355
+MY_P=${P}.${SVN_REV}
+
+DESCRIPTION="Sorts files on FAT16/32 partitions, ideal for basic audio players."
+HOMEPAGE="http://fatsort.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-util/bbe sys-fs/dosfstools )"
+
+RESTRICT="test? ( userpriv )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i -e '/^\(MANDIR=\|SBINDIR=\)/s|/usr/local|/usr|' \
+ $(find ./ -name Makefile) || die
+ epatch "${FILESDIR}/${P}-tests.patch"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) LD=$(tc-getCC) \
+ CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ DESTDIR="${D}"
+}
+
+src_test() {
+ make tests
+}
diff --git a/sys-fs/fatsort/files/fatsort-1.2-tests.patch b/sys-fs/fatsort/files/fatsort-1.2-tests.patch
new file mode 100644
index 000000000000..6fc44e23efcb
--- /dev/null
+++ b/sys-fs/fatsort/files/fatsort-1.2-tests.patch
@@ -0,0 +1,30 @@
+diff -Naur tests/tc_check_consistent_version/Makefile tests/tc_check_consistent_version/Makefile
+--- tests/tc_check_consistent_version/Makefile 2013-12-10 21:52:36.773278926 +0100
++++ tests/tc_check_consistent_version/Makefile 2013-12-10 21:52:43.783278646 +0100
+@@ -2,8 +2,8 @@
+
+ all:
+ manver=\
+- `head -1 ../../man/fatsort.1 | sed -e "s/.* \([0-9.]*\)\"$$/\1/"`; \
+- progver=`../../src/fatsort -v | head -1 | sed -e "s/^.* \([0-9.]\+\) .*$$/\1/"`; \
++ `head -2 ../../man/fatsort.1 | tail -1 | sed -e "s/^.*\"fatsort \([0-9.]\+\)\".*$$/\1/"`; \
++ progver=`../../src/fatsort --version | head -1 | sed -e "s/^fatsort \([0-9.]\+\).*$$/\1/"`; \
+ changesver=`head -1 ../../CHANGES | sed -e "s/^.*v\([0-9.]\+\)$$/\1/"`; \
+ echo "#$$manver#$$progver#$$changesver#"; \
+ [ "$$manver" = "$$progver" ]; \
+diff -Naur tests/tc_pos_sort_modification_time/Makefile tests/tc_pos_sort_modification_time/Makefile
+--- tests/tc_pos_sort_modification_time/Makefile 2013-12-10 21:52:36.772278926 +0100
++++ tests/tc_pos_sort_modification_time/Makefile 2013-12-10 21:57:06.433268173 +0100
+@@ -44,10 +44,11 @@
+ sudo mount -o loop,codepage=850,iocharset=iso8859-1,utf8,uid=${MOUNT_UID},gid=${MOUNT_GID} ${FS_IMG} ${MOUNT_POINT}
+ cat ${DIRECTORIES} | while read dir; do mkdir -p "${MOUNT_POINT}/$$dir"; done
+ cat ${FILES} | while read file; do touch "${MOUNT_POINT}/$$file"; done
+- sleep 3
++ sleep 1
+ touch ${MOUNT_POINT}/last # alter modification time
++ sleep 1
+ touch ${MOUNT_POINT}/first -t 200001010101.01
+-
++ sleep 1
+ sudo umount -l ${MOUNT_POINT}
+ rmdir ${MOUNT_POINT}