summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-02-26 17:38:17 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-02-26 17:38:17 +0000
commit9eab9e1cfda62f3d16aa3297311f6099d8138525 (patch)
tree0305658b5eb10a6825410dbb6b916f6cac9729c6 /sys-fs/extundelete
parentmedia-gfx/imageworsener: 0.9.8 (diff)
downloadgentoo-2-9eab9e1cfda62f3d16aa3297311f6099d8138525.tar.gz
gentoo-2-9eab9e1cfda62f3d16aa3297311f6099d8138525.tar.bz2
gentoo-2-9eab9e1cfda62f3d16aa3297311f6099d8138525.zip
Fix building against recent e2fsprogs wrt #402633 by Richard Yao
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/extundelete')
-rw-r--r--sys-fs/extundelete/ChangeLog10
-rw-r--r--sys-fs/extundelete/extundelete-0.2.0-r1.ebuild27
-rw-r--r--sys-fs/extundelete/files/extundelete-0.2.0-build.patch23
3 files changed, 58 insertions, 2 deletions
diff --git a/sys-fs/extundelete/ChangeLog b/sys-fs/extundelete/ChangeLog
index 7583c1b79c01..45be78cfc05b 100644
--- a/sys-fs/extundelete/ChangeLog
+++ b/sys-fs/extundelete/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/extundelete
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/extundelete/ChangeLog,v 1.3 2011/06/19 13:59:20 maekke Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/extundelete/ChangeLog,v 1.4 2012/02/26 17:38:17 ssuominen Exp $
+
+*extundelete-0.2.0-r1 (26 Feb 2012)
+
+ 26 Feb 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +extundelete-0.2.0-r1.ebuild, +files/extundelete-0.2.0-build.patch:
+ Fix building against recent e2fsprogs wrt #402633 by Richard Yao
19 Jun 2011; Markus Meier <maekke@gentoo.org> extundelete-0.2.0.ebuild:
x86 stable, bug #370789
diff --git a/sys-fs/extundelete/extundelete-0.2.0-r1.ebuild b/sys-fs/extundelete/extundelete-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..c66571d10dad
--- /dev/null
+++ b/sys-fs/extundelete/extundelete-0.2.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/extundelete/extundelete-0.2.0-r1.ebuild,v 1.1 2012/02/26 17:38:17 ssuominen Exp $
+
+EAPI=4
+inherit eutils
+
+_E2FS=1.42
+
+DESCRIPTION="A utility to undelete files from an ext3 or ext4 partition"
+HOMEPAGE="http://extundelete.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=sys-fs/e2fsprogs-${_E2FS}
+ >=sys-libs/e2fsprogs-libs-${_E2FS}"
+DEPEND="${RDEPEND}"
+
+DOCS="README"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+}
diff --git a/sys-fs/extundelete/files/extundelete-0.2.0-build.patch b/sys-fs/extundelete/files/extundelete-0.2.0-build.patch
new file mode 100644
index 000000000000..2bd56ef2bbdf
--- /dev/null
+++ b/sys-fs/extundelete/files/extundelete-0.2.0-build.patch
@@ -0,0 +1,23 @@
+http://bugs.gentoo.org/402633
+http://projects.archlinux.org/svntogit/community.git/tree/trunk/extundelete-build.patch?h=packages/extundelete
+
+--- src/extundelete.cc
++++ src/extundelete.cc
+@@ -943,3 +943,3 @@
+ {
+- group_descriptor_table[n] = fs->group_desc[n];
++ group_descriptor_table[n] = *ext2fs_group_desc(fs, fs->group_desc, n);
+ }
+@@ -2613,3 +2613,4 @@
+ inode->osd2.linux2.l_i_gid_high = le16_to_cpu( (uint16_t *) &inodebuf[item*60] );
+- inode->osd2.linux2.l_i_reserved2 = le32_to_cpu( (uint32_t *) &inodebuf[item*62] );
++ inode->osd2.linux2.l_i_checksum_lo = le16_to_cpu( (uint16_t *) &inodebuf[item*62] );
++ inode->osd2.linux2.l_i_reserved = le16_to_cpu( (uint16_t *) &inodebuf[item*63] );
+ }
+--- src/insertionops.cc
++++ src/insertionops.cc
+@@ -65,3 +65,3 @@
+ os << "# Blocks per group: " << s_block->s_blocks_per_group << std::endl;
+- os << "# Fragments per group: " << s_block->s_frags_per_group << std::endl;
++ os << "# Fragments per group: " << s_block->s_clusters_per_group << std::endl;
+ os << "# Inodes per group: " << s_block->s_inodes_per_group << std::endl;