summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2008-05-17 15:04:01 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2008-05-17 15:04:01 +0000
commit83950c387c3de0cfe5df240b0f9f438c2bb38e6a (patch)
treeff7975a4465e0de1dd622e6268b884ad8eec2201 /sys-fs/encfs
parentAdded ~ppc wrt bug 219723 (diff)
downloadgentoo-2-83950c387c3de0cfe5df240b0f9f438c2bb38e6a.tar.gz
gentoo-2-83950c387c3de0cfe5df240b0f9f438c2bb38e6a.tar.bz2
gentoo-2-83950c387c3de0cfe5df240b0f9f438c2bb38e6a.zip
Add gcc-4.3 patch for bug 222287. Thanks to Martin Vath <vaeth at
mathematik.uni-wuerzburg dot de>. (Portage version: 2.1.4.4)
Diffstat (limited to 'sys-fs/encfs')
-rw-r--r--sys-fs/encfs/ChangeLog7
-rw-r--r--sys-fs/encfs/encfs-1.4.2.ebuild10
-rw-r--r--sys-fs/encfs/files/encfs-1.4.2-gcc-4.3.patch176
3 files changed, 191 insertions, 2 deletions
diff --git a/sys-fs/encfs/ChangeLog b/sys-fs/encfs/ChangeLog
index 504a93302052..f227b6072d62 100644
--- a/sys-fs/encfs/ChangeLog
+++ b/sys-fs/encfs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/encfs
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/encfs/ChangeLog,v 1.32 2008/05/17 14:56:57 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/encfs/ChangeLog,v 1.33 2008/05/17 15:04:01 vanquirius Exp $
+
+ 17 May 2008; Marcelo Goes <vanquirius@gentoo.org>
+ +files/encfs-1.4.2-gcc-4.3.patch, encfs-1.4.2.ebuild:
+ Add gcc-4.3 patch for bug 222287. Thanks to Martin Vath <vaeth at
+ mathematik.uni-wuerzburg dot de>.
17 May 2008; Marcelo Goes <vanquirius@gentoo.org> encfs-1.4.2.ebuild:
Add >=dev-libs/boost-1.34 dependency for bug 222223. Thanks to Remy Blank
diff --git a/sys-fs/encfs/encfs-1.4.2.ebuild b/sys-fs/encfs/encfs-1.4.2.ebuild
index 80a08dc17a21..d8a016d57666 100644
--- a/sys-fs/encfs/encfs-1.4.2.ebuild
+++ b/sys-fs/encfs/encfs-1.4.2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/encfs/encfs-1.4.2.ebuild,v 1.2 2008/05/17 14:56:57 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/encfs/encfs-1.4.2.ebuild,v 1.3 2008/05/17 15:04:01 vanquirius Exp $
+
+inherit eutils
DESCRIPTION="Encrypted Filesystem module for Linux"
SRC_URI="http://encfs.googlecode.com/files/${P}.tgz"
@@ -16,6 +18,12 @@ DEPEND=">=dev-libs/openssl-0.9.7
>=dev-libs/boost-1.34
nls? ( >=sys-devel/gettext-0.14.1 )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc-4.3.patch
+}
+
src_compile() {
econf `use_enable nls` || die
emake || die
diff --git a/sys-fs/encfs/files/encfs-1.4.2-gcc-4.3.patch b/sys-fs/encfs/files/encfs-1.4.2-gcc-4.3.patch
new file mode 100644
index 000000000000..b979c76aa12e
--- /dev/null
+++ b/sys-fs/encfs/files/encfs-1.4.2-gcc-4.3.patch
@@ -0,0 +1,176 @@
+--- encfs/CipherFileIO.cpp
++++ encfs/CipherFileIO.cpp
+@@ -23,7 +23,7 @@
+ #include <rlog/rlog.h>
+
+ #include <fcntl.h>
+-#include <errno.h>
++#include <cerrno>
+
+ using boost::shared_ptr;
+
+--- encfs/ConfigVar.h
++++ encfs/ConfigVar.h
+@@ -19,6 +19,7 @@
+ #define _ConfigVar_incl_
+
+ #include <string>
++#include <cstring>
+ #include <boost/shared_ptr.hpp>
+
+ using boost::shared_ptr;
+--- encfs/DirNode.cpp
++++ encfs/DirNode.cpp
+@@ -22,9 +22,9 @@
+
+ #include <sys/stat.h>
+ #include <sys/types.h>
+-#include <errno.h>
+-#include <stdio.h>
+-#include <stdlib.h>
++#include <cerrno>
++#include <cstdio>
++#include <cstdlib>
+ #include <pthread.h>
+ #include <unistd.h>
+ #ifdef linux
+--- encfs/FileNode.cpp
++++ encfs/FileNode.cpp
+@@ -19,7 +19,7 @@
+ // of sys/stat.h or other system headers (to be safe)
+ #include "encfs.h"
+
+-#include <errno.h>
++#include <cerrno>
+ #include <sys/stat.h>
+ #include <sys/types.h>
+ #include <fcntl.h>
+--- encfs/FileUtils.cpp
++++ encfs/FileUtils.cpp
+@@ -47,9 +47,9 @@
+ #include <fcntl.h>
+ #include <unistd.h>
+ #include <ctype.h>
+-#include <stdio.h>
+-#include <stdlib.h>
+-#include <errno.h>
++#include <cstdio>
++#include <cstdlib>
++#include <cerrno>
+ #include <string.h>
+
+ #include <iostream>
+--- encfs/MemoryPool.cpp
++++ encfs/MemoryPool.cpp
+@@ -19,7 +19,7 @@
+ #include "MemoryPool.h"
+ #include <rlog/rlog.h>
+
+-#include <stdlib.h>
++#include <cstdlib>
+ #include <string.h>
+
+ #include "config.h"
+--- encfs/NameIO.h
++++ encfs/NameIO.h
+@@ -19,6 +19,7 @@
+ #define _NameIO_incl_
+
+ #include <string>
++#include <cstring>
+ #include <list>
+
+ #include <inttypes.h>
+--- encfs/RawFileIO.cpp
++++ encfs/RawFileIO.cpp
+@@ -29,7 +29,7 @@
+ #include <fcntl.h>
+ #include <string.h>
+
+-#include <errno.h>
++#include <cerrno>
+
+ using namespace std;
+
+--- encfs/encfs.cpp
++++ encfs/encfs.cpp
+@@ -17,12 +17,12 @@
+
+ #include "encfs.h"
+
+-#include <stdio.h>
++#include <cstdio>
+ #include <string.h>
+ #include <unistd.h>
+ #include <fcntl.h>
+ #include <dirent.h>
+-#include <errno.h>
++#include <cerrno>
+ #include <sys/statvfs.h>
+ #include <sys/time.h>
+
+--- encfs/encfs.h
++++ encfs/encfs.h
+@@ -28,7 +28,7 @@
+ #endif
+
+ #ifndef linux
+-#include <errno.h>
++#include <cerrno>
+
+ static __inline int setfsuid(uid_t uid)
+ {
+--- encfs/main.cpp
++++ encfs/main.cpp
+@@ -25,10 +25,10 @@
+ #include <sstream>
+
+ #include <assert.h>
+-#include <stdio.h>
++#include <cstdio>
+ #include <unistd.h>
+ #include <sys/time.h>
+-#include <errno.h>
++#include <cerrno>
+ #include <string.h>
+
+ #include <getopt.h>
+--- encfs/readpassphrase.cpp
++++ encfs/readpassphrase.cpp
+@@ -36,8 +36,8 @@
+ #ifndef HAVE_READPASSPHRASE
+
+ #include <signal.h>
+-#include <stdio.h>
+-#include <errno.h>
++#include <cstdio>
++#include <cerrno>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
+--- encfs/test.cpp
++++ encfs/test.cpp
+@@ -22,7 +22,7 @@
+
+ #include <iostream>
+
+-#include <stdlib.h>
++#include <cstdlib>
+
+ #include "Cipher.h"
+ #include "DirNode.h"
+--- intl/autosprintf.cpp
++++ intl/autosprintf.cpp
+@@ -28,10 +28,10 @@
+ #include "autosprintf.h"
+
+ #include <stdarg.h>
+-#include <stdlib.h>
++#include <cstdlib>
+ #include <string.h>
+ //#include "lib-asprintf.h"
+-#include <stdio.h>
++#include <cstdio>
+
+ namespace gnu
+ {