summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-03-29 17:08:28 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-03-29 17:08:28 +0000
commit7f714adf5927ad92d16c39212f853d40768083a5 (patch)
tree1b7a85d4e58d9bed53976892ce5cecab85369492 /sys-fs/ecryptfs-utils
parentMigrate to EAPI 2 for bug #239835. (diff)
downloadgentoo-2-7f714adf5927ad92d16c39212f853d40768083a5.tar.gz
gentoo-2-7f714adf5927ad92d16c39212f853d40768083a5.tar.bz2
gentoo-2-7f714adf5927ad92d16c39212f853d40768083a5.zip
Version bump (bug #246762).
(Portage version: 13244-svn/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/ecryptfs-utils')
-rw-r--r--sys-fs/ecryptfs-utils/ChangeLog11
-rw-r--r--sys-fs/ecryptfs-utils/ecryptfs-utils-73.ebuild68
-rw-r--r--sys-fs/ecryptfs-utils/files/ecryptfs-utils-73-fix_implicit_declarations.patch42
-rw-r--r--sys-fs/ecryptfs-utils/metadata.xml2
4 files changed, 121 insertions, 2 deletions
diff --git a/sys-fs/ecryptfs-utils/ChangeLog b/sys-fs/ecryptfs-utils/ChangeLog
index 2b9340fa59a8..ffac5d68ee1e 100644
--- a/sys-fs/ecryptfs-utils/ChangeLog
+++ b/sys-fs/ecryptfs-utils/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/ecryptfs-utils
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ecryptfs-utils/ChangeLog,v 1.22 2008/08/22 21:24:33 cardoe Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ecryptfs-utils/ChangeLog,v 1.23 2009/03/29 17:08:28 arfrever Exp $
+
+*ecryptfs-utils-73 (29 Mar 2009)
+
+ 29 Mar 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +files/ecryptfs-utils-73-fix_implicit_declarations.patch,
+ +ecryptfs-utils-73.ebuild:
+ Version bump (bug #246762).
22 Aug 2008; Doug Goldstein <cardoe@gentoo.org> metadata.xml:
add GLEP 56 USE flag desc from use.local.desc
diff --git a/sys-fs/ecryptfs-utils/ecryptfs-utils-73.ebuild b/sys-fs/ecryptfs-utils/ecryptfs-utils-73.ebuild
new file mode 100644
index 000000000000..a740088baaf9
--- /dev/null
+++ b/sys-fs/ecryptfs-utils/ecryptfs-utils-73.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ecryptfs-utils/ecryptfs-utils-73.ebuild,v 1.1 2009/03/29 17:08:28 arfrever Exp $
+
+inherit eutils pam
+
+DESCRIPTION="eCryptfs userspace utilities"
+HOMEPAGE="http://launchpad.net/ecryptfs"
+SRC_URI="http://launchpad.net/ecryptfs/trunk/${PV}/+download/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc gpg gtk nss openssl pam pkcs11 python suid tpm"
+
+RDEPEND=">=sys-apps/keyutils-1.0
+ >=dev-libs/libgcrypt-1.2.0
+ gpg? ( app-crypt/gpgme )
+ gtk? ( x11-libs/gtk+ )
+ nss? ( dev-libs/nss )
+ openssl? ( >=dev-libs/openssl-0.9.7 )
+ pam? ( sys-libs/pam )
+ pkcs11? (
+ >=dev-libs/openssl-0.9.7
+ >=dev-libs/pkcs11-helper-1.04
+ )
+ python? ( >=dev-lang/python-2.5 )
+ tpm? ( app-crypt/trousers )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9.0
+ python? ( dev-lang/swig )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-fix_implicit_declarations.patch"
+}
+
+src_compile() {
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ --with-pamdir=$(getpam_mod_dir) \
+ $(use_enable doc docs) \
+ $(use_enable gpg) \
+ $(use_enable gtk gui) \
+ $(use_enable nss) \
+ $(use_enable openssl) \
+ $(use_enable pam) \
+ $(use_enable pkcs11 pkcs11-helper) \
+ $(use_enable python pywrap) \
+ $(use_enable tpm tspi)
+ emake || die "emake failed"
+}
+
+src_install(){
+ emake DESTDIR="${D}" install || die "emake install failed"
+ use suid && fperms u+s /sbin/mount.ecryptfs
+}
+
+pkg_postinst() {
+ if use suid; then
+ ewarn
+ ewarn "You have chosen to install ${PN} with the binary setuid root. This"
+ ewarn "means that if there are any undetected vulnerabilities in the binary,"
+ ewarn "then local users may be able to gain root access on your machine."
+ ewarn
+ fi
+}
diff --git a/sys-fs/ecryptfs-utils/files/ecryptfs-utils-73-fix_implicit_declarations.patch b/sys-fs/ecryptfs-utils/files/ecryptfs-utils-73-fix_implicit_declarations.patch
new file mode 100644
index 000000000000..ed8ddbcdfded
--- /dev/null
+++ b/sys-fs/ecryptfs-utils/files/ecryptfs-utils-73-fix_implicit_declarations.patch
@@ -0,0 +1,42 @@
+--- src/key_mod/ecryptfs_key_mod_gpg.c
++++ src/key_mod/ecryptfs_key_mod_gpg.c
+@@ -18,6 +18,7 @@
+ * 02111-1307, USA.
+ */
+
++#include "config.h"
+ #include <fcntl.h>
+ #include <pwd.h>
+ #include <stdio.h>
+@@ -29,7 +30,6 @@
+ #include <gpgme.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+-#include "config.h"
+ #include "../include/ecryptfs.h"
+ #include "../include/decision_graph.h"
+
+--- src/key_mod/ecryptfs_key_mod_pkcs11_helper.c
++++ src/key_mod/ecryptfs_key_mod_pkcs11_helper.c
+@@ -20,6 +20,7 @@
+ * 02111-1307, USA.
+ */
+
++#include "config.h"
+ #include <fcntl.h>
+ #include <pwd.h>
+ #include <stdio.h>
+@@ -28,11 +29,12 @@
+ #include <errno.h>
+ #include <stdlib.h>
+ #include <unistd.h>
++#include <openssl/err.h>
++#include <openssl/pem.h>
+ #include <openssl/x509.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <pkcs11-helper-1.0/pkcs11h-certificate.h>
+-#include "config.h"
+ #include "../include/ecryptfs.h"
+ #include "../include/decision_graph.h"
+
diff --git a/sys-fs/ecryptfs-utils/metadata.xml b/sys-fs/ecryptfs-utils/metadata.xml
index a868f7a6214c..39ce26f33cdc 100644
--- a/sys-fs/ecryptfs-utils/metadata.xml
+++ b/sys-fs/ecryptfs-utils/metadata.xml
@@ -5,8 +5,10 @@
<herd>crypto</herd>
<use>
<flag name='gpg'>Enable <pkg>app-crypt/gnupg</pkg> key module</flag>
+ <flag name='nss'>Enable support for <pkg>dev-libs/nss</pkg></flag>
<flag name='openssl'>Enable <pkg>dev-libs/openssl</pkg> key
module</flag>
<flag name='pkcs11'>Enable PKCS#11 (Smartcards) key module</flag>
+ <flag name='tpm'>Enable support for Trusted Platform Module (TPM) using <pkg>app-crypt/trousers</pkg></flag>
</use>
</pkgmetadata>