summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-05-02 18:30:04 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-05-02 18:30:04 +0000
commit7aaf17c27e22e31829fb8fe971552abd031e682e (patch)
treebd4add1d2b22d56008c99f0e27c50a4c3a920b57 /sys-fs/ecryptfs-utils
parentnew developer branch (diff)
downloadgentoo-2-7aaf17c27e22e31829fb8fe971552abd031e682e.tar.gz
gentoo-2-7aaf17c27e22e31829fb8fe971552abd031e682e.tar.bz2
gentoo-2-7aaf17c27e22e31829fb8fe971552abd031e682e.zip
Version bump.
(Portage version: 13595-svn/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/ecryptfs-utils')
-rw-r--r--sys-fs/ecryptfs-utils/ChangeLog8
-rw-r--r--sys-fs/ecryptfs-utils/ecryptfs-utils-75.ebuild67
-rw-r--r--sys-fs/ecryptfs-utils/files/ecryptfs-utils-75-fix_warnings.patch110
3 files changed, 184 insertions, 1 deletions
diff --git a/sys-fs/ecryptfs-utils/ChangeLog b/sys-fs/ecryptfs-utils/ChangeLog
index ffac5d68ee1e..fd82b06e1220 100644
--- a/sys-fs/ecryptfs-utils/ChangeLog
+++ b/sys-fs/ecryptfs-utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/ecryptfs-utils
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ecryptfs-utils/ChangeLog,v 1.23 2009/03/29 17:08:28 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ecryptfs-utils/ChangeLog,v 1.24 2009/05/02 18:30:04 arfrever Exp $
+
+*ecryptfs-utils-75 (02 May 2009)
+
+ 02 May 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +ecryptfs-utils-75.ebuild, +files/ecryptfs-utils-75-fix_warnings.patch:
+ Version bump.
*ecryptfs-utils-73 (29 Mar 2009)
diff --git a/sys-fs/ecryptfs-utils/ecryptfs-utils-75.ebuild b/sys-fs/ecryptfs-utils/ecryptfs-utils-75.ebuild
new file mode 100644
index 000000000000..43bf93a57a07
--- /dev/null
+++ b/sys-fs/ecryptfs-utils/ecryptfs-utils-75.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ecryptfs-utils/ecryptfs-utils-75.ebuild,v 1.1 2009/05/02 18:30:04 arfrever Exp $
+
+EAPI="2"
+
+inherit eutils pam
+
+DESCRIPTION="eCryptfs userspace utilities"
+HOMEPAGE="http://launchpad.net/ecryptfs"
+SRC_URI="http://launchpad.net/ecryptfs/trunk/${PV}/+download/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc gpg gtk nss openssl pam pkcs11 python suid tpm"
+
+RDEPEND=">=sys-apps/keyutils-1.0
+ >=dev-libs/libgcrypt-1.2.0
+ gpg? ( app-crypt/gpgme )
+ gtk? ( x11-libs/gtk+ )
+ nss? ( dev-libs/nss )
+ openssl? ( >=dev-libs/openssl-0.9.7 )
+ pam? ( sys-libs/pam )
+ pkcs11? (
+ >=dev-libs/openssl-0.9.7
+ >=dev-libs/pkcs11-helper-1.04
+ )
+ python? ( >=dev-lang/python-2.5 )
+ tpm? ( app-crypt/trousers )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9.0
+ python? ( dev-lang/swig )"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-fix_warnings.patch"
+}
+
+src_configure() {
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ --with-pamdir=$(getpam_mod_dir) \
+ $(use_enable doc docs) \
+ $(use_enable gpg) \
+ $(use_enable gtk gui) \
+ $(use_enable nss) \
+ $(use_enable openssl) \
+ $(use_enable pam) \
+ $(use_enable pkcs11 pkcs11-helper) \
+ $(use_enable python pywrap) \
+ $(use_enable tpm tspi)
+}
+
+src_install(){
+ emake DESTDIR="${D}" install || die "emake install failed"
+ use suid && fperms u+s /sbin/mount.ecryptfs
+}
+
+pkg_postinst() {
+ if use suid; then
+ ewarn
+ ewarn "You have chosen to install ${PN} with the binary setuid root. This"
+ ewarn "means that if there are any undetected vulnerabilities in the binary,"
+ ewarn "then local users may be able to gain root access on your machine."
+ ewarn
+ fi
+}
diff --git a/sys-fs/ecryptfs-utils/files/ecryptfs-utils-75-fix_warnings.patch b/sys-fs/ecryptfs-utils/files/ecryptfs-utils-75-fix_warnings.patch
new file mode 100644
index 000000000000..0a143455ba4a
--- /dev/null
+++ b/sys-fs/ecryptfs-utils/files/ecryptfs-utils-75-fix_warnings.patch
@@ -0,0 +1,110 @@
+--- src/key_mod/ecryptfs_key_mod_gpg.c
++++ src/key_mod/ecryptfs_key_mod_gpg.c
+@@ -131,7 +131,7 @@
+
+ int ecryptfs_gpg_encrypt(char *to, int size, char *from, unsigned char *blob)
+ {
+- int rc;
++ int rc = 0;
+
+ /* gpg_op_encrypt(...); */
+ out:
+@@ -251,7 +251,7 @@
+ struct val_node **head, void **foo)
+ {
+ struct key_mod_gpg *key_mod_gpg = (struct key_mod_gpg *)(*foo);
+- int i;
++ int i = 0;
+ gpgme_error_t err;
+ int rc = 0;
+ gpgme_key_t key;
+@@ -283,10 +283,7 @@
+
+ static int generate_name_val_list(struct ecryptfs_name_val_pair *head)
+ {
+- struct stat buf;
+- int i = 0;
+ uid_t id = getuid();
+- struct passwd *pw = getpwuid(id);
+ int rc = 0;
+
+ head->next = NULL;
+@@ -304,6 +301,7 @@
+ destroy_key_mod_gpg(key_mod_gpg);
+ free(key_mod_gpg);
+ }
++ return 0;
+ }
+
+
+@@ -312,7 +310,6 @@
+ {
+ struct key_mod_gpg *key_mod_gpg;
+ gpgme_error_t err;
+- gpgme_keylist_result_t keylist_res;
+ int rc = 0;
+
+ (*foo) = NULL;
+@@ -329,7 +326,7 @@
+ if ((err = gpgme_op_keylist_start(key_mod_gpg->ctx, "", 0))) {
+ printf("Error attempting to start keylist\n");
+ rc = -EINVAL;
+- gpgme_release(ctx);
++ gpgme_release(key_mod_gpg->ctx);
+ free(key_mod_gpg);
+ goto out;
+ }
+--- src/key_mod/ecryptfs_key_mod_pkcs11_helper.c
++++ src/key_mod/ecryptfs_key_mod_pkcs11_helper.c
+@@ -592,7 +592,6 @@
+ char dn[1024] = {0};
+ char serial[1024] = {0};
+ char *ser = NULL;
+- char *ssh_key = NULL;
+ size_t ser_len = 0;
+ int n;
+
+@@ -1538,7 +1537,6 @@
+ struct ecryptfs_ctx *ctx = &_ctx;
+ struct ecryptfs_name_val_pair nvp_head;
+ struct val_node *dummy_mnt_params;
+- uid_t id;
+ struct passwd *pw;
+ char *rcfile_fullpath = NULL;
+ int fd;
+@@ -1649,6 +1647,7 @@
+ if (pkcs11h_key_param_nodes[PKCS11H_KEY_TOK_ID].suggested_val)
+ free(pkcs11h_key_param_nodes[PKCS11H_KEY_TOK_ID].suggested_val);
+ pkcs11h_terminate ();
++ return 0;
+ }
+
+ static struct ecryptfs_key_mod_ops ecryptfs_pkcs11h_ops = {
+--- src/libecryptfs/key_management.c
++++ src/libecryptfs/key_management.c
+@@ -18,6 +18,7 @@
+ * 02111-1307, USA.
+ */
+
++#include "config.h"
+ #include <errno.h>
+ #ifdef ENABLE_NSS
+ #include <nss.h>
+@@ -39,7 +40,6 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <pwd.h>
+-#include "config.h"
+ #include "../include/ecryptfs.h"
+
+ #ifndef ENOKEY
+--- src/utils/ecryptfs_unwrap_passphrase.c
++++ src/utils/ecryptfs_unwrap_passphrase.c
+@@ -42,7 +42,6 @@
+ char *wrapping_passphrase;
+ char salt[ECRYPTFS_SALT_SIZE];
+ char salt_hex[ECRYPTFS_SALT_SIZE_HEX];
+- struct passwd *pwd;
+ int rc = 0;
+
+ if (argc == 1) {