summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-11-20 18:17:32 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-11-20 18:17:32 +0000
commit789bb51f8ab644eca588de0bc1627d48973a27ac (patch)
tree9a51a359c7eca0bc9cda811a3e2540a2fdc37666 /sys-fs/ecryptfs-utils
parentRevbump to stable to add an useful fix, bug #199734 (diff)
downloadgentoo-2-789bb51f8ab644eca588de0bc1627d48973a27ac.tar.gz
gentoo-2-789bb51f8ab644eca588de0bc1627d48973a27ac.tar.bz2
gentoo-2-789bb51f8ab644eca588de0bc1627d48973a27ac.zip
Fix locate gpgme issue, bug#199779
(Portage version: 2.1.3.19)
Diffstat (limited to 'sys-fs/ecryptfs-utils')
-rw-r--r--sys-fs/ecryptfs-utils/ChangeLog6
-rw-r--r--sys-fs/ecryptfs-utils/ecryptfs-utils-30.ebuild3
-rw-r--r--sys-fs/ecryptfs-utils/files/ecryptfs-utils-30-gpgme.patch50
3 files changed, 57 insertions, 2 deletions
diff --git a/sys-fs/ecryptfs-utils/ChangeLog b/sys-fs/ecryptfs-utils/ChangeLog
index 3cacec4893d8..3c83ba213cbe 100644
--- a/sys-fs/ecryptfs-utils/ChangeLog
+++ b/sys-fs/ecryptfs-utils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/ecryptfs-utils
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ecryptfs-utils/ChangeLog,v 1.10 2007/11/10 17:12:44 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ecryptfs-utils/ChangeLog,v 1.11 2007/11/20 18:17:32 alonbl Exp $
+
+ 20 Nov 2007; Alon Bar-Lev <alonbl@gentoo.org>
+ +files/ecryptfs-utils-30-gpgme.patch, ecryptfs-utils-30.ebuild:
+ Fix locate gpgme issue, bug#199779
10 Nov 2007; Alon Bar-Lev <alonbl@gentoo.org> metadata.xml:
Add crypto as maintainer
diff --git a/sys-fs/ecryptfs-utils/ecryptfs-utils-30.ebuild b/sys-fs/ecryptfs-utils/ecryptfs-utils-30.ebuild
index 19b8803548eb..224614bf8859 100644
--- a/sys-fs/ecryptfs-utils/ecryptfs-utils-30.ebuild
+++ b/sys-fs/ecryptfs-utils/ecryptfs-utils-30.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ecryptfs-utils/ecryptfs-utils-30.ebuild,v 1.2 2007/11/11 06:29:34 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ecryptfs-utils/ecryptfs-utils-30.ebuild,v 1.3 2007/11/20 18:17:32 alonbl Exp $
inherit autotools
@@ -31,6 +31,7 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}/${P}-gpgme.patch"
# Until upstream move to autoconf-2.60
eautoreconf
}
diff --git a/sys-fs/ecryptfs-utils/files/ecryptfs-utils-30-gpgme.patch b/sys-fs/ecryptfs-utils/files/ecryptfs-utils-30-gpgme.patch
new file mode 100644
index 000000000000..3b351a124dab
--- /dev/null
+++ b/sys-fs/ecryptfs-utils/files/ecryptfs-utils-30-gpgme.patch
@@ -0,0 +1,50 @@
+diff --git a/configure.ac b/configure.ac
+index 6778105..ba6484d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -93,6 +93,13 @@ AC_ARG_ENABLE(
+ )
+
+ AC_ARG_WITH(
++ [gpgme-prefix],
++ [AC_HELP_STRING([--with-gpgme-prefix=PATH], [Specify the directory where gpgme install, default /usr])],
++ ,
++ [with_gpgme_prefix="/usr"]
++)
++
++AC_ARG_WITH(
+ [pamdir],
+ [AC_HELP_STRING([--with-pamdir=PATH], [Specify the directory where PAM modules are stored])],
+ [pamdir="${withval}"],
+@@ -233,15 +240,13 @@ if test "${enable_tspi}" = "yes" ; then
+ fi
+
+ if test "${enable_gpg}" = "yes" ; then
+- if test -z "${GPGME_LIBS}"; then
+- AC_ARG_VAR([GPGME_CFLAGS], [C compiler flags for gpg])
+- AC_ARG_VAR([GPGME_LIBS], [linker flags for gpg])
+- AC_CHECK_LIB(
+- [gpgme],
+- [gpgme_new],
+- [GPGME_LIBS="-lgpgme"],
+- [AC_MSG_ERROR([Cannot find gpgme])]
+- )
++ AC_MSG_CHECKING([for gpgme])
++ if ! test -x "${with_gpgme_prefix}/bin/gpgme-config"; then
++ AC_MSG_ERROR([Cannot locate gpgme])
++ else
++ AC_MSG_RESULT([found])
++ GPGME_CFLAGS="`\"${with_gpgme_prefix}/bin/gpgme-config\" --cflags`"
++ GPGME_LIBS="`\"${with_gpgme_prefix}/bin/gpgme-config\" --libs`"
+ fi
+ fi
+
+@@ -280,6 +285,8 @@ AC_SUBST([pamlibdir])
+ AC_SUBST([pkgconfigdir])
+ AC_SUBST([rootsbindir])
+ AC_SUBST([ecryptfskeymoddir])
++AC_SUBST([GPGME_CFLAGS])
++AC_SUBST([GPGME_LIBS])
+ AM_CONDITIONAL([BUILD_OPENSSL], [test "${enable_openssl}" = "yes"])
+ AM_CONDITIONAL([BUILD_PKCS11_HELPER], [test "${enable_pkcs11_helper}" = "yes"])
+ AM_CONDITIONAL([BUILD_TSPI], [test "${enable_tspi}" = "yes"])