summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-08-31 00:01:09 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-08-31 00:01:09 +0000
commit4025c008cd84771eedebe33072d6c263a063b260 (patch)
treec7e9f99663c92530c13825a45c8fb52958409d3a /sys-fs/ecryptfs-utils
parentAdd workaround for bug 380801 (diff)
downloadgentoo-2-4025c008cd84771eedebe33072d6c263a063b260.tar.gz
gentoo-2-4025c008cd84771eedebe33072d6c263a063b260.tar.bz2
gentoo-2-4025c008cd84771eedebe33072d6c263a063b260.zip
Use pkg-config to look up NSS. This allows a clean cross-compilation of the package.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/ecryptfs-utils')
-rw-r--r--sys-fs/ecryptfs-utils/ChangeLog7
-rw-r--r--sys-fs/ecryptfs-utils/ecryptfs-utils-90.ebuild7
-rw-r--r--sys-fs/ecryptfs-utils/files/ecryptfs-utils-90-nss-pkgconfig.patch27
3 files changed, 38 insertions, 3 deletions
diff --git a/sys-fs/ecryptfs-utils/ChangeLog b/sys-fs/ecryptfs-utils/ChangeLog
index 43753efa20d0..d72813e3bf72 100644
--- a/sys-fs/ecryptfs-utils/ChangeLog
+++ b/sys-fs/ecryptfs-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/ecryptfs-utils
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ecryptfs-utils/ChangeLog,v 1.33 2011/08/24 18:01:53 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ecryptfs-utils/ChangeLog,v 1.34 2011/08/31 00:01:08 flameeyes Exp $
+
+ 31 Aug 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ ecryptfs-utils-90.ebuild, +files/ecryptfs-utils-90-nss-pkgconfig.patch:
+ Use pkg-config to look up NSS. This allows a clean cross-compilation of the
+ package.
*ecryptfs-utils-90 (24 Aug 2011)
diff --git a/sys-fs/ecryptfs-utils/ecryptfs-utils-90.ebuild b/sys-fs/ecryptfs-utils/ecryptfs-utils-90.ebuild
index 30bc41de9109..8b8f692340d0 100644
--- a/sys-fs/ecryptfs-utils/ecryptfs-utils-90.ebuild
+++ b/sys-fs/ecryptfs-utils/ecryptfs-utils-90.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ecryptfs-utils/ecryptfs-utils-90.ebuild,v 1.1 2011/08/24 18:01:54 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ecryptfs-utils/ecryptfs-utils-90.ebuild,v 1.2 2011/08/31 00:01:08 flameeyes Exp $
EAPI="3"
PYTHON_DEPEND="python? 2:2.5"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="2.4 3.* *-jython"
-inherit flag-o-matic pam python linux-info
+inherit flag-o-matic pam python linux-info autotools
DESCRIPTION="eCryptfs userspace utilities"
HOMEPAGE="http://launchpad.net/ecryptfs"
@@ -50,6 +50,9 @@ src_prepare() {
# Python bindings are built/installed manually.
sed -e "/SUBDIRS =/s/ libecryptfs-swig//" -i src/Makefile.{am,in} || die "sed failed"
+
+ epatch "${FILESDIR}"/${P}-nss-pkgconfig.patch
+ eautoreconf
}
src_configure() {
diff --git a/sys-fs/ecryptfs-utils/files/ecryptfs-utils-90-nss-pkgconfig.patch b/sys-fs/ecryptfs-utils/files/ecryptfs-utils-90-nss-pkgconfig.patch
new file mode 100644
index 000000000000..b132729ff616
--- /dev/null
+++ b/sys-fs/ecryptfs-utils/files/ecryptfs-utils-90-nss-pkgconfig.patch
@@ -0,0 +1,27 @@
+Index: ecryptfs-utils-90/configure.ac
+===================================================================
+--- ecryptfs-utils-90.orig/configure.ac
++++ ecryptfs-utils-90/configure.ac
+@@ -228,16 +228,12 @@ else
+ fi
+
+ #Verify nss
+-NSS_LIBS=`nss-config --libs`
+-if test "x${NSS_LIBS}" != "x" ; then
+- NSS_CFLAGS=`nss-config --cflags`
+- NSPR_CFLAGS=`nspr-config --cflags`
+- NSS_CFLAGS="${NSS_CFLAGS} -DENABLE_NSS ${NSPR_CFLAGS}"
+- have_nss="yes"
+-else
+- NSS_CFLAGS=""
+- have_nss="no"
+-fi
++PKG_CHECK_MODULES(
++ [NSS],
++ [nss],
++ [have_nss="yes"
++ NSS_CFLAGS="${NSS_CFLAGS} -DENABLE_NSS"],
++ [have_nss="no"])
+
+ if test "${enable_nss}" = "detect" ; then
+ if test "$have_nss" == "yes" ; then