summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2010-08-17 19:47:55 +0000
committerThomas Sachau <tommy@gentoo.org>2010-08-17 19:47:55 +0000
commit809c323ba42cd2282602be44eedb42a34fdd3d3d (patch)
tree4c984e943fb3f5f30243f97294f0a974ff79dc87 /sys-fs/dmraid
parentFix building (and implicits of fstat, mknod and chmod) with recent glibc wrt ... (diff)
downloadgentoo-2-809c323ba42cd2282602be44eedb42a34fdd3d3d.tar.gz
gentoo-2-809c323ba42cd2282602be44eedb42a34fdd3d3d.tar.bz2
gentoo-2-809c323ba42cd2282602be44eedb42a34fdd3d3d.zip
Revision bump, fixes bug 331899 and bug 332737
(Portage version: 2.2_rc67-r8/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/dmraid')
-rw-r--r--sys-fs/dmraid/ChangeLog13
-rw-r--r--sys-fs/dmraid/dmraid-1.0.0_rc15-r1.ebuild75
-rw-r--r--sys-fs/dmraid/dmraid-1.0.0_rc16-r2.ebuild (renamed from sys-fs/dmraid/dmraid-1.0.0_rc16-r1.ebuild)16
-rw-r--r--sys-fs/dmraid/dmraid-1.0.0_rc16.ebuild78
-rw-r--r--sys-fs/dmraid/files/dmraid-1.0.0_rc16-as-needed.patch11
-rw-r--r--sys-fs/dmraid/files/dmraid-1.0.0_rc16-as-needed2.patch11
6 files changed, 34 insertions, 170 deletions
diff --git a/sys-fs/dmraid/ChangeLog b/sys-fs/dmraid/ChangeLog
index d77708e69313..bf3e704ae04f 100644
--- a/sys-fs/dmraid/ChangeLog
+++ b/sys-fs/dmraid/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-fs/dmraid
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dmraid/ChangeLog,v 1.22 2009/12/01 17:03:54 tommy Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dmraid/ChangeLog,v 1.23 2010/08/17 19:47:55 tommy Exp $
+
+*dmraid-1.0.0_rc16-r2 (17 Aug 2010)
+
+ 17 Aug 2010; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ -dmraid-1.0.0_rc15-r1.ebuild, -dmraid-1.0.0_rc16.ebuild,
+ -dmraid-1.0.0_rc16-r1.ebuild, +dmraid-1.0.0_rc16-r2.ebuild,
+ -files/dmraid-1.0.0_rc16-as-needed.patch,
+ +files/dmraid-1.0.0_rc16-as-needed2.patch:
+ Revision bump, fixes bug 331899 and bug 332737
*dmraid-1.0.0_rc16-r1 (01 Dec 2009)
diff --git a/sys-fs/dmraid/dmraid-1.0.0_rc15-r1.ebuild b/sys-fs/dmraid/dmraid-1.0.0_rc15-r1.ebuild
deleted file mode 100644
index 2f96bdf969b3..000000000000
--- a/sys-fs/dmraid/dmraid-1.0.0_rc15-r1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dmraid/dmraid-1.0.0_rc15-r1.ebuild,v 1.1 2009/09/09 21:02:11 tommy Exp $
-
-inherit linux-info flag-o-matic
-
-MY_PV=${PV/_/.}
-
-DESCRIPTION="Device-mapper RAID tool and library"
-HOMEPAGE="http://people.redhat.com/~heinzm/sw/dmraid/"
-SRC_URI="http://people.redhat.com/~heinzm/sw/dmraid/src/${PN}-${MY_PV}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="static selinux"
-
-DEPEND="|| ( >=sys-fs/lvm2-2.02.45
- sys-fs/device-mapper )
- selinux? ( sys-libs/libselinux
- sys-libs/libsepol )"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${PN}/${MY_PV}
-
-pkg_setup() {
- if kernel_is lt 2 6 ; then
- ewarn "You are using a kernel < 2.6"
- ewarn "DMraid uses recently introduced Device-Mapper features."
- ewarn "These might be unavailable in the kernel you are running now."
- fi
- if use static && use selinux ; then
- eerror "ERROR - cannot compile static with libselinux / libsepol"
- die "USE flag conflicts."
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${PN}-destdir-fix.patch"
- epatch "${FILESDIR}/${P}-devsk-isw.patch"
- epatch "${FILESDIR}/${P}-undo-p-rename.patch"
-}
-
-src_compile() {
- econf \
- $(use_enable static static_link) \
- $(use_enable selinux libselinux) \
- $(use_enable selinux libsepol)
- emake -j1 || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc CHANGELOG README TODO KNOWN_BUGS doc/* || die "dodoc failed"
-}
-
-pkg_postinst() {
- einfo "For booting Gentoo from Device-Mapper RAID you can use Genkernel."
- einfo " "
- einfo "Genkernel will generate the kernel and the initrd with a statically "
- einfo "linked dmraid binary (its own version which may not be the same as this version):"
- einfo " emerge -av sys-kernel/genkernel"
- einfo " genkernel --dmraid --udev all"
- einfo " "
- einfo "If you would rather use this version of DMRAID with Genkernel, copy the distfile"
- einfo "from your distdir to '/usr/share/genkernel/pkg/' and update the following"
- einfo "in /etc/genkernel.conf:"
- einfo " DMRAID_VER=\"${MY_PV/_/.}\""
- einfo " DMRAID_SRCTAR=\"\${GK_SHARE}/pkg/${A}\""
- einfo " "
- ewarn "DMRAID should be safe to use, but no warranties can be given"
- einfo " "
-}
diff --git a/sys-fs/dmraid/dmraid-1.0.0_rc16-r1.ebuild b/sys-fs/dmraid/dmraid-1.0.0_rc16-r2.ebuild
index fde3d2219838..1f13a162d37f 100644
--- a/sys-fs/dmraid/dmraid-1.0.0_rc16-r1.ebuild
+++ b/sys-fs/dmraid/dmraid-1.0.0_rc16-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dmraid/dmraid-1.0.0_rc16-r1.ebuild,v 1.1 2009/12/01 17:03:54 tommy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dmraid/dmraid-1.0.0_rc16-r2.ebuild,v 1.1 2010/08/17 19:47:55 tommy Exp $
EAPI="2"
@@ -21,7 +21,8 @@ RDEPEND="|| ( >=sys-fs/lvm2-2.02.45
sys-fs/device-mapper )
selinux? ( sys-libs/libselinux
sys-libs/libsepol )"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ static? ( dev-util/pkgconfig )"
S=${WORKDIR}/${PN}/${MY_PV}
@@ -41,7 +42,14 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-undo-p-rename.patch \
"${FILESDIR}"/${P}-return-all-sets.patch \
"${FILESDIR}"/${PN}-destdir-fix.patch \
- "${FILESDIR}"/${P}-as-needed.patch
+ "${FILESDIR}"/${P}-as-needed2.patch
+
+ if use static; then
+ local myflags
+ myflags=`/usr/bin/pkg-config --libs --static devmapper`
+ sed -i -e "s#^LIBS += -ldl#LIBS += -ldl $myflags#" \
+ tools/Makefile.in || die "sed failed"
+ fi
# archive the patched source for use with genkernel
cd "${WORKDIR}"
diff --git a/sys-fs/dmraid/dmraid-1.0.0_rc16.ebuild b/sys-fs/dmraid/dmraid-1.0.0_rc16.ebuild
deleted file mode 100644
index 45f4d4a7a074..000000000000
--- a/sys-fs/dmraid/dmraid-1.0.0_rc16.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dmraid/dmraid-1.0.0_rc16.ebuild,v 1.1 2009/09/18 14:49:12 tommy Exp $
-
-EAPI="2"
-
-inherit linux-info flag-o-matic
-
-MY_PV=${PV/_/.}
-
-DESCRIPTION="Device-mapper RAID tool and library"
-HOMEPAGE="http://people.redhat.com/~heinzm/sw/dmraid/"
-SRC_URI="http://people.redhat.com/~heinzm/sw/dmraid/src/${PN}-${MY_PV}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="static selinux"
-
-RDEPEND="|| ( >=sys-fs/lvm2-2.02.45
- sys-fs/device-mapper )
- selinux? ( sys-libs/libselinux
- sys-libs/libsepol )"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/${PN}/${MY_PV}
-
-pkg_setup() {
- if kernel_is lt 2 6 ; then
- ewarn "You are using a kernel < 2.6"
- ewarn "DMraid uses recently introduced Device-Mapper features."
- ewarn "These might be unavailable in the kernel you are running now."
- fi
- if use static && use selinux ; then
- eerror "ERROR - cannot compile static with libselinux / libsepol"
- die "USE flag conflicts."
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-undo-p-rename.patch \
- "${FILESDIR}"/${PN}-destdir-fix.patch \
- "${FILESDIR}"/${P}-as-needed.patch
-
- # archive the patched source for use with genkernel
- cd "${WORKDIR}"
- tar -jcf ${PN}-${MY_PV}-prepatched.tar.bz2 ${PN} || die
-}
-
-src_configure() {
- econf \
- $(use_enable static static_link) \
- $(use_enable selinux libselinux) \
- $(use_enable selinux libsepol)
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc CHANGELOG README TODO KNOWN_BUGS doc/* || die "dodoc failed"
- insinto /usr/share/${PN}
- doins "${WORKDIR}"/${PN}-${MY_PV}-prepatched.tar.bz2 || die
-}
-
-pkg_postinst() {
- elog "For booting Gentoo from Device-Mapper RAID you can use Genkernel."
- elog " "
- elog "Genkernel will generate the kernel and the initrd with a statically "
- elog "linked dmraid binary (its own version which may not be the same as this version):"
- elog "\t emerge -av sys-kernel/genkernel"
- elog "\t genkernel --dmraid all"
- elog " "
- elog "If you would rather use this version of DMRAID with Genkernel, update the following"
- elog "in /etc/genkernel.conf:"
- elog "\t DMRAID_VER=\"${MY_PV}\""
- elog "\t DMRAID_SRCTAR=\"/usr/share/${PN}/${PN}-${MY_PV}-prepatched.tar.bz2\""
- elog " "
- ewarn "DMRAID should be safe to use, but no warranties can be given"
-}
diff --git a/sys-fs/dmraid/files/dmraid-1.0.0_rc16-as-needed.patch b/sys-fs/dmraid/files/dmraid-1.0.0_rc16-as-needed.patch
deleted file mode 100644
index b7c0c8b4b990..000000000000
--- a/sys-fs/dmraid/files/dmraid-1.0.0_rc16-as-needed.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- 1.0.0.rc16/make.tmpl.in 2009-09-17 17:40:28.000000000 -0400
-+++ 1.0.0.rc16/make.tmpl.in.new 2009-09-17 17:52:40.000000000 -0400
-@@ -136,7 +136,7 @@
-
- %.so: $(OBJECTS)
- $(CC) -shared -Wl,-soname,$(notdir $@).$(DMRAID_LIB_VERSION) \
-- -Wl,--version-script,.export.sym $(OBJECTS) -o $@ -ldevmapper-event
-+ -Wl,--version-script,.export.sym $(OBJECTS) -o $@ -ldevmapper-event -ldl
-
- $(LIB_STATIC): $(OBJECTS)
- $(RM) $@ \ No newline at end of file
diff --git a/sys-fs/dmraid/files/dmraid-1.0.0_rc16-as-needed2.patch b/sys-fs/dmraid/files/dmraid-1.0.0_rc16-as-needed2.patch
new file mode 100644
index 000000000000..cf3018863ffd
--- /dev/null
+++ b/sys-fs/dmraid/files/dmraid-1.0.0_rc16-as-needed2.patch
@@ -0,0 +1,11 @@
+--- 1.0.0.rc16/make.tmpl.in 2010-08-16 10:22:32.000000000 -0400
++++ 1.0.0.rc16/make.tmpl.in 2010-08-16 10:42:49.000000000 -0400
+@@ -136,7 +136,7 @@
+
+ %.so: $(OBJECTS)
+ $(CC) -shared -Wl,-soname,$(notdir $@).$(DMRAID_LIB_VERSION) \
+- -Wl,--version-script,.export.sym $(OBJECTS) -o $@ -ldevmapper-event
++ $(LDFLAGS) -Wl,--version-script,.export.sym $(OBJECTS) -o $@ -ldevmapper-event -ldl
+
+ $(LIB_STATIC): $(OBJECTS)
+ $(RM) $@