summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2009-07-22 16:04:34 +0000
committerJoseph Jezak <josejx@gentoo.org>2009-07-22 16:04:34 +0000
commit95635f8b5fc1001af7f69ca0c7e66852b66102d0 (patch)
treea98d2f42d47d9155488807c9968d96f848efad78 /sys-fs/diskdev_cmds
parentRename USE cdaudio to USE cdda. (diff)
downloadgentoo-2-95635f8b5fc1001af7f69ca0c7e66852b66102d0.tar.gz
gentoo-2-95635f8b5fc1001af7f69ca0c7e66852b66102d0.tar.bz2
gentoo-2-95635f8b5fc1001af7f69ca0c7e66852b66102d0.zip
Add patch to ensure CFLAGS are respected.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/diskdev_cmds')
-rw-r--r--sys-fs/diskdev_cmds/ChangeLog8
-rw-r--r--sys-fs/diskdev_cmds/diskdev_cmds-332.14_p1.ebuild8
-rw-r--r--sys-fs/diskdev_cmds/files/diskdev_cmds-respect-cflags.patch9
3 files changed, 20 insertions, 5 deletions
diff --git a/sys-fs/diskdev_cmds/ChangeLog b/sys-fs/diskdev_cmds/ChangeLog
index 14a9fed6b879..df565253e00b 100644
--- a/sys-fs/diskdev_cmds/ChangeLog
+++ b/sys-fs/diskdev_cmds/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/diskdev_cmds
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/diskdev_cmds/ChangeLog,v 1.3 2008/12/10 23:35:17 flameeyes Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/diskdev_cmds/ChangeLog,v 1.4 2009/07/22 16:04:34 josejx Exp $
+
+ 22 Jul 2009; Joseph Jezak <josejx@gentoo.org>
+ +files/diskdev_cmds-respect-cflags.patch, diskdev_cmds-332.14_p1.ebuild:
+ Add patch to ensure CFLAGS are respected. Marked ppc stable.
*diskdev_cmds-332.14_p1 (10 Dec 2008)
diff --git a/sys-fs/diskdev_cmds/diskdev_cmds-332.14_p1.ebuild b/sys-fs/diskdev_cmds/diskdev_cmds-332.14_p1.ebuild
index a5c0ef49ef7c..600fd212ce8a 100644
--- a/sys-fs/diskdev_cmds/diskdev_cmds-332.14_p1.ebuild
+++ b/sys-fs/diskdev_cmds/diskdev_cmds-332.14_p1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/diskdev_cmds/diskdev_cmds-332.14_p1.ebuild,v 1.1 2008/12/10 23:35:17 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/diskdev_cmds/diskdev_cmds-332.14_p1.ebuild,v 1.2 2009/07/22 16:04:34 josejx Exp $
inherit eutils
@@ -12,9 +12,10 @@ SRC_URI="http://darwinsource.opendarwin.org/tarballs/apsl/diskdev_cmds-${MY_PV}.
mirror://gentoo/diskdev_cmds-${PV}.patch.bz2"
LICENSE="APSL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86 ~ppc"
+KEYWORDS="~amd64 ppc ~x86"
IUSE=""
DEPEND=""
+RDEPEND="${DEPEND}"
S="${WORKDIR}/${PN}-${MY_PV}"
@@ -22,6 +23,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${WORKDIR}"/diskdev_cmds-${PV}.patch
+ epatch "${FILESDIR}"/diskdev_cmds-respect-cflags.patch
}
src_compile() {
diff --git a/sys-fs/diskdev_cmds/files/diskdev_cmds-respect-cflags.patch b/sys-fs/diskdev_cmds/files/diskdev_cmds-respect-cflags.patch
new file mode 100644
index 000000000000..3f939f61163a
--- /dev/null
+++ b/sys-fs/diskdev_cmds/files/diskdev_cmds-respect-cflags.patch
@@ -0,0 +1,9 @@
+--- Makefile.lnx.bak 2009-07-22 11:58:10.000000000 -0400
++++ Makefile.lnx 2009-07-22 11:57:37.000000000 -0400
+@@ -1,5 +1,5 @@
+ CC := gcc
+-CFLAGS := -g3 -Wall -I$(PWD)/include -DDEBUG_BUILD=0 -D_FILE_OFFSET_BITS=64 -D LINUX=1 -D BSD=1
++CFLAGS += -Wall -I$(PWD)/include -DDEBUG_BUILD=0 -D_FILE_OFFSET_BITS=64 -D LINUX=1 -D BSD=1
+ SUBDIRS := newfs_hfs.tproj fsck_hfs.tproj
+
+ all clean: