summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-02-11 22:03:52 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-02-11 22:03:52 +0000
commit8877ae4bd151ab1ca5a6494b91717d386e218f79 (patch)
tree2b53f25b61f168ad15b4ff640a55cb9cc62aa14f /sys-fs/device-mapper
parentVersion bump to 3.1.6 (diff)
downloadgentoo-2-8877ae4bd151ab1ca5a6494b91717d386e218f79.tar.gz
gentoo-2-8877ae4bd151ab1ca5a6494b91717d386e218f79.tar.bz2
gentoo-2-8877ae4bd151ab1ca5a6494b91717d386e218f79.zip
Fix bug #209705 so that LDFLAGS are respected by the libraries AND binaries.
(Portage version: 2.1.4.1)
Diffstat (limited to 'sys-fs/device-mapper')
-rw-r--r--sys-fs/device-mapper/ChangeLog8
-rw-r--r--sys-fs/device-mapper/device-mapper-1.02.24-r1.ebuild74
2 files changed, 81 insertions, 1 deletions
diff --git a/sys-fs/device-mapper/ChangeLog b/sys-fs/device-mapper/ChangeLog
index 51a0620502e0..4b6c36aea391 100644
--- a/sys-fs/device-mapper/ChangeLog
+++ b/sys-fs/device-mapper/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/device-mapper
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/device-mapper/ChangeLog,v 1.105 2008/02/07 01:54:05 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/device-mapper/ChangeLog,v 1.106 2008/02/11 22:03:52 robbat2 Exp $
+
+*device-mapper-1.02.24-r1 (11 Feb 2008)
+
+ 11 Feb 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +device-mapper-1.02.24-r1.ebuild:
+ Fix bug #209705 so that LDFLAGS are respected by the libraries AND binaries.
*device-mapper-1.02.24 (07 Feb 2008)
diff --git a/sys-fs/device-mapper/device-mapper-1.02.24-r1.ebuild b/sys-fs/device-mapper/device-mapper-1.02.24-r1.ebuild
new file mode 100644
index 000000000000..7494c7339266
--- /dev/null
+++ b/sys-fs/device-mapper/device-mapper-1.02.24-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/device-mapper/device-mapper-1.02.24-r1.ebuild,v 1.1 2008/02/11 22:03:52 robbat2 Exp $
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Device mapper ioctl library for use with LVM2 utilities"
+HOMEPAGE="http://sources.redhat.com/dm/"
+SRC_URI="ftp://sources.redhat.com/pub/dm/${PN}.${PV}.tgz
+ ftp://sources.redhat.com/pub/dm/old/${PN}.${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="selinux"
+
+DEPEND="selinux? ( sys-libs/libselinux )"
+RDEPEND="!<sys-fs/udev-115-r1
+ ${DEPEND}"
+
+S="${WORKDIR}/${PN}.${PV}"
+
+src_unpack() {
+ unpack ${A}
+ EPATCH_OPTS="-p1 -d${S}" epatch "${FILESDIR}"/device-mapper-1.02.24-export-format.diff
+}
+
+src_compile() {
+ econf \
+ --sbindir=/sbin \
+ --enable-dmeventd \
+ $(use_enable selinux) \
+ CLDFLAGS="${LDFLAGS}" || die "econf failed"
+ emake || die "compile problem"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ # move shared libs to /
+ mv "${D}"/usr/$(get_libdir) "${D}"/ || die "move libdir"
+ dolib.a lib/ioctl/libdevmapper.a || die "dolib.a"
+ gen_usr_ldscript libdevmapper.so
+
+ insinto /etc
+ doins "${FILESDIR}"/dmtab
+ insinto /lib/rcscripts/addons
+ doins "${FILESDIR}"/dm-start.sh
+
+ newinitd "${FILESDIR}"/device-mapper.rc-1.02.22-r3 device-mapper || die
+ newconfd "${FILESDIR}"/device-mapper.conf-1.02.22-r3 device-mapper || die
+
+ newinitd "${FILESDIR}"/1.02.22-dmeventd.initd dmeventd || die
+ dolib.a dmeventd/libdevmapper-event.a || die
+ gen_usr_ldscript libdevmapper-event.so
+
+ insinto /etc/udev/rules.d/
+ newins "${FILESDIR}"/64-device-mapper.rules-1.02.22-r5 64-device-mapper.rules
+
+ dodoc INSTALL INTRO README VERSION WHATS_NEW
+}
+
+pkg_preinst() {
+ local l="${ROOT}"/$(get_libdir)/libdevmapper.so.1.01
+ [[ -e ${l} ]] && cp "${l}" "${D}"/$(get_libdir)/
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /$(get_libdir)/libdevmapper.so.1.01
+
+ elog "device-mapper volumes are no longer automatically created for"
+ elog "baselayout-2 users. If you are using baselayout-2, be sure to"
+ elog "run: # rc-update add device-mapper boot"
+}