summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-06-10 09:42:00 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-06-10 09:42:00 +0000
commitba7bf8bca79ebfb9730c6b93a1f15d2b55241cc0 (patch)
treefcc9bce398987973e4280cc4c3335ff0581ddedc /sys-fs/ddrescue
parentVersion bump (diff)
downloadgentoo-2-ba7bf8bca79ebfb9730c6b93a1f15d2b55241cc0.tar.gz
gentoo-2-ba7bf8bca79ebfb9730c6b93a1f15d2b55241cc0.tar.bz2
gentoo-2-ba7bf8bca79ebfb9730c6b93a1f15d2b55241cc0.zip
Version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'sys-fs/ddrescue')
-rw-r--r--sys-fs/ddrescue/ChangeLog7
-rw-r--r--sys-fs/ddrescue/ddrescue-1.18.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/sys-fs/ddrescue/ChangeLog b/sys-fs/ddrescue/ChangeLog
index 9a52c92d795a..59e5df0ea4fc 100644
--- a/sys-fs/ddrescue/ChangeLog
+++ b/sys-fs/ddrescue/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/ddrescue
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ddrescue/ChangeLog,v 1.46 2014/02/27 21:08:15 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ddrescue/ChangeLog,v 1.47 2014/06/10 09:42:00 polynomial-c Exp $
+
+*ddrescue-1.18 (10 Jun 2014)
+
+ 10 Jun 2014; Lars Wendler <polynomial-c@gentoo.org> +ddrescue-1.18.ebuild:
+ Version bump.
27 Feb 2014; Samuli Suominen <ssuominen@gentoo.org> ddrescue-1.17-r1.ebuild:
Use the unpacker_src_uri_depends() function to pull in either pdlzip or lzip
diff --git a/sys-fs/ddrescue/ddrescue-1.18.ebuild b/sys-fs/ddrescue/ddrescue-1.18.ebuild
new file mode 100644
index 000000000000..ddf74696972f
--- /dev/null
+++ b/sys-fs/ddrescue/ddrescue-1.18.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ddrescue/ddrescue-1.18.ebuild,v 1.1 2014/06/10 09:42:00 polynomial-c Exp $
+
+EAPI=5
+
+inherit toolchain-funcs flag-o-matic unpacker
+
+DESCRIPTION="Copy data from one file or block device to another with read-error recovery"
+HOMEPAGE="http://www.gnu.org/software/ddrescue/ddrescue.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.lz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86 ~amd64-linux"
+IUSE="static"
+
+DEPEND="$(unpacker_src_uri_depends)"
+RDEPEND=""
+
+src_configure() {
+ use static && append-ldflags -static
+
+ # not a normal configure script
+ econf \
+ --prefix="${EPREFIX}"/usr \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CFLAGS="${CFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_test() {
+ ./testsuite/check.sh "${S}"/testsuite || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-man
+ dodoc ChangeLog README NEWS AUTHORS
+}