summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2007-03-13 07:38:38 +0000
committerDaniel Black <dragonheart@gentoo.org>2007-03-13 07:38:38 +0000
commitc2a1c404e7655efa973150a7f7960b674f179fef (patch)
treef62e2f0b92d2684774225c74458be64520d60d3b /sys-fs/cowloop/cowloop-3.0-r2.ebuild
parentInit script no longer requires bash. (diff)
downloadgentoo-2-c2a1c404e7655efa973150a7f7960b674f179fef.tar.gz
gentoo-2-c2a1c404e7655efa973150a7f7960b674f179fef.tar.bz2
gentoo-2-c2a1c404e7655efa973150a7f7960b674f179fef.zip
Fixed udev rules thanks to Magnus as per bug #168297
(Portage version: 2.1.2-r11)
Diffstat (limited to 'sys-fs/cowloop/cowloop-3.0-r2.ebuild')
-rw-r--r--sys-fs/cowloop/cowloop-3.0-r2.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/sys-fs/cowloop/cowloop-3.0-r2.ebuild b/sys-fs/cowloop/cowloop-3.0-r2.ebuild
new file mode 100644
index 000000000000..c0e37ddf34b8
--- /dev/null
+++ b/sys-fs/cowloop/cowloop-3.0-r2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cowloop/cowloop-3.0-r2.ebuild,v 1.1 2007/03/13 07:38:38 dragonheart Exp $
+
+inherit linux-mod toolchain-funcs
+
+DESCRIPTION="A copy-on-write loop driver (block device) to be used on top of any other block driver"
+HOMEPAGE="http://www.atconsultancy.nl/cowloop/"
+SRC_URI="http://www.atconsultancy.nl/cowloop/packages/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~ppc x86"
+IUSE=""
+DEPEND="virtual/libc
+ virtual/linux-sources"
+
+S=${WORKDIR}/${P}/src
+MODULE_NAMES="cowloop(fs:)"
+BUILD_TARGETS="modules"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="-C ${KV_DIR} SUBDIRS=${S} -I."
+ einfo "Linux kernel ${KV_FULL}"
+ if kernel_is lt 2 6
+ then
+ eerror "This version only works with 2.6 kernels"
+ eerror "For 2.4 kernel support, use version 1.4"
+ die "No compatible kernel detected!"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-cflags.patch
+ epatch ${FILESDIR}/${P}-config_h.patch
+ epatch ${FILESDIR}/${P}-vfs_statfs.patch
+}
+
+src_compile() {
+ touch .gpl_license_accepted
+ linux-mod_src_compile
+ CC="$(tc-getCC)" emake utils || die "make failed"
+}
+
+src_install() {
+ linux-mod_src_install
+ emake DESTDIR="${D}" install-utils install-man || die 'make failed'
+ dodoc "${S}"/../RELEASENOTES "${S}"/../HOWTO ../doc/*
+ dodir /etc/udev/rules.d
+ echo 'KERNEL=="cowctl" NAME="cow/ctl"' > ${D}/etc/udev/rules.d/70-cow.rules
+ echo 'KERNEL=="cow[0-9]*" NAME="cow/%n"' >> ${D}/etc/udev/rules.d/70-cow.rules
+}