summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom William Payne <twp@gentoo.org>2004-06-27 09:48:35 +0000
committerTom William Payne <twp@gentoo.org>2004-06-27 09:48:35 +0000
commit25f679644208b9ae168233e10759349300687269 (patch)
tree59ae546adfc6ace343a9bb2a1f89bfd604cb702e /sys-fs/convertfs
parentStable x86 amd64. (Manifest recommit) (diff)
downloadgentoo-2-25f679644208b9ae168233e10759349300687269.tar.gz
gentoo-2-25f679644208b9ae168233e10759349300687269.tar.bz2
gentoo-2-25f679644208b9ae168233e10759349300687269.zip
Bug # 55273
Diffstat (limited to 'sys-fs/convertfs')
-rw-r--r--sys-fs/convertfs/ChangeLog9
-rw-r--r--sys-fs/convertfs/Manifest3
-rw-r--r--sys-fs/convertfs/convertfs-20020318-r1.ebuild35
-rw-r--r--sys-fs/convertfs/files/convertfs-20020318-convertfs-paths.patch28
-rw-r--r--sys-fs/convertfs/files/digest-convertfs-20020318-r11
5 files changed, 75 insertions, 1 deletions
diff --git a/sys-fs/convertfs/ChangeLog b/sys-fs/convertfs/ChangeLog
index 35da0d007610..e4573f3bc615 100644
--- a/sys-fs/convertfs/ChangeLog
+++ b/sys-fs/convertfs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/convertfs
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/convertfs/ChangeLog,v 1.3 2004/06/24 22:49:47 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/convertfs/ChangeLog,v 1.4 2004/06/27 09:48:35 twp Exp $
+
+*convertfs-20020318-r1 (27 Jun 2004)
+
+ 27 Jun 2004; <twp@gentoo.org>
+ +files/convertfs-20020318-convertfs-paths.patch,
+ +convertfs-20020318-r1.ebuild:
+ Bug # 55273
06 Mar 2003; Tom Payne <twp@gentoo.org> convertfs-20020318.ebuild :
Fix IUSE. Mark stable on x86.
diff --git a/sys-fs/convertfs/Manifest b/sys-fs/convertfs/Manifest
index 538eb9423ef9..609f73411bb3 100644
--- a/sys-fs/convertfs/Manifest
+++ b/sys-fs/convertfs/Manifest
@@ -1,4 +1,7 @@
+MD5 169d9034fcc8723382a8fa3e61b93c49 convertfs-20020318-r1.ebuild 952
MD5 770a796d7c21ecc7addfaa6bcd73f844 convertfs-20020318.ebuild 891
MD5 935e8526bde181e037410253e1bb9b8e ChangeLog 447
MD5 d992d28bec4a3bfd72b441145091a58e metadata.xml 244
+MD5 616e1ef3c8db68325318527d3a30b260 files/digest-convertfs-20020318-r1 69
+MD5 942615f95e7c6cae8c4c0005c9113727 files/convertfs-20020318-convertfs-paths.patch 993
MD5 616e1ef3c8db68325318527d3a30b260 files/digest-convertfs-20020318 69
diff --git a/sys-fs/convertfs/convertfs-20020318-r1.ebuild b/sys-fs/convertfs/convertfs-20020318-r1.ebuild
new file mode 100644
index 000000000000..21b9ad663e21
--- /dev/null
+++ b/sys-fs/convertfs/convertfs-20020318-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/convertfs/convertfs-20020318-r1.ebuild,v 1.1 2004/06/27 09:48:35 twp Exp $
+
+DESCRIPTION="A tool to convert filesystems in-place"
+HOMEPAGE="http://tzukanov.narod.ru/convertfs/"
+SRC_URI="http://tzukanov.narod.ru/convertfs/convertfs-18mar2002.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+DEPEND="virtual/glibc"
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/convertfs-20020318-convertfs-paths.patch
+ cd ${S}
+ sed -i Makefile -e "s/^\(CFLAGS=\).*\$/\1${CFLAGS}/"
+}
+
+src_compile() {
+ emake devclone devremap prepindex || die
+}
+
+src_install() {
+ into /
+ dosbin convertfs_dumb devclone devremap prepindex contrib/convertfs
+}
+
+pkg_postinst() {
+ ewarn "This tool is HIGHLY DANGEROUS. Read the homepage before using it!"
+ ewarn " ${HOMEPAGE}"
+ ewarn "You have been warned!"
+}
diff --git a/sys-fs/convertfs/files/convertfs-20020318-convertfs-paths.patch b/sys-fs/convertfs/files/convertfs-20020318-convertfs-paths.patch
new file mode 100644
index 000000000000..c02fdb2b51dc
--- /dev/null
+++ b/sys-fs/convertfs/files/convertfs-20020318-convertfs-paths.patch
@@ -0,0 +1,28 @@
+diff -Naur convertfs-20020318/contrib/convertfs convertfs/contrib/convertfs
+--- convertfs-20020318/contrib/convertfs 2002-03-18 17:15:15.000000000 +0100
++++ convertfs/contrib/convertfs 2004-06-27 11:41:49.265225592 +0200
+@@ -192,7 +192,7 @@
+ echo "== Creating clone of \`$from_fs_type' filesystem that's on \`$dev'. =="
+ umount $dev 2>/dev/null
+ mount -t $from_fs_type $dev $fs1root || error
+-./devclone $dev $fsimage || error
++devclone $dev $fsimage || error
+
+ echo "===== Creating destination \`$to_fs_type' filesystem. ====="
+ umount $loopdev 2>/dev/null
+@@ -216,13 +216,13 @@
+ losetup -d $loopdev 2>/dev/null
+
+ echo "=== Preparing info for block relocation ==="
+-./prepindex $fsimage $fsindex $fssuper || error
++prepindex $fsimage $fsindex $fssuper || error
+ umount $dev || error
+ dd if=$fssuper of=$dev || exit
+ sync
+
+ echo "============ Relocating blocks ============"
+-./devremap $dev || exit
++devremap $dev || exit
+
+ echo "=== Filesystem conversion accomplished! ==="
+ rm -rf $tmp
diff --git a/sys-fs/convertfs/files/digest-convertfs-20020318-r1 b/sys-fs/convertfs/files/digest-convertfs-20020318-r1
new file mode 100644
index 000000000000..1c2d75003ed0
--- /dev/null
+++ b/sys-fs/convertfs/files/digest-convertfs-20020318-r1
@@ -0,0 +1 @@
+MD5 10fcab200d3722f008274ed11fe643af convertfs-18mar2002.tar.gz 7451