summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2005-04-27 11:26:02 +0000
committerStefan Schweizer <genstef@gentoo.org>2005-04-27 11:26:02 +0000
commit1e4df5a4686210862ba2e6cf48356298c07273f1 (patch)
tree98cc72f276df78ca84e51ec1e74e4abced3107cf /sys-fs/cloop
parentMarked ppc (diff)
downloadgentoo-2-1e4df5a4686210862ba2e6cf48356298c07273f1.tar.gz
gentoo-2-1e4df5a4686210862ba2e6cf48356298c07273f1.tar.bz2
gentoo-2-1e4df5a4686210862ba2e6cf48356298c07273f1.zip
Move to kernel herd, remove old ebuilds and mark latest ebuild stable thanks to Daniel Webert <rockoo@gmail.com> in bug 90408
(Portage version: 1.586-cvs)
Diffstat (limited to 'sys-fs/cloop')
-rw-r--r--sys-fs/cloop/ChangeLog10
-rw-r--r--sys-fs/cloop/cloop-0.68.ebuild77
-rw-r--r--sys-fs/cloop/cloop-1.0.ebuild67
-rw-r--r--sys-fs/cloop/cloop-1.02.ebuild68
-rw-r--r--sys-fs/cloop/cloop-2.00.ebuild72
-rw-r--r--sys-fs/cloop/cloop-2.01.5-r1.ebuild9
-rw-r--r--sys-fs/cloop/cloop-2.01.5.ebuild73
-rw-r--r--sys-fs/cloop/files/cloop.fix.patch43
-rw-r--r--sys-fs/cloop/files/cloop.zlib-amd64.patch21
-rw-r--r--sys-fs/cloop/files/digest-cloop-0.681
-rw-r--r--sys-fs/cloop/files/digest-cloop-1.01
-rw-r--r--sys-fs/cloop/files/digest-cloop-1.021
-rw-r--r--sys-fs/cloop/files/digest-cloop-2.001
-rw-r--r--sys-fs/cloop/files/digest-cloop-2.01.51
-rw-r--r--sys-fs/cloop/files/kernel-2.6.8-fs_h-fix.patch20
-rw-r--r--sys-fs/cloop/files/kernel26_amd64.patch69
-rw-r--r--sys-fs/cloop/metadata.xml2
17 files changed, 16 insertions, 520 deletions
diff --git a/sys-fs/cloop/ChangeLog b/sys-fs/cloop/ChangeLog
index ca89d540c5e3..9d7c11bd459d 100644
--- a/sys-fs/cloop/ChangeLog
+++ b/sys-fs/cloop/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-fs/cloop
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cloop/ChangeLog,v 1.6 2005/01/12 18:11:53 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cloop/ChangeLog,v 1.7 2005/04/27 11:26:02 genstef Exp $
+
+ 27 Apr 2005; Stefan Schweizer <genstef@gentoo.org>
+ -files/kernel-2.6.8-fs_h-fix.patch, -files/cloop.fix.patch,
+ -files/cloop.zlib-amd64.patch, -files/kernel26_amd64.patch, metadata.xml,
+ -cloop-0.68.ebuild, -cloop-1.0.ebuild, -cloop-1.02.ebuild,
+ -cloop-2.00.ebuild, -cloop-2.01.5.ebuild, cloop-2.01.5-r1.ebuild:
+ Move to kernel herd, remove old ebuilds and mark latest ebuild stable thanks
+ to Daniel Webert <rockoo@gmail.com> in bug 90408
*cloop-2.01.5-r1 (12 Jan 2005)
diff --git a/sys-fs/cloop/cloop-0.68.ebuild b/sys-fs/cloop/cloop-0.68.ebuild
deleted file mode 100644
index 4177f9f34e3c..000000000000
--- a/sys-fs/cloop/cloop-0.68.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cloop/cloop-0.68.ebuild,v 1.2 2005/01/12 18:11:53 genstef Exp $
-
-inherit kernel-mod
-
-MY_PV="${PV}-3"
-MY_P="${PN}_${MY_PV}"
-DESCRIPTION="Compressed filesystem loopback kernel module"
-HOMEPAGE="http://www.knopper.net/knoppix/"
-SRC_URI="http://developer.linuxtag.net/knoppix/sources/${MY_P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86"
-IUSE=""
-DEPEND=""
-
-# Run-time dependencies, same as DEPEND if RDEPEND isn't defined:
-#RDEPEND=""
-
-S=${WORKDIR}/${PN}-${PV}
-
-badversion () {
- eerror "This version of cloop will only compile against Linux 2.4.x"
- eerror "Please change where /usr/src/linux points to, or export the KERNEL_DIR"
- eerror "environment variable like this:"
- eerror
- eerror " KERNEL_DIR=\"<dir>\" emerge cloop"
-
- die "cloop ${PV} only works with Linux 2.4"
-}
-
-badconfig () {
- eerror "You have not enabled the zlib compression and/or decompression options"
- eerror "in your Linux kernel."
- eerror
- eerror "You must configure both options to be compiled into your kernel; cloop"
- eerror "will not compile if the zlib options are compiled as modules"
- die
-}
-
-badconfig_deps () {
- eerror "You must enable one of these kernel configuration options, to"
- eerror "ensure that the kernel's zlib support is included:"
-}
-
-src_compile() {
- kernel-mod_getversion
- [ "$KV_MAJOR" = "2" ] && [ "$KV_MINOR" != "4" ] && badversion
-
- . ${KERNEL_DIR}/.config || die "kernel has not been configured yet"
- [ "$CONFIG_ZLIB_INFLATE" != "y" ] && badconfig
- [ "$CONFIG_ZLIB_DEFLATE" != "y" ] && badconfig
-
- kernel-mod_checkzlibinflate_configured
-
- # cloop is not safe to compile with -j > 1
- MAKEOPTS=-j1
-
- kernel-mod_src_compile
-}
-
-src_install() {
- insinto /lib/modules/$KV_VERSION_FULL/misc
- doins cloop.o
- dobin create_compressed_fs compressloop extract_compressed_fs
- doman debian/create_compressed_fs.1
- dodoc CHANGELOG README
-}
-
-pkg_postinst () {
- einfo "Adding /dev/cloop device"
- if [ -e /dev/cloop ] ; then
- rm -f /dev/cloop
- fi
- mknod /dev/cloop b 240 0 || die
-}
diff --git a/sys-fs/cloop/cloop-1.0.ebuild b/sys-fs/cloop/cloop-1.0.ebuild
deleted file mode 100644
index 07eff6eacf1e..000000000000
--- a/sys-fs/cloop/cloop-1.0.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cloop/cloop-1.0.ebuild,v 1.2 2005/01/12 18:11:53 genstef Exp $
-
-inherit kernel-mod
-
-MY_PV="${PV}-1"
-MY_P="${PN}_${MY_PV}"
-DESCRIPTION="Compressed filesystem loopback kernel module"
-HOMEPAGE="http://www.knopper.net/knoppix/"
-SRC_URI="http://developer.linuxtag.net/knoppix/sources/${MY_P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-DEPEND=""
-
-# Run-time dependencies, same as DEPEND if RDEPEND isn't defined:
-#RDEPEND=""
-
-S=${WORKDIR}/${PN}-${PV}
-
-badversion () {
- eerror "This version of cloop will only compile against Linux 2.4.x"
- eerror "Please change where /usr/src/linux points to, or export the KERNEL_DIR"
- eerror "environment variable like this:"
- eerror
- eerror " KERNEL_DIR=\"<dir>\" emerge cloop"
-
- die "cloop ${PV} only works with Linux 2.4"
-}
-
-badconfig () {
- eerror "You have not enabled the zlib compression and/or decompression options"
- eerror "in your Linux kernel."
- eerror
- eerror "You must configure both options to be compiled into your kernel; cloop"
- eerror "will not compile if the zlib options are compiled as modules"
- die
-}
-
-src_compile() {
- kernel-mod_getversion
- [ "$KV_MAJOR" = "2" ] && [ "$KV_MINOR" != "4" ] && badversion
-
- . ${KERNEL_DIR}/.config || die "kernel has not been configured yet"
- [ "$CONFIG_ZLIB_INFLATE" != "y" ] && badconfig
- [ "$CONFIG_ZLIB_DEFLATE" != "y" ] && badconfig
-
- kernel-mod_src_compile
-}
-
-src_install() {
- insinto /lib/modules/$KV_VERSION_FULL/misc
- doins cloop.o
- dobin create_compressed_fs compressloop
- doman debian/create_compressed_fs.1
- dodoc CHANGELOG README
-}
-
-pkg_postinst () {
- einfo "Adding /dev/cloop device"
- if [ -e /dev/cloop ] ; then
- rm -f /dev/cloop
- fi
- mknod /dev/cloop b 240 0 || die
-}
diff --git a/sys-fs/cloop/cloop-1.02.ebuild b/sys-fs/cloop/cloop-1.02.ebuild
deleted file mode 100644
index 4293dcfe7a2a..000000000000
--- a/sys-fs/cloop/cloop-1.02.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cloop/cloop-1.02.ebuild,v 1.2 2005/01/12 18:11:53 genstef Exp $
-
-inherit kernel-mod
-
-MY_PV="${PV}-1"
-MY_P="${PN}_${MY_PV}"
-DESCRIPTION="Compressed filesystem loopback kernel module"
-HOMEPAGE="http://www.knopper.net/knoppix/"
-SRC_URI="http://developer.linuxtag.net/knoppix/sources/${MY_P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-DEPEND=""
-
-# Run-time dependencies, same as DEPEND if RDEPEND isn't defined:
-#RDEPEND=""
-
-S=${WORKDIR}/${PN}-${PV}
-
-badversion () {
- eerror "This version of cloop will only compile against Linux 2.4.x"
- eerror "Please change where /usr/src/linux points to, or export the KERNEL_DIR"
- eerror "environment variable like this:"
- eerror
- eerror " KERNEL_DIR=\"<dir>\" emerge cloop"
-
- die "cloop ${PV} only works with Linux 2.4"
-}
-
-badconfig () {
- eerror "You have not enabled the zlib compression and/or decompression options"
- eerror "in your Linux kernel."
- eerror
- eerror "You must configure both options to be compiled into your kernel; cloop"
- eerror "will not compile if the zlib options are compiled as modules"
- die
-}
-
-src_compile() {
- kernel-mod_getversion
- [ "$KV_MAJOR" = "2" ] && [ "$KV_MINOR" != "4" ] && badversion
-
- . ${KERNEL_DIR}/.config || die "kernel has not been configured yet"
- [ "$CONFIG_ZLIB_INFLATE" != "y" ] && badconfig
- [ "$CONFIG_ZLIB_DEFLATE" != "y" ] && badconfig
-
- kernel-mod_src_compile
-}
-
-src_install() {
- insinto /lib/modules/$KV_VERSION_FULL/misc
- doins cloop.o
- dobin create_compressed_fs extract_compressed_fs
- cp debian/create_compressed_fs.1 debian/extract_compressed_fs.1
- doman debian/create_compressed_fs.1 debian/extract_compressed_fs.1
- dodoc CHANGELOG README
-}
-
-pkg_postinst () {
- einfo "Adding /dev/cloop device"
- if [ -e /dev/cloop ] ; then
- rm -f /dev/cloop
- fi
- mknod /dev/cloop b 240 0 || die
-}
diff --git a/sys-fs/cloop/cloop-2.00.ebuild b/sys-fs/cloop/cloop-2.00.ebuild
deleted file mode 100644
index ccbdcd9261a0..000000000000
--- a/sys-fs/cloop/cloop-2.00.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cloop/cloop-2.00.ebuild,v 1.2 2005/01/12 18:11:53 genstef Exp $
-
-inherit kernel-mod
-
-MY_PV="${PV}-1"
-MY_P="${PN}_${MY_PV}"
-DESCRIPTION="Compressed filesystem loopback kernel module"
-HOMEPAGE="http://www.knopper.net/knoppix/"
-SRC_URI="http://developer.linuxtag.net/knoppix/sources/${MY_P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-DEPEND=""
-
-# Run-time dependencies, same as DEPEND if RDEPEND isn't defined:
-#RDEPEND=""
-
-S=${WORKDIR}/${PN}-${PV}
-
-badversion () {
- eerror "This version of cloop will only compile against Linux 2.4.x"
- eerror "Please change where /usr/src/linux points to, or export the KERNEL_DIR"
- eerror "environment variable like this:"
- eerror
- eerror " KERNEL_DIR=\"<dir>\" emerge cloop"
-
- die "cloop ${PV} only works with Linux 2.4"
-}
-
-badconfig () {
- eerror "You have not enabled the zlib compression and/or decompression options"
- eerror "in your Linux kernel."
- eerror
- eerror "You must configure both options to be compiled into your kernel; cloop"
- eerror "will not compile if the zlib options are compiled as modules"
- die
-}
-
-src_compile() {
- kernel-mod_getversion
- [ "$KV_MAJOR" = "2" ] && [ "$KV_MINOR" != "4" ] && badversion
-
- . ${KERNEL_DIR}/.config || die "kernel has not been configured yet"
- [ "$CONFIG_ZLIB_INFLATE" != "y" ] && badconfig
- [ "$CONFIG_ZLIB_DEFLATE" != "y" ] && badconfig
-
- kernel-mod_src_compile
-}
-
-src_install() {
- insinto /lib/modules/$KV_VERSION_FULL/misc
- doins cloop.o
- dobin create_compressed_fs extract_compressed_fs
- cp debian/create_compressed_fs.1 debian/extract_compressed_fs.1
- doman debian/create_compressed_fs.1 debian/extract_compressed_fs.1
- dodoc CHANGELOG README
-}
-
-pkg_postinst () {
- einfo "Adding /dev/cloop devices"
- if [ -e /dev/cloop ] ; then
- rm -f /dev/cloop
- fi
- mknod /dev/cloop b 240 0 || die
- if [ -e /dev/cloop1 ] ; then
- rm -f /dev/cloop1
- fi
- mknod /dev/cloop1 b 240 1 || die
-}
diff --git a/sys-fs/cloop/cloop-2.01.5-r1.ebuild b/sys-fs/cloop/cloop-2.01.5-r1.ebuild
index 2a1553aa8045..ad57eb99d387 100644
--- a/sys-fs/cloop/cloop-2.01.5-r1.ebuild
+++ b/sys-fs/cloop/cloop-2.01.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cloop/cloop-2.01.5-r1.ebuild,v 1.1 2005/01/12 18:11:53 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cloop/cloop-2.01.5-r1.ebuild,v 1.2 2005/04/27 11:26:02 genstef Exp $
inherit linux-mod eutils versionator
@@ -9,7 +9,7 @@ HOMEPAGE="http://www.knopper.net/knoppix/"
SRC_URI="http://developer.linuxtag.net/knoppix/sources/${PN}_$(replace_version_separator 2 '-').tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~amd64"
+KEYWORDS="x86 ~amd64"
IUSE=""
S=${WORKDIR}/${PN}-$(get_version_component_range 1-2)
@@ -39,7 +39,10 @@ src_unpack() {
# Remove erroneous 2.4 include
has_version =sys-kernel/linux-headers-2.4.* && \
- sed -i "s:#include <netinet/in.h>::" advancecomp-1.9_create_compressed_fs/advfs.cc
+ sed -i "s:#include <netinet/in.h>::" \
+ advancecomp-1.9_create_compressed_fs/advfs.cc \
+ create_compressed_fs.c \
+ extract_compressed_fs.c
}
src_install() {
diff --git a/sys-fs/cloop/cloop-2.01.5.ebuild b/sys-fs/cloop/cloop-2.01.5.ebuild
deleted file mode 100644
index 717fe31fd460..000000000000
--- a/sys-fs/cloop/cloop-2.01.5.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cloop/cloop-2.01.5.ebuild,v 1.4 2005/01/12 18:11:53 genstef Exp $
-
-inherit kernel-mod eutils versionator
-
-DESCRIPTION="Compressed filesystem loopback kernel module"
-HOMEPAGE="http://www.knopper.net/knoppix/"
-SRC_URI="http://developer.linuxtag.net/knoppix/sources/${PN}_$(replace_version_separator 2 '-').tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE=""
-
-S=${WORKDIR}/${PN}-$(get_version_component_range 1-2)
-
-pkg_setup() {
- if kernel-mod_is_2_4_kernel ;
- then
- kernel-mod_configoption_present ZLIB_DEFLATE || \
- die "You need ZLIB_DEFLATE support in your kernel!"
- fi
- kernel-mod_configoption_present ZLIB_INFLATE || \
- die "You need ZLIB_INFLATE support in your kernel!"
- kernel-mod_check_modules_supported
-}
-
-src_unpack() {
- unpack ${A}
- epatch ${FILESDIR}/kernel26_amd64.patch
- kernel-mod_is_2_6_kernel && [ "${KV_PATCH}" -gt 7 ] && epatch ${FILESDIR}/kernel-2.6.8-fs_h-fix.patch
- cd ${S}
- epatch ${FILESDIR}/cloop.fix.patch
- epatch ${FILESDIR}/cloop.zlib-amd64.patch
-
- # Debian uses conf.vars, everyone else uses .config
- sed -i "s:conf.vars:.config:" Makefile
-
- # Remove erroneous 2.4 include
- kernel-mod_is_2_4_kernel && \
- sed -i "s:#include <netinet/in.h>::" advancecomp-1.9_create_compressed_fs/advfs.cc
-}
-
-src_compile() {
- kernel-mod_src_compile
-}
-
-src_install() {
- insinto /lib/modules/${KV_VERSION_FULL}/misc
- kernel-mod_is_2_4_kernel && doins cloop.o || doins cloop.ko
- dobin create_compressed_fs extract_compressed_fs
- cp debian/create_compressed_fs.1 debian/extract_compressed_fs.1
- doman debian/create_compressed_fs.1 debian/extract_compressed_fs.1
- dodoc CHANGELOG README
-}
-
-pkg_postinst () {
- if kernel-mod_is_2_4_kernel ; then
- einfo "Adding /dev/cloop devices"
- if [ -e /dev/cloop ] ; then
- rm -f /dev/cloop
- fi
- mknod /dev/cloop b 240 0 || die
- if [ -e /dev/cloop1 ] ; then
- rm -f /dev/cloop1
- fi
- mknod /dev/cloop1 b 240 1 || die
- fi
-
- einfo "Checking kernel module dependencies"
- test -r "${ROOT}/usr/src/linux/System.map" && \
- depmod -ae -F "${ROOT}/usr/src/linux/System.map" -b "${ROOT}" -r ${KV}
-}
diff --git a/sys-fs/cloop/files/cloop.fix.patch b/sys-fs/cloop/files/cloop.fix.patch
deleted file mode 100644
index 7b92064eaefe..000000000000
--- a/sys-fs/cloop/files/cloop.fix.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-diff -urN ../tmp-orig/cloop-2.01.4/advancecomp-1.9_create_compressed_fs/7z/AriBitCoder.h ./advancecomp-1.9_create_compressed_fs/7z/AriBitCoder.h
---- ../tmp-orig/cloop-2.01.4/advancecomp-1.9_create_compressed_fs/7z/AriBitCoder.h 2003-02-10 20:25:06.000000000 +0100
-+++ ./advancecomp-1.9_create_compressed_fs/7z/AriBitCoder.h 2004-07-10 15:27:58.225214667 +0200
-@@ -51,13 +51,13 @@
- public:
- void Encode(CRangeEncoder *aRangeEncoder, UINT32 aSymbol)
- {
-- aRangeEncoder->EncodeBit(m_Probability, kNumBitModelTotalBits, aSymbol);
-- UpdateModel(aSymbol);
-+ aRangeEncoder->EncodeBit(this->m_Probability, kNumBitModelTotalBits, aSymbol);
-+ this->UpdateModel(aSymbol);
- }
- UINT32 GetPrice(UINT32 aSymbol) const
- {
- return g_PriceTables.m_StatePrices[
-- (((m_Probability - aSymbol) ^ ((-(int)aSymbol))) & (kBitModelTotal - 1)) >> kNumMoveReducingBits];
-+ (((this->m_Probability - aSymbol) ^ ((-(int)aSymbol))) & (kBitModelTotal - 1)) >> kNumMoveReducingBits];
- }
- };
-
-@@ -68,11 +68,11 @@
- public:
- UINT32 Decode(CRangeDecoder *aRangeDecoder)
- {
-- UINT32 aNewBound = (aRangeDecoder->m_Range >> kNumBitModelTotalBits) * m_Probability;
-+ UINT32 aNewBound = (aRangeDecoder->m_Range >> kNumBitModelTotalBits) * this->m_Probability;
- if (aRangeDecoder->m_Code < aNewBound)
- {
- aRangeDecoder->m_Range = aNewBound;
-- m_Probability += (kBitModelTotal - m_Probability) >> aNumMoveBits;
-+ this->m_Probability += (kBitModelTotal - this->m_Probability) >> aNumMoveBits;
- if (aRangeDecoder->m_Range < kTopValue)
- {
- aRangeDecoder->m_Code = (aRangeDecoder->m_Code << 8) | aRangeDecoder->m_Stream.ReadByte();
-@@ -84,7 +84,7 @@
- {
- aRangeDecoder->m_Range -= aNewBound;
- aRangeDecoder->m_Code -= aNewBound;
-- m_Probability -= (m_Probability) >> aNumMoveBits;
-+ this->m_Probability -= (this->m_Probability) >> aNumMoveBits;
- if (aRangeDecoder->m_Range < kTopValue)
- {
- aRangeDecoder->m_Code = (aRangeDecoder->m_Code << 8) | aRangeDecoder->m_Stream.ReadByte();
diff --git a/sys-fs/cloop/files/cloop.zlib-amd64.patch b/sys-fs/cloop/files/cloop.zlib-amd64.patch
deleted file mode 100644
index f6f024556ea1..000000000000
--- a/sys-fs/cloop/files/cloop.zlib-amd64.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- cloop-2.01/advancecomp-1.9_create_compressed_fs/advfs.cc 2004-04-18 16:33:29.000000000 -0400
-+++ cloop-2.01.new/advancecomp-1.9_create_compressed_fs/advfs.cc 2004-11-23 18:04:49.859941344 -0500
-@@ -81,7 +81,7 @@
- {
- int z_error;
- unsigned long total=0;
-- unsigned len[maxalg];
-+ uLong len[maxalg];
- unsigned int best;
- //memset(compressed,0,len); memset(uncompressed,0,blocksize);
- for(j=0; j<maxalg; j++) memset(compressed[j],0,maxlen), len[j]=maxlen;
-@@ -111,7 +111,8 @@
- }
-
- /* Try 7ZIP compression now. */
-- if(!compress_zlib(shrink_extreme, (unsigned char *)compressed[maxalg-1], len[maxalg-1], (unsigned char *)uncompressed, blocksize))
-+ unsigned zlib_length=(unsigned int)len[maxalg-1];
-+ if(!compress_zlib(shrink_extreme, (unsigned char *)compressed[maxalg-1], zlib_length, (unsigned char *)uncompressed, blocksize))
- {
- fprintf(stderr, "*** Error %d compressing block %lu! (compressed=%p, len=%lu, uncompressed=%p, blocksize=%lu)\n", z_error, i, compressed,len,uncompressed,blocksize);
- goto error_free_cb_list;
diff --git a/sys-fs/cloop/files/digest-cloop-0.68 b/sys-fs/cloop/files/digest-cloop-0.68
deleted file mode 100644
index d953921d04f6..000000000000
--- a/sys-fs/cloop/files/digest-cloop-0.68
+++ /dev/null
@@ -1 +0,0 @@
-MD5 526b850ebe9296373471f8fd9d60ddff cloop_0.68-3.tar.gz 213474
diff --git a/sys-fs/cloop/files/digest-cloop-1.0 b/sys-fs/cloop/files/digest-cloop-1.0
deleted file mode 100644
index 8578ca866b69..000000000000
--- a/sys-fs/cloop/files/digest-cloop-1.0
+++ /dev/null
@@ -1 +0,0 @@
-MD5 f88034ddcd74dab779ce029964c16766 cloop_1.0-1.tar.gz 32246
diff --git a/sys-fs/cloop/files/digest-cloop-1.02 b/sys-fs/cloop/files/digest-cloop-1.02
deleted file mode 100644
index 107b9855fbff..000000000000
--- a/sys-fs/cloop/files/digest-cloop-1.02
+++ /dev/null
@@ -1 +0,0 @@
-MD5 bf5423599eb39d8bf068b0261d39339b cloop_1.02-1.tar.gz 20156
diff --git a/sys-fs/cloop/files/digest-cloop-2.00 b/sys-fs/cloop/files/digest-cloop-2.00
deleted file mode 100644
index 1e61447e13c1..000000000000
--- a/sys-fs/cloop/files/digest-cloop-2.00
+++ /dev/null
@@ -1 +0,0 @@
-MD5 a18f5d97bae863b823c42cf6722ef769 cloop_2.00-1.tar.gz 21583
diff --git a/sys-fs/cloop/files/digest-cloop-2.01.5 b/sys-fs/cloop/files/digest-cloop-2.01.5
deleted file mode 100644
index cc0eb187161d..000000000000
--- a/sys-fs/cloop/files/digest-cloop-2.01.5
+++ /dev/null
@@ -1 +0,0 @@
-MD5 38daf7faba0427fed469137bca917c1c cloop_2.01-5.tar.gz 428324
diff --git a/sys-fs/cloop/files/kernel-2.6.8-fs_h-fix.patch b/sys-fs/cloop/files/kernel-2.6.8-fs_h-fix.patch
deleted file mode 100644
index eb9e359844ac..000000000000
--- a/sys-fs/cloop/files/kernel-2.6.8-fs_h-fix.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- cloop-2.01/compressed_loop.c.orig 2004-05-14 15:22:47.000000000 -0400
-+++ cloop-2.01/compressed_loop.c 2004-11-22 11:32:45.772837000 -0500
-@@ -202,7 +202,7 @@
- unsigned long offset, unsigned long size)
- {
- char *kaddr;
-- struct clo_read_data *p = (struct clo_read_data*)desc->buf;
-+ struct clo_read_data *p = (struct clo_read_data*)desc->arg.buf;
- unsigned long count = desc->count;
- if (size > count) size = count;
- kaddr = kmap(page);
-@@ -228,7 +228,7 @@
- read_descriptor_t desc;
- desc.written = 0;
- desc.count = size;
-- desc.buf = (char*)&cd;
-+ desc.arg.buf = (char*)&cd;
- desc.error = 0;
- #ifdef REDHAT_KERNEL /* Greenshoe Linux */
- do_generic_file_read(f, &pos, &desc, clo_read_actor, 0);
diff --git a/sys-fs/cloop/files/kernel26_amd64.patch b/sys-fs/cloop/files/kernel26_amd64.patch
deleted file mode 100644
index 464915ae5e49..000000000000
--- a/sys-fs/cloop/files/kernel26_amd64.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-diff -ru cloop-2.01/Makefile cloop-2.01.new/Makefile
---- cloop-2.01/Makefile 2004-05-14 14:17:51.000000000 -0500
-+++ cloop-2.01.new/Makefile 2004-07-21 16:26:59.167257880 -0500
-@@ -1,18 +1,51 @@
- #!/usr/bin/make
-
--KERNEL_DIR=/usr/src/linux
-+KVERSION=$(shell uname -r)
-+MACHINE=$(shell uname -m)
-+KERNEL_DIR=/lib/modules/$(KVERSION)/build
-+KERNEL_INCLUDE=$(KERNEL_DIR)/include
-+INCLUDE_26:=-include $(KERNEL_INCLUDE)/config/modversions.h -include $(KERNEL_INCLUDE)/linux/version.h
-+INCLUDE_24:=-include $(KERNEL_INCLUDE)/linux/modversions.h
-+
-+file_exist=$(shell test -f $(1) && echo yes || echo no)
-+
-+# test for 2.6 or 2.4 kernel
-+ifeq ($(call file_exist,$(KERNEL_DIR)/Rules.make), yes)
-+PATCHLEVEL:=4
-+else
-+PATCHLEVEL:=6
-+endif
-
- ifdef APPSONLY
- CFLAGS:=-Wall -Wstrict-prototypes -Wno-trigraphs -O2 -s -I. -fno-strict-aliasing -fno-common -fomit-frame-pointer
- else
--include $(KERNEL_DIR)/.config
-+ifeq ($(PATCHLEVEL),4)
- include $(KERNEL_DIR)/conf.vars
-+else
-+include $(KERNEL_DIR)/.config
-+endif
- endif
-
- CKERNOPS:=-D__KERNEL__ -DMODULE -fno-builtin -nostdlib -DKBUILD_MODNAME="cloop" -DKBUILD_BASENAME="cloop"
-
-+# I needed this for my amd64 system running 2.6.7
-+# it maybe required for 2.6, so I add it here
-+ifeq ($(PATCHLEVEL),6)
-+CKERNOPS+= -D__OPTIMIZE__
-+endif
-+
-+# check for amd64
-+ifeq ($(MACHINE),x86_64)
-+CKERNOPS+=-mno-red-zone -mcmodel=kernel
-+endif
-+
- ifdef CONFIG_MODVERSIONS
--MODVERSIONS:= -DMODVERSIONS -include $(KERNEL_DIR)/include/linux/modversions.h
-+MODVERSIONS:= -DMODVERSIONS
-+ifeq ($(PATCHLEVEL),4)
-+MODVERSIONS+=$(INCLUDE_24)
-+else
-+MODVERSIONS+=$(INCLUDE_26)
-+endif
- CKERNOPS += $(MODVERSIONS)
- endif
-
-diff -ru cloop-2.01/advancecomp-1.9_create_compressed_fs/advfs.cc cloop-2.01.new/advancecomp-1.9_create_compressed_fs/advfs.cc
---- cloop-2.01/advancecomp-1.9_create_compressed_fs/advfs.cc 2004-04-18 15:33:29.000000000 -0500
-+++ cloop-2.01.new/advancecomp-1.9_create_compressed_fs/advfs.cc 2004-07-20 11:55:28.000000000 -0500
-@@ -30,6 +30,7 @@
- #include "utility.h"
- #include "compress.h"
- #include "siglock.h"
-+#define __OPTIMIZE__
- #include <netinet/in.h>
-
- #include "lib/mng.h"
diff --git a/sys-fs/cloop/metadata.xml b/sys-fs/cloop/metadata.xml
index 209f080820d9..c8f81b37cf66 100644
--- a/sys-fs/cloop/metadata.xml
+++ b/sys-fs/cloop/metadata.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>base-system</herd>
+ <herd>kernel</herd>
<maintainer>
<email>genstef@gentoo.org</email>
<name>Stefan Schweizer</name>