summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-06-17 17:29:26 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-06-17 17:29:26 +0000
commit3d0519f4ba7d453d9eabc4e3e0665542d4b1f6b0 (patch)
treeefc7b0b2119b2f4ce1a76756402911c2693e093a /sys-fs/clamfs
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-3d0519f4ba7d453d9eabc4e3e0665542d4b1f6b0.tar.gz
gentoo-2-3d0519f4ba7d453d9eabc4e3e0665542d4b1f6b0.tar.bz2
gentoo-2-3d0519f4ba7d453d9eabc4e3e0665542d4b1f6b0.zip
Fixed gcc-4.5 issue, bug #320107.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/clamfs')
-rw-r--r--sys-fs/clamfs/ChangeLog8
-rw-r--r--sys-fs/clamfs/clamfs-1.0.1-r1.ebuild43
-rw-r--r--sys-fs/clamfs/files/clamfs-1.0.1-gcc45.patch15
3 files changed, 65 insertions, 1 deletions
diff --git a/sys-fs/clamfs/ChangeLog b/sys-fs/clamfs/ChangeLog
index cb7cd56bd248..dc317ecd51cf 100644
--- a/sys-fs/clamfs/ChangeLog
+++ b/sys-fs/clamfs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/clamfs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/clamfs/ChangeLog,v 1.1 2010/01/08 16:29:26 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/clamfs/ChangeLog,v 1.2 2010/06/17 17:29:26 matsuu Exp $
+
+*clamfs-1.0.1-r1 (17 Jun 2010)
+
+ 17 Jun 2010; MATSUU Takuto <matsuu@gentoo.org> +clamfs-1.0.1-r1.ebuild,
+ +files/clamfs-1.0.1-gcc45.patch:
+ Fixed gcc-4.5 issue, bug #320107.
*clamfs-1.0.1 (08 Jan 2010)
diff --git a/sys-fs/clamfs/clamfs-1.0.1-r1.ebuild b/sys-fs/clamfs/clamfs-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..a97c5a988546
--- /dev/null
+++ b/sys-fs/clamfs/clamfs-1.0.1-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/clamfs/clamfs-1.0.1-r1.ebuild,v 1.1 2010/06/17 17:29:26 matsuu Exp $
+
+EAPI="2"
+inherit eutils linux-info
+
+DESCRIPTION="A FUSE-based user-space file system with on-access anti-virus file scanning"
+HOMEPAGE="http://clamfs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/boost-1.33
+ sys-fs/fuse
+ dev-cpp/commoncpp2
+ dev-libs/rlog
+ dev-libs/poco"
+RDEPEND="${DEPEND}
+ app-antivirus/clamav"
+
+CONFIG_CHECK="~FUSE_FS"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/${P}-gentoo.patch" \
+ "${FILESDIR}/${P}-gcc45.patch"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+
+ insinto /etc/clamfs
+ doins doc/clamfs.xml || die
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN} || die
+ newconfd "${FILESDIR}/${PN}.confd" ${PN} || die
+
+ dodoc AUTHORS ChangeLog NEWS README TODO || die
+}
diff --git a/sys-fs/clamfs/files/clamfs-1.0.1-gcc45.patch b/sys-fs/clamfs/files/clamfs-1.0.1-gcc45.patch
new file mode 100644
index 000000000000..1f5f63a252f2
--- /dev/null
+++ b/sys-fs/clamfs/files/clamfs-1.0.1-gcc45.patch
@@ -0,0 +1,15 @@
+Fix building with gcc 4.5
+
+http://bugs.gentoo.org/show_bug.cgi?id=320107
+
+--- src/scancache.cxx
++++ src/scancache.cxx
+@@ -37,7 +37,7 @@
+ }
+
+ ScanCache::ScanCache(long int elements, long int expire):
+- ExpireLRUCache<ino_t, CachedResult>::ExpireLRUCache<ino_t, CachedResult>(elements, expire) {
++ ExpireLRUCache<ino_t, CachedResult>(elements, expire) {
+ }
+
+ ScanCache::~ScanCache() {