summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Peterson <lavajoe@gentoo.org>2008-06-07 16:38:36 +0000
committerJoe Peterson <lavajoe@gentoo.org>2008-06-07 16:38:36 +0000
commit1035ce625e7260f1467ed6bc358e66f8ca99683e (patch)
tree2aa8a2d5c759b70c94f27496d67d26975eb122bc /sys-fs/btrfs
parentUpdate homepage and SRC_URI (diff)
downloadgentoo-2-1035ce625e7260f1467ed6bc358e66f8ca99683e.tar.gz
gentoo-2-1035ce625e7260f1467ed6bc358e66f8ca99683e.tar.bz2
gentoo-2-1035ce625e7260f1467ed6bc358e66f8ca99683e.zip
Patch to fix preserving file/dir modes by disabling ACLs
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-fs/btrfs')
-rw-r--r--sys-fs/btrfs/ChangeLog8
-rw-r--r--sys-fs/btrfs/btrfs-0.15-r1.ebuild61
-rw-r--r--sys-fs/btrfs/files/btrfs-0.15-acl-disable.patch31
3 files changed, 99 insertions, 1 deletions
diff --git a/sys-fs/btrfs/ChangeLog b/sys-fs/btrfs/ChangeLog
index 3c84e10acaa8..1032b9476576 100644
--- a/sys-fs/btrfs/ChangeLog
+++ b/sys-fs/btrfs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/btrfs
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/btrfs/ChangeLog,v 1.3 2008/05/29 16:59:52 lavajoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/btrfs/ChangeLog,v 1.4 2008/06/07 16:38:35 lavajoe Exp $
+
+*btrfs-0.15-r1 (07 Jun 2008)
+
+ 07 Jun 2008; Joe Peterson <lavajoe@gentoo.org>
+ +files/btrfs-0.15-acl-disable.patch, +btrfs-0.15-r1.ebuild:
+ Patch to fix preserving file/dir modes by disabling ACLs
*btrfs-0.15 (29 May 2008)
diff --git a/sys-fs/btrfs/btrfs-0.15-r1.ebuild b/sys-fs/btrfs/btrfs-0.15-r1.ebuild
new file mode 100644
index 000000000000..63ef6287dd63
--- /dev/null
+++ b/sys-fs/btrfs/btrfs-0.15-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/btrfs/btrfs-0.15-r1.ebuild,v 1.1 2008/06/07 16:38:35 lavajoe Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="A checksumming copy-on-write filesystem"
+HOMEPAGE="http://btrfs.wiki.kernel.org/"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/people/mason/btrfs/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-fs/e2fsprogs"
+PDEPEND="~sys-fs/btrfs-progs-${PV}"
+
+pkg_setup()
+{
+ linux-mod_pkg_setup
+
+ BUILD_TARGETS="all"
+ BUILD_PARAMS="KERNELDIR=/lib/modules/${KV_FULL}/build"
+ MODULE_NAMES="btrfs(fs:${S}/"
+
+ if ! kernel_is 2 6; then
+ eerror "Need a 2.6 kernel to compile against!"
+ die "Need a 2.6 kernel to compile against!"
+ fi
+
+ if ! linux_chkconfig_present LIBCRC32C; then
+ eerror "You need to enable LIBCRC32C in your kernel!"
+ die "You need to enable LIBCRC32C in your kernel!"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-acl-disable.patch"
+}
+
+src_install()
+{
+ linux-mod_src_install
+
+ dodoc INSTALL TODO
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ ewarn "WARNING: Btrfs is under heavy development and is not suitable for"
+ ewarn "any uses other than benchmarking and review."
+ ewarn "The Btrfs disk format is not yet finalized."
+ ewarn ""
+ ewarn "Note: If upgrading from 0.14, there is no disk format change,"
+ ewarn " but it might be prudent to fsck after upgrading."
+}
diff --git a/sys-fs/btrfs/files/btrfs-0.15-acl-disable.patch b/sys-fs/btrfs/files/btrfs-0.15-acl-disable.patch
new file mode 100644
index 000000000000..e6dae4b314c6
--- /dev/null
+++ b/sys-fs/btrfs/files/btrfs-0.15-acl-disable.patch
@@ -0,0 +1,31 @@
+--- btrfs-0.15/xattr.c.orig 2008-06-03 11:11:03.000000000 -0600
++++ btrfs-0.15/xattr.c 2008-06-03 11:11:23.000000000 -0600
+@@ -29,22 +29,22 @@
+ static struct xattr_handler *btrfs_xattr_handler_map[] = {
+ [BTRFS_XATTR_INDEX_USER] = &btrfs_xattr_user_handler,
+ #ifdef CONFIG_FS_POSIX_ACL
+- [BTRFS_XATTR_INDEX_POSIX_ACL_ACCESS] = &btrfs_xattr_acl_access_handler,
+- [BTRFS_XATTR_INDEX_POSIX_ACL_DEFAULT] = &btrfs_xattr_acl_default_handler,
++// [BTRFS_XATTR_INDEX_POSIX_ACL_ACCESS] = &btrfs_xattr_acl_access_handler,
++// [BTRFS_XATTR_INDEX_POSIX_ACL_DEFAULT] = &btrfs_xattr_acl_default_handler,
+ #endif
+ [BTRFS_XATTR_INDEX_TRUSTED] = &btrfs_xattr_trusted_handler,
+ [BTRFS_XATTR_INDEX_SECURITY] = &btrfs_xattr_security_handler,
+- [BTRFS_XATTR_INDEX_SYSTEM] = &btrfs_xattr_system_handler,
++// [BTRFS_XATTR_INDEX_SYSTEM] = &btrfs_xattr_system_handler,
+ };
+ struct xattr_handler *btrfs_xattr_handlers[] = {
+ &btrfs_xattr_user_handler,
+ #ifdef CONFIG_FS_POSIX_ACL
+- &btrfs_xattr_acl_access_handler,
+- &btrfs_xattr_acl_default_handler,
++// &btrfs_xattr_acl_access_handler,
++// &btrfs_xattr_acl_default_handler,
+ #endif
+ &btrfs_xattr_trusted_handler,
+ &btrfs_xattr_security_handler,
+- &btrfs_xattr_system_handler,
++// &btrfs_xattr_system_handler,
+ NULL,
+ };
+