summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-10-16 13:59:51 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-10-16 13:59:51 +0000
commit461cb3afc2fcb8943a164bb9303d14ec7da16cdf (patch)
treec4177ad350dd4a627875ec958155af32fb41d6a2 /sys-fs/bleachbit
parentInitial commit. (diff)
downloadgentoo-2-461cb3afc2fcb8943a164bb9303d14ec7da16cdf.tar.gz
gentoo-2-461cb3afc2fcb8943a164bb9303d14ec7da16cdf.tar.bz2
gentoo-2-461cb3afc2fcb8943a164bb9303d14ec7da16cdf.zip
Missing PYTHON_USE_WITH="sqlite" and USE="nls" support.
(Portage version: 2.2.0_alpha67/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/bleachbit')
-rw-r--r--sys-fs/bleachbit/ChangeLog5
-rw-r--r--sys-fs/bleachbit/bleachbit-0.9.0.ebuild14
2 files changed, 15 insertions, 4 deletions
diff --git a/sys-fs/bleachbit/ChangeLog b/sys-fs/bleachbit/ChangeLog
index ff5682c2e558..c52bf123ff34 100644
--- a/sys-fs/bleachbit/ChangeLog
+++ b/sys-fs/bleachbit/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-fs/bleachbit
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/bleachbit/ChangeLog,v 1.1 2011/10/16 13:54:55 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/bleachbit/ChangeLog,v 1.2 2011/10/16 13:59:51 ssuominen Exp $
+
+ 16 Oct 2011; Samuli Suominen <ssuominen@gentoo.org> bleachbit-0.9.0.ebuild:
+ Missing PYTHON_USE_WITH="sqlite" and USE="nls" support.
*bleachbit-0.9.0 (16 Oct 2011)
diff --git a/sys-fs/bleachbit/bleachbit-0.9.0.ebuild b/sys-fs/bleachbit/bleachbit-0.9.0.ebuild
index 8481fc6217be..ea4e684e9715 100644
--- a/sys-fs/bleachbit/bleachbit-0.9.0.ebuild
+++ b/sys-fs/bleachbit/bleachbit-0.9.0.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/bleachbit/bleachbit-0.9.0.ebuild,v 1.1 2011/10/16 13:54:55 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/bleachbit/bleachbit-0.9.0.ebuild,v 1.2 2011/10/16 13:59:51 ssuominen Exp $
EAPI=4
PYTHON_DEPEND="2"
+PYTHON_USE_WITH="sqlite"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.*"
@@ -17,10 +18,11 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="nls"
RDEPEND=">=dev-python/pygtk-2"
-DEPEND="${DEPEND}"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
DOCS="README"
@@ -33,8 +35,14 @@ src_prepare() {
distutils_src_prepare
}
+src_compile() {
+ distutils_src_compile
+ use nls && emake -C po
+}
+
src_install() {
distutils_src_install
+ use nls && emake -C po DESTDIR="${D}" install
newbin ${PN}.py ${PN}