summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-10-17 13:16:58 +0000
committerRoy Marples <uberlord@gentoo.org>2006-10-17 13:16:58 +0000
commita328bc20aaaea43c73e9ff632c6dc880ac0957af (patch)
tree0e491e5c6c9b0a70590b003a73e349dc986fb591 /sys-freebsd
parentNew snapshot (diff)
downloadgentoo-2-a328bc20aaaea43c73e9ff632c6dc880ac0957af.tar.gz
gentoo-2-a328bc20aaaea43c73e9ff632c6dc880ac0957af.tar.bz2
gentoo-2-a328bc20aaaea43c73e9ff632c6dc880ac0957af.zip
Add warning about using kldload on sparc
(Portage version: 2.1.2_pre3-r3)
Diffstat (limited to 'sys-freebsd')
-rw-r--r--sys-freebsd/freebsd-sources/freebsd-sources-6.2_beta2.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/sys-freebsd/freebsd-sources/freebsd-sources-6.2_beta2.ebuild b/sys-freebsd/freebsd-sources/freebsd-sources-6.2_beta2.ebuild
index ee546cd134a6..b1b32e74760e 100644
--- a/sys-freebsd/freebsd-sources/freebsd-sources-6.2_beta2.ebuild
+++ b/sys-freebsd/freebsd-sources/freebsd-sources-6.2_beta2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-sources/freebsd-sources-6.2_beta2.ebuild,v 1.2 2006/10/17 09:55:56 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-sources/freebsd-sources-6.2_beta2.ebuild,v 1.3 2006/10/17 13:16:58 uberlord Exp $
inherit bsdmk freebsd flag-o-matic
@@ -76,4 +76,11 @@ pkg_postinst() {
ln -sf "sys-${MY_PVR}" "${ROOT}/usr/src/sys-${RV}" || \
eerror "Couldn't create ${ROOT}/usr/src/sys-${RV} symlink."
fi
+
+ if use sparc-fbsd ; then
+ ewarn "WARNING: kldload currently causes kernel panics"
+ ewarn "on sparc64. This is probably a gcc-4.1 issue, but"
+ ewarn "we need gcc-4.1 to compile the kernel correctly :/"
+ ewarn "Please compile all modules you need into the kernel"
+ fi
}