summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-09-22 09:28:09 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-09-22 09:28:09 +0000
commit82e3ee3983dc998128d41895fca499fa13d6219d (patch)
tree6ec7e14460825ae387494eacf885a09de05a0c76 /sys-freebsd
parentCorrect fpc-ide-2.0.4's DESCRIPTION (diff)
downloadgentoo-2-82e3ee3983dc998128d41895fca499fa13d6219d.tar.gz
gentoo-2-82e3ee3983dc998128d41895fca499fa13d6219d.tar.bz2
gentoo-2-82e3ee3983dc998128d41895fca499fa13d6219d.zip
Add new patch for rpcgen that fix it properly.
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'sys-freebsd')
-rw-r--r--sys-freebsd/freebsd-ubin/ChangeLog7
-rw-r--r--sys-freebsd/freebsd-ubin/files/freebsd-ubin-6.2-rpcgen-gcc4.1.patch131
-rw-r--r--sys-freebsd/freebsd-ubin/freebsd-ubin-6.2_beta1.ebuild6
3 files changed, 140 insertions, 4 deletions
diff --git a/sys-freebsd/freebsd-ubin/ChangeLog b/sys-freebsd/freebsd-ubin/ChangeLog
index c91090d5a725..b5f732625a8f 100644
--- a/sys-freebsd/freebsd-ubin/ChangeLog
+++ b/sys-freebsd/freebsd-ubin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-freebsd/freebsd-ubin
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-ubin/ChangeLog,v 1.23 2006/09/21 21:01:47 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-ubin/ChangeLog,v 1.24 2006/09/22 09:28:09 flameeyes Exp $
+
+ 22 Sep 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/freebsd-ubin-6.2-rpcgen-gcc4.1.patch,
+ freebsd-ubin-6.2_beta1.ebuild:
+ Add new patch for rpcgen that fix it properly.
*freebsd-ubin-6.2_beta1 (21 Sep 2006)
diff --git a/sys-freebsd/freebsd-ubin/files/freebsd-ubin-6.2-rpcgen-gcc4.1.patch b/sys-freebsd/freebsd-ubin/files/freebsd-ubin-6.2-rpcgen-gcc4.1.patch
new file mode 100644
index 000000000000..fffd69ebbde4
--- /dev/null
+++ b/sys-freebsd/freebsd-ubin/files/freebsd-ubin-6.2-rpcgen-gcc4.1.patch
@@ -0,0 +1,131 @@
+Index: fbsd-6.2/usr.bin/rpcgen/rpc_hout.c
+===================================================================
+--- fbsd-6.2.orig/usr.bin/rpcgen/rpc_hout.c
++++ fbsd-6.2/usr.bin/rpcgen/rpc_hout.c
+@@ -50,7 +50,7 @@ void storexdrfuncdecl( char *, int );
+ static void pconstdef( definition * );
+ static void pstructdef( definition * );
+ static void puniondef( definition * );
+-static void pprogramdef( definition *, int );
++static void pprogramdef( definition *, int, int );
+ static void pstructdef( definition * );
+ static void penumdef( definition * );
+ static void ptypedef( definition * );
+@@ -64,7 +64,7 @@ void pdeclaration( char *, declaration *
+ * Print the C-version of an xdr definition
+ */
+ void
+-print_datadef(definition *def, int headeronly)
++print_datadef(definition *def, int headeronly, int nomain)
+ {
+
+ if (def->def_kind == DEF_PROGRAM) /* handle data only */
+@@ -87,7 +87,7 @@ print_datadef(definition *def, int heade
+ ptypedef(def);
+ break;
+ case DEF_PROGRAM:
+- pprogramdef(def, headeronly);
++ pprogramdef(def, headeronly, nomain);
+ break;
+ case DEF_CONST:
+ pconstdef(def);
+@@ -103,12 +103,12 @@ print_datadef(definition *def, int heade
+
+
+ void
+-print_funcdef(definition *def, int headeronly)
++print_funcdef(definition *def, int headeronly, int nomain)
+ {
+ switch (def->def_kind) {
+ case DEF_PROGRAM:
+ f_print(fout, "\n");
+- pprogramdef(def, headeronly);
++ pprogramdef(def, headeronly, nomain);
+ break;
+ default:
+ break;
+@@ -313,7 +313,7 @@ pdispatch(char * name, char *vers, int m
+ }
+
+ static void
+-pprogramdef(definition *def, int headeronly)
++pprogramdef(definition *def, int headeronly, int nomain)
+ {
+ version_list *vers;
+ proc_list *proc;
+@@ -341,7 +341,7 @@ pprogramdef(definition *def, int headero
+
+ if(!Cflag){
+ ext = "extern ";
+- if (headeronly) {
++ if (headeronly && nomain) {
+ f_print(fout, "%s", ext);
+ pdispatch(def->def_name, vers->vers_num, 2);
+ }
+@@ -372,7 +372,7 @@ pprogramdef(definition *def, int headero
+ ext = "extern ";
+ }
+
+- if (headeronly) {
++ if (headeronly && nomain) {
+ f_print(fout, "%s", ext);
+ pdispatch(def->def_name, vers->vers_num,
+ i);
+Index: fbsd-6.2/usr.bin/rpcgen/rpc_main.c
+===================================================================
+--- fbsd-6.2.orig/usr.bin/rpcgen/rpc_main.c
++++ fbsd-6.2/usr.bin/rpcgen/rpc_main.c
+@@ -61,7 +61,7 @@ extern int write_sample_clnt( definition
+ extern void write_sample_clnt_main( void );
+ extern void add_sample_msg( void );
+ static void c_output( char *, char *, int, char * );
+-static void h_output( char *, char *, int, char *, int );
++static void h_output( char *, char *, int, char *, int, int );
+ static void l_output( char *, char *, int, char * );
+ static void t_output( char *, char *, int, char * );
+ static void clnt_output( char *, char *, int, char * );
+@@ -173,7 +173,7 @@ main(argc, argv)
+ c_output(cmd.infile, "-DRPC_XDR", DONT_EXTEND, cmd.outfile);
+ } else if (cmd.hflag) {
+ h_output(cmd.infile, "-DRPC_HDR", DONT_EXTEND, cmd.outfile,
+- cmd.hflag);
++ cmd.hflag, cmd.nflag);
+ } else if (cmd.lflag) {
+ l_output(cmd.infile, "-DRPC_CLNT", DONT_EXTEND, cmd.outfile);
+ } else if (cmd.sflag || cmd.mflag || (cmd.nflag)) {
+@@ -193,7 +193,7 @@ main(argc, argv)
+ /* the rescans are required, since cpp may effect input */
+ c_output(cmd.infile, "-DRPC_XDR", EXTEND, "_xdr.c");
+ reinitialize();
+- h_output(cmd.infile, "-DRPC_HDR", EXTEND, ".h", cmd.hflag);
++ h_output(cmd.infile, "-DRPC_HDR", EXTEND, ".h", cmd.hflag, cmd.nflag);
+ reinitialize();
+ l_output(cmd.infile, "-DRPC_CLNT", EXTEND, "_clnt.c");
+ reinitialize();
+@@ -515,7 +515,7 @@ char *generate_guard(pathname)
+
+
+ static void
+-h_output(char *infile, char *define, int extend, char *outfile, int headeronly)
++h_output(char *infile, char *define, int extend, char *outfile, int headeronly, int nomain)
+ {
+ definition *def;
+ char *outfilename;
+@@ -555,7 +555,7 @@ h_output(char *infile, char *define, int
+
+ /* print data definitions */
+ while ( (def = get_definition()) ) {
+- print_datadef(def, headeronly);
++ print_datadef(def, headeronly, nomain);
+ }
+
+ /*
+@@ -564,7 +564,7 @@ h_output(char *infile, char *define, int
+ * arguments for functions
+ */
+ for (l = defined; l != NULL; l = l->next) {
+- print_funcdef(l->val, headeronly);
++ print_funcdef(l->val, headeronly, nomain);
+ }
+ /* Now print all xdr func declarations */
+ if (xdrfunc_head != NULL){
diff --git a/sys-freebsd/freebsd-ubin/freebsd-ubin-6.2_beta1.ebuild b/sys-freebsd/freebsd-ubin/freebsd-ubin-6.2_beta1.ebuild
index 6f1dd8717970..03b942eb7708 100644
--- a/sys-freebsd/freebsd-ubin/freebsd-ubin-6.2_beta1.ebuild
+++ b/sys-freebsd/freebsd-ubin/freebsd-ubin-6.2_beta1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-ubin/freebsd-ubin-6.2_beta1.ebuild,v 1.1 2006/09/21 21:01:47 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-ubin/freebsd-ubin-6.2_beta1.ebuild,v 1.2 2006/09/22 09:28:08 flameeyes Exp $
inherit bsdmk freebsd flag-o-matic pam
@@ -52,8 +52,8 @@ PATCHES="${FILESDIR}/${PN}-6.0-bsdcmp.patch
${FILESDIR}/${PN}-setXid.patch
${FILESDIR}/${PN}-lint-stdarg.patch
${FILESDIR}/${PN}-6.0-kdump-ioctl.patch
- ${FILESDIR}/${P}-gcc41.patch
- ${FILESDIR}/${P}-rpcgen-gcc41.patch"
+ ${FILESDIR}/${PN}-6.1-gcc41.patch
+ ${FILESDIR}/${PN}-6.2-rpcgen-gcc4.1.patch"
# Here we remove some sources we don't need because they are already
# provided by portage's packages or similar. In order: