summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJavier Villavicencio <the_paya@gentoo.org>2009-01-22 21:04:49 +0000
committerJavier Villavicencio <the_paya@gentoo.org>2009-01-22 21:04:49 +0000
commit599f2a3b25cb60da7a1c999333eef958f7077918 (patch)
treebc79f9c04c59ce154d77250b9cc4ce38847b3ff4 /sys-freebsd
parentImport of the 7.1 ebuilds from gentoo-bsd overlay. (diff)
downloadgentoo-2-599f2a3b25cb60da7a1c999333eef958f7077918.tar.gz
gentoo-2-599f2a3b25cb60da7a1c999333eef958f7077918.tar.bz2
gentoo-2-599f2a3b25cb60da7a1c999333eef958f7077918.zip
Import of the 7.1 ebuilds from gentoo-bsd overlay.
(Portage version: 2.2_rc23/cvs/FreeBSD i386)
Diffstat (limited to 'sys-freebsd')
-rw-r--r--sys-freebsd/freebsd-sbin/ChangeLog9
-rw-r--r--sys-freebsd/freebsd-sbin/files/freebsd-sbin-7.1-zlib.patch21
-rwxr-xr-xsys-freebsd/freebsd-sbin/files/idmapd.initd20
-rw-r--r--sys-freebsd/freebsd-sbin/freebsd-sbin-7.1.ebuild97
4 files changed, 146 insertions, 1 deletions
diff --git a/sys-freebsd/freebsd-sbin/ChangeLog b/sys-freebsd/freebsd-sbin/ChangeLog
index 34ce848e1b41..c847ff247f7a 100644
--- a/sys-freebsd/freebsd-sbin/ChangeLog
+++ b/sys-freebsd/freebsd-sbin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-freebsd/freebsd-sbin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-sbin/ChangeLog,v 1.46 2009/01/08 20:02:49 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-sbin/ChangeLog,v 1.47 2009/01/22 21:04:48 the_paya Exp $
+
+*freebsd-sbin-7.1 (22 Jan 2009)
+
+ 22 Jan 2009; Javier Villavicencio <the_paya@gentoo.org>
+ +files/freebsd-sbin-7.1-zlib.patch, +files/idmapd.initd,
+ +freebsd-sbin-7.1.ebuild:
+ Import 7.1 ebuilds from gentoo-bsd overlay.
08 Jan 2009; Alexis Ballier <aballier@gentoo.org>
freebsd-sbin-6.2-r2.ebuild:
diff --git a/sys-freebsd/freebsd-sbin/files/freebsd-sbin-7.1-zlib.patch b/sys-freebsd/freebsd-sbin/files/freebsd-sbin-7.1-zlib.patch
new file mode 100644
index 000000000000..22fb2ec62d4f
--- /dev/null
+++ b/sys-freebsd/freebsd-sbin/files/freebsd-sbin-7.1-zlib.patch
@@ -0,0 +1,21 @@
+diff -ur sbin/savecore/savecore.c sbin-zlib/savecore/savecore.c
+--- sbin/savecore/savecore.c 2005-02-26 01:21:50 +0000
++++ sbin-zlib/savecore/savecore.c 2005-05-06 12:00:06 +0000
+@@ -95,7 +95,7 @@
+ static int checkfor, compress, clear, force, keep, verbose; /* flags */
+ static int nfound, nsaved, nerr; /* statistics */
+
+-extern FILE *zopen(const char *, const char *);
++extern FILE *gzopen(const char *, const char *);
+
+ static void
+ printheader(FILE *f, const struct kerneldumpheader *h, const char *device,
+@@ -553,7 +553,7 @@
+ if (compress) {
+ sprintf(filename, "%s.%d.gz", istextdump ? "textdump.tar" :
+ "vmcore", bounds);
+- fp = zopen(filename, "w");
++ fp = gzopen(filename, "w");
+ } else {
+ sprintf(filename, "%s.%d", istextdump ? "textdump.tar" :
+ "vmcore", bounds);
diff --git a/sys-freebsd/freebsd-sbin/files/idmapd.initd b/sys-freebsd/freebsd-sbin/files/idmapd.initd
new file mode 100755
index 000000000000..407b0e87f85d
--- /dev/null
+++ b/sys-freebsd/freebsd-sbin/files/idmapd.initd
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need rpcbind
+}
+
+start() {
+ ebegin "Starting NFS idmapd"
+ start-stop-daemon --start --quiet --exec \
+ /sbin/idmapd -- $idmapdopts
+ eend $? "Error starting NFS idmapd"
+}
+
+stop() {
+ ebegin "Stopping NFS idmapd"
+ start-stop-daemon --stop --quiet --exec /sbin/idmapd
+ eend $? "Error stopping NFS idmapd"
+}
diff --git a/sys-freebsd/freebsd-sbin/freebsd-sbin-7.1.ebuild b/sys-freebsd/freebsd-sbin/freebsd-sbin-7.1.ebuild
new file mode 100644
index 000000000000..529cbbc813d6
--- /dev/null
+++ b/sys-freebsd/freebsd-sbin/freebsd-sbin-7.1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-sbin/freebsd-sbin-7.1.ebuild,v 1.1 2009/01/22 21:04:48 the_paya Exp $
+
+inherit flag-o-matic bsdmk freebsd
+
+DESCRIPTION="FreeBSD sbin utils"
+KEYWORDS="~sparc-fbsd ~x86-fbsd"
+SLOT="0"
+
+SRC_URI="mirror://gentoo/${SBIN}.tar.bz2
+ mirror://gentoo/${CONTRIB}.tar.bz2
+ mirror://gentoo/${LIB}.tar.bz2
+ mirror://gentoo/${LIBEXEC}.tar.bz2
+ mirror://gentoo/${USBIN}.tar.bz2
+ mirror://gentoo/${ETC}.tar.bz2
+ build? ( mirror://gentoo/${SYS}.tar.bz2 )"
+
+RDEPEND="=sys-freebsd/freebsd-lib-${RV}*
+ =sys-freebsd/freebsd-libexec-${RV}*
+ ssl? ( dev-libs/openssl )
+ dev-libs/libedit
+ sys-libs/readline
+ sys-process/vixie-cron"
+DEPEND="${RDEPEND}
+ !build? ( =sys-freebsd/freebsd-sources-${RV}* )
+ =sys-freebsd/freebsd-mk-defs-${RV}*"
+
+PROVIDE="virtual/dev-manager"
+
+S="${WORKDIR}/sbin"
+
+IUSE="atm ipfilter ipv6 vinum suid ssl build"
+
+pkg_setup() {
+ use atm || mymakeopts="${mymakeopts} NO_ATM= "
+ use ipfilter || mymakeopts="${mymakeopts} NO_IPFILTER= "
+ use ipv6 || mymakeopts="${mymakeopts} NO_INET6= "
+ use vinum || mymakeopts="${mymakeopts} NO_VINUM= "
+ use suid || mymakeopts="${mymakeopts} NO_SUID= "
+
+ # O3 breaks this, apparently
+ replace-flags -O3 -O2
+}
+
+REMOVE_SUBDIRS="dhclient pfctl pflogd rcorder"
+
+PATCHES="${FILESDIR}/${PN}-setXid.patch
+ ${FILESDIR}/${PN}-7.1-zlib.patch
+ ${FILESDIR}/${PN}-6.2-ldconfig.patch
+ ${FILESDIR}/${PN}-6.1-pr102701.patch"
+
+src_unpack() {
+ freebsd_src_unpack
+ use build || ln -s "/usr/src/sys-${RV}" "${WORKDIR}/sys"
+}
+
+src_install() {
+ freebsd_src_install
+ keepdir /var/log
+ # Needed by ldconfig:
+ keepdir /var/run
+
+ # Allow users to use ping and other commands
+ dodir /bin
+ mv "${D}/sbin/ping" "${D}/bin/" || die "mv failed"
+
+ # ext2fs can mount ext3, you just don't get the journalling
+ dosym mount_ext2fs sbin/mount_ext3
+
+ # Do we need pccard.conf if we have devd?
+ # Maybe ship our own sysctl.conf so things like radvd work out of the box.
+ cd "${WORKDIR}/etc/"
+ insinto /etc
+ doins defaults/pccard.conf minfree sysctl.conf
+
+ # initd script for idmapd
+ newinitd "${FILESDIR}/idmapd.initd" idmapd
+
+ # Install a crontab for adjkerntz
+ insinto /etc/cron.d
+ newins "${FILESDIR}/adjkerntz-crontab" adjkerntz
+
+ # Install the periodic stuff (needs probably to be ported in a more
+ # gentooish way)
+ cd "${WORKDIR}/etc/periodic"
+
+ doperiodic security \
+ security/*.ipfwlimit \
+ security/*.ip6fwlimit \
+ security/*.ip6fwdenied \
+ security/*.ipfwdenied
+
+ use ipfilter && doperiodic security \
+ security/*.ipf6denied \
+ security/*.ipfdenied
+}