summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-05-18 01:48:00 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-05-18 01:48:00 +0000
commit1b65a85548720353fd0b50db594208d6a08c6034 (patch)
treed9b8ed90e49dc68b98c6eee771f69b5022d797f9 /sys-freebsd
parentFactorize some more code and regroup variable assignments. (diff)
downloadgentoo-2-1b65a85548720353fd0b50db594208d6a08c6034.tar.gz
gentoo-2-1b65a85548720353fd0b50db594208d6a08c6034.tar.bz2
gentoo-2-1b65a85548720353fd0b50db594208d6a08c6034.zip
Preinstall headers only with USE=build
(Portage version: 2.2.0_alpha107/cvs/Linux x86_64)
Diffstat (limited to 'sys-freebsd')
-rw-r--r--sys-freebsd/freebsd-lib/ChangeLog5
-rw-r--r--sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild12
2 files changed, 8 insertions, 9 deletions
diff --git a/sys-freebsd/freebsd-lib/ChangeLog b/sys-freebsd/freebsd-lib/ChangeLog
index 873a522048e7..b9687a07363e 100644
--- a/sys-freebsd/freebsd-lib/ChangeLog
+++ b/sys-freebsd/freebsd-lib/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-freebsd/freebsd-lib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/ChangeLog,v 1.130 2012/05/18 01:35:07 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/ChangeLog,v 1.131 2012/05/18 01:48:00 aballier Exp $
+
+ 18 May 2012; Alexis Ballier <aballier@gentoo.org> freebsd-lib-9.0-r2.ebuild:
+ Preinstall headers only with USE=build
18 May 2012; Alexis Ballier <aballier@gentoo.org> freebsd-lib-9.0-r2.ebuild:
Factorize some more code and regroup variable assignments.
diff --git a/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild b/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild
index 4c52cced2a45..3dfec3838ddb 100644
--- a/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild
+++ b/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild,v 1.16 2012/05/18 01:35:07 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild,v 1.17 2012/05/18 01:48:00 aballier Exp $
EAPI=2
@@ -173,10 +173,6 @@ src_prepare() {
sed -i.bak -e 's:${INSTALL} -C:${INSTALL}:' "${WORKDIR}/include/Makefile"
fi
- # Preinstall includes so we don't use the system's ones.
- mkdir "${WORKDIR}/include_proper" || die "Couldn't create ${WORKDIR}/include_proper"
- install_includes "/include_proper"
-
# Let arch-specific includes to be found
local machine
machine=$(tc-arch-kernel ${CTARGET})
@@ -254,9 +250,9 @@ src_compile() {
SUBDIRS="lib/libc lib/msun gnu/lib/libssp lib/libthr lib/libutil"
else
- # Forces to use the local copy of headers as they might be outdated in
- # the system
- append-flags "-isystem '${WORKDIR}/include_proper'"
+ # Forces to use the local copy of headers with USE=build as they might
+ # be outdated in the system. Assume they are fine otherwise.
+ use build && append-flags "-isystem '${WORKDIR}/include_proper'"
bootstrap_libssp_nonshared