summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-05-30 12:25:14 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-05-30 12:25:14 +0000
commit17f7874430782770f2a3634f8deb85403fe85bc8 (patch)
tree06481ca0f3968cce12bf0d15dd4256aa1424687b /sys-freebsd
parentRemove old (diff)
downloadgentoo-2-17f7874430782770f2a3634f8deb85403fe85bc8.tar.gz
gentoo-2-17f7874430782770f2a3634f8deb85403fe85bc8.tar.bz2
gentoo-2-17f7874430782770f2a3634f8deb85403fe85bc8.zip
Treat multilib and non multilib builds the same way as multilib.eclass does the right thing. Go back to -isystem for system includes and force to use ours as otherwise we may pick gcc ones and it got that wrong. Bypass append-flags and append cflags directly as flag-o-matic eclass maintainers think it wise to add broken checks that break with flags with spaces.
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
Diffstat (limited to 'sys-freebsd')
-rw-r--r--sys-freebsd/freebsd-lib/ChangeLog9
-rw-r--r--sys-freebsd/freebsd-lib/freebsd-lib-9.0-r3.ebuild13
2 files changed, 13 insertions, 9 deletions
diff --git a/sys-freebsd/freebsd-lib/ChangeLog b/sys-freebsd/freebsd-lib/ChangeLog
index 727176b95dcd..830b80dbd932 100644
--- a/sys-freebsd/freebsd-lib/ChangeLog
+++ b/sys-freebsd/freebsd-lib/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-freebsd/freebsd-lib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/ChangeLog,v 1.152 2012/05/28 03:17:39 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/ChangeLog,v 1.153 2012/05/30 12:25:14 aballier Exp $
+
+ 30 May 2012; Alexis Ballier <aballier@gentoo.org> freebsd-lib-9.0-r3.ebuild:
+ Treat multilib and non multilib builds the same way as multilib.eclass does
+ the right thing. Go back to -isystem for system includes and force to use
+ ours as otherwise we may pick gcc ones and it got that wrong. Bypass
+ append-flags and append cflags directly as flag-o-matic eclass maintainers
+ think it wise to add broken checks that break with flags with spaces.
28 May 2012; Alexis Ballier <aballier@gentoo.org> freebsd-lib-9.0-r3.ebuild:
fix broken logic in is_native_abi, by Naohiro Aota, bug #417863
diff --git a/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r3.ebuild b/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r3.ebuild
index bbebcce53574..b4f18e4d21b8 100644
--- a/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r3.ebuild
+++ b/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r3.ebuild,v 1.3 2012/05/28 03:17:39 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r3.ebuild,v 1.4 2012/05/30 12:25:14 aballier Exp $
EAPI=2
@@ -337,11 +337,6 @@ src_compile() {
if is_crosscompile ; then
do_compile
- elif ! use multilib ; then
- # Forces to use the local copy of headers with USE=build as they might
- # be outdated in the system. Assume they are fine otherwise.
- use build && append-flags "-I${WORKDIR}/include_proper"
- do_compile
else
for ABI in $(get_all_abis) ; do
# First, save the variables: CFLAGS, CXXFLAGS, LDFLAGS and mymakeopts.
@@ -353,17 +348,19 @@ src_compile() {
local target="$(tc-arch-kernel ${CHOST})"
mymakeopts="${mymakeopts} TARGET=${target} MACHINE=${target} MACHINE_ARCH=${target}"
+ CFLAGADD=""
if ! is_native_abi ; then
mymakeopts="${mymakeopts} COMPAT_32BIT="
einfo "Pre-installing includes in include_proper_${ABI}"
mkdir "${WORKDIR}/include_proper_${ABI}" || die
CTARGET="${CHOST}" install_includes "/include_proper_${ABI}"
- CC="${CC} -I${WORKDIR}/include_proper_${ABI}"
+ CFLAGADD="-isystem ${WORKDIR}/include_proper_${ABI}"
else
- use build && append-flags "-I${WORKDIR}/include_proper" ;
+ use build && CFLAGADD="-isystem ${WORKDIR}/include_proper" || CFLAGADD="-isystem /usr/include";
fi
einfo "Building for ABI ${ABI} and TARGET=$(tc-arch-kernel ${CHOST})"
+ CFLAGS="${CFLAGS} ${CFLAGADD}"
CTARGET="${CHOST}" do_compile