summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-12-07 17:04:42 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-12-07 17:04:42 +0000
commit09eff23e0ade8b5c8bf690eb8725b3b09993f5f3 (patch)
tree3ef1155b5eae0d48a2ccaae8d19f384346264a30 /sys-freebsd
parentAdd ~x86-fbsd #393179 (diff)
downloadgentoo-2-09eff23e0ade8b5c8bf690eb8725b3b09993f5f3.tar.gz
gentoo-2-09eff23e0ade8b5c8bf690eb8725b3b09993f5f3.tar.bz2
gentoo-2-09eff23e0ade8b5c8bf690eb8725b3b09993f5f3.zip
bump to rc2
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'sys-freebsd')
-rw-r--r--sys-freebsd/boot0/ChangeLog7
-rw-r--r--sys-freebsd/boot0/boot0-9.0_rc2.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/sys-freebsd/boot0/ChangeLog b/sys-freebsd/boot0/ChangeLog
index 600c359b2732..88b5fc926bca 100644
--- a/sys-freebsd/boot0/ChangeLog
+++ b/sys-freebsd/boot0/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-freebsd/boot0
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/boot0/ChangeLog,v 1.28 2011/11/07 12:18:39 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/boot0/ChangeLog,v 1.29 2011/12/07 17:04:42 aballier Exp $
+
+*boot0-9.0_rc2 (07 Dec 2011)
+
+ 07 Dec 2011; Alexis Ballier <aballier@gentoo.org> +boot0-9.0_rc2.ebuild:
+ bump to rc2
*boot0-9.0_rc1 (07 Nov 2011)
diff --git a/sys-freebsd/boot0/boot0-9.0_rc2.ebuild b/sys-freebsd/boot0/boot0-9.0_rc2.ebuild
new file mode 100644
index 000000000000..dd33bff65a9d
--- /dev/null
+++ b/sys-freebsd/boot0/boot0-9.0_rc2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/boot0/boot0-9.0_rc2.ebuild,v 1.1 2011/12/07 17:04:42 aballier Exp $
+
+EAPI=2
+
+inherit bsdmk freebsd flag-o-matic
+
+DESCRIPTION="FreeBSD's bootloader"
+SLOT="0"
+KEYWORDS="~sparc-fbsd ~x86-fbsd"
+
+IUSE="bzip2 ieee1394 tftp zfs"
+
+SRC_URI="mirror://gentoo/${SYS}.tar.bz2"
+
+RDEPEND=""
+DEPEND="=sys-freebsd/freebsd-mk-defs-${RV}*
+ =sys-freebsd/freebsd-lib-${RV}*"
+
+S="${WORKDIR}/sys/boot"
+
+boot0_use_enable() {
+ use ${1} && mymakeopts="${mymakeopts} LOADER_${2}_SUPPORT=\"yes\""
+}
+
+pkg_setup() {
+ boot0_use_enable ieee1394 FIREWIRE
+ boot0_use_enable zfs ZFS
+ boot0_use_enable tftp TFTP
+ boot0_use_enable bzip2 BZIP2
+}
+
+src_prepare() {
+ sed -e '/-fomit-frame-pointer/d' -e '/-mno-align-long-strings/d' \
+ -i "${S}"/i386/boot2/Makefile \
+ -i "${S}"/i386/gptboot/Makefile \
+ -i "${S}"/i386/gptzfsboot/Makefile \
+ -i "${S}"/i386/zfsboot/Makefile || die
+}
+
+src_compile() {
+ strip-flags
+ append-flags "-I/usr/include/libstand/"
+ append-flags "-fno-strict-aliasing"
+ NOFLAGSTRIP="yes" freebsd_src_compile
+}
+
+src_install() {
+ dodir /boot/defaults
+ mkinstall FILESDIR=/boot || die "mkinstall failed"
+}