summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJavier Villavicencio <the_paya@gentoo.org>2010-04-20 23:06:53 +0000
committerJavier Villavicencio <the_paya@gentoo.org>2010-04-20 23:06:53 +0000
commit18dfa5dfba2d4b08b2de2dc2c162bfe594383929 (patch)
treef6abb0970bd27d394d82d52f97c23f20b24aa432 /sys-freebsd/freebsd-sources
parentBug #316427: upstream changes to makefiles caused some libraries to not be pr... (diff)
downloadgentoo-2-18dfa5dfba2d4b08b2de2dc2c162bfe594383929.tar.gz
gentoo-2-18dfa5dfba2d4b08b2de2dc2c162bfe594383929.tar.bz2
gentoo-2-18dfa5dfba2d4b08b2de2dc2c162bfe594383929.zip
Fix a kernel panic in arpresolve, and add support for my 3g modem.
(Portage version: 2.2_rc67/cvs/FreeBSD i386)
Diffstat (limited to 'sys-freebsd/freebsd-sources')
-rw-r--r--sys-freebsd/freebsd-sources/ChangeLog9
-rw-r--r--sys-freebsd/freebsd-sources/files/freebsd-sources-8.0-arpresolve_panic.patch18
-rw-r--r--sys-freebsd/freebsd-sources/files/freebsd-sources-8.0-mf626.patch24
-rw-r--r--sys-freebsd/freebsd-sources/freebsd-sources-8.0.ebuild4
4 files changed, 53 insertions, 2 deletions
diff --git a/sys-freebsd/freebsd-sources/ChangeLog b/sys-freebsd/freebsd-sources/ChangeLog
index b9feb060af26..368cde6de650 100644
--- a/sys-freebsd/freebsd-sources/ChangeLog
+++ b/sys-freebsd/freebsd-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-freebsd/freebsd-sources
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-sources/ChangeLog,v 1.56 2010/03/19 11:50:50 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-sources/ChangeLog,v 1.57 2010/04/20 23:06:53 the_paya Exp $
+
+ 20 Apr 2010; Javier Villavicencio <the_paya@gentoo.org>
+ freebsd-sources-8.0.ebuild,
+ +files/freebsd-sources-8.0-arpresolve_panic.patch,
+ +files/freebsd-sources-8.0-mf626.patch:
+ Fix a null pointer reference in arpresolve() that caused panics, and add
+ support for a common 3g usb modem.
*freebsd-sources-8.0 (19 Mar 2010)
diff --git a/sys-freebsd/freebsd-sources/files/freebsd-sources-8.0-arpresolve_panic.patch b/sys-freebsd/freebsd-sources/files/freebsd-sources-8.0-arpresolve_panic.patch
new file mode 100644
index 000000000000..c624532d8c93
--- /dev/null
+++ b/sys-freebsd/freebsd-sources/files/freebsd-sources-8.0-arpresolve_panic.patch
@@ -0,0 +1,18 @@
+This one (plus a misrule in my pf.conf) made my box crash at random after 6
+to 48 hours of uptime. Thanks to an incoming icmp packet.
+
+Taken from:
+http://svn.freebsd.org/viewvc/base/head/sys/netinet/if_ether.c?r1=198418&r2=201416
+--- head/sys/netinet/if_ether.c
++++ head/sys/netinet/if_ether.c
+@@ -372,8 +372,8 @@
+ if (la->la_asked < V_arp_maxtries)
+ error = EWOULDBLOCK; /* First request. */
+ else
+- error =
+- (rt0->rt_flags & RTF_GATEWAY) ? EHOSTUNREACH : EHOSTDOWN;
++ error = rt0 != NULL && (rt0->rt_flags & RTF_GATEWAY) ?
++ EHOSTUNREACH : EHOSTDOWN;
+
+ if (renew) {
+ LLE_ADDREF(la);
diff --git a/sys-freebsd/freebsd-sources/files/freebsd-sources-8.0-mf626.patch b/sys-freebsd/freebsd-sources/files/freebsd-sources-8.0-mf626.patch
new file mode 100644
index 000000000000..9121c0a819f3
--- /dev/null
+++ b/sys-freebsd/freebsd-sources/files/freebsd-sources-8.0-mf626.patch
@@ -0,0 +1,24 @@
+Backport this 3g modem that I have.
+Given it's quite common, should be useful
+And I hate when I forget to patch the kernel after a re-emerge.
+
+--- sys/dev/usb/usbdevs.orig
++++ sys/dev/usb/usbdevs
+@@ -2055,6 +2055,7 @@
+ product QUALCOMM2 CDMA_MSM 0x3196 CDMA Technologies MSM modem
+ product QUALCOMMINC CDMA_MSM 0x0001 CDMA Technologies MSM modem
+ product QUALCOMMINC ZTE_STOR 0x2000 USB ZTE Storage
++product QUALCOMMINC MF626 0X0031 3G modem
+ product QUALCOMMINC AC8700 0xfffe CDMA 1xEVDO USB modem
+
+ /* Qtronix products */
+--- sys/dev/usb/serial/u3g.c.orig
++++ sys/dev/usb/serial/u3g.c
+@@ -184,6 +184,7 @@
+ /* OEM: Qualcomm, Inc. */
+ U3G_DEV(QUALCOMMINC, ZTE_STOR, U3GFL_SCSI_EJECT),
+ U3G_DEV(QUALCOMMINC, CDMA_MSM, U3GFL_SCSI_EJECT),
++ U3G_DEV(QUALCOMMINC, MF626, 0),
+ /* OEM: Huawei */
+ U3G_DEV(HUAWEI, MOBILE, U3GFL_HUAWEI_INIT),
+ U3G_DEV(HUAWEI, E180V, U3GFL_HUAWEI_INIT),
diff --git a/sys-freebsd/freebsd-sources/freebsd-sources-8.0.ebuild b/sys-freebsd/freebsd-sources/freebsd-sources-8.0.ebuild
index 4f5320c7991f..1979e729ae48 100644
--- a/sys-freebsd/freebsd-sources/freebsd-sources-8.0.ebuild
+++ b/sys-freebsd/freebsd-sources/freebsd-sources-8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-sources/freebsd-sources-8.0.ebuild,v 1.1 2010/03/19 11:50:50 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-sources/freebsd-sources-8.0.ebuild,v 1.2 2010/04/20 23:06:53 the_paya Exp $
inherit bsdmk freebsd flag-o-matic
@@ -49,6 +49,8 @@ src_unpack() {
epatch "${FILESDIR}/${PN}-8.0-subnet-route-pr40133.patch"
epatch "${FILESDIR}/${PN}-7.1-includes.patch"
epatch "${FILESDIR}/${PN}-8.0-zfs.patch"
+ epatch "${FILESDIR}/${PN}-8.0-arpresolve_panic.patch" # Already in SVN
+ epatch "${FILESDIR}/${PN}-8.0-mf626.patch" # Backported from SVN
# By adding -DGENTOO_LIVECD to CFLAGS activate this stub
# vop_whiteout to tmpfs, so it can be used as an overlay