summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-03-19 11:51:07 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-03-19 11:51:07 +0000
commitbbf334e5c06d8676968eb2327d560d97c76a4523 (patch)
treee2be7c9800aa6fed357f9dda0d7c5f9d20357b13 /sys-freebsd/freebsd-sources/files
parentFix bug 293374 and sync with fedora to solve other issues (diff)
downloadgentoo-2-bbf334e5c06d8676968eb2327d560d97c76a4523.tar.gz
gentoo-2-bbf334e5c06d8676968eb2327d560d97c76a4523.tar.bz2
gentoo-2-bbf334e5c06d8676968eb2327d560d97c76a4523.zip
bump to 8.0 from the bsd overlay
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-freebsd/freebsd-sources/files')
-rw-r--r--sys-freebsd/freebsd-sources/files/freebsd-sources-8.0-gentoo.patch33
-rw-r--r--sys-freebsd/freebsd-sources/files/freebsd-sources-8.0-sparc64.patch11
-rw-r--r--sys-freebsd/freebsd-sources/files/freebsd-sources-8.0-subnet-route-pr40133.patch21
-rw-r--r--sys-freebsd/freebsd-sources/files/freebsd-sources-8.0-werror.patch22
-rw-r--r--sys-freebsd/freebsd-sources/files/freebsd-sources-8.0-zfs.patch23
5 files changed, 110 insertions, 0 deletions
diff --git a/sys-freebsd/freebsd-sources/files/freebsd-sources-8.0-gentoo.patch b/sys-freebsd/freebsd-sources/files/freebsd-sources-8.0-gentoo.patch
new file mode 100644
index 000000000000..0f8d070e9a31
--- /dev/null
+++ b/sys-freebsd/freebsd-sources/files/freebsd-sources-8.0-gentoo.patch
@@ -0,0 +1,33 @@
+--- sys/conf/kern.mk.old 2007-05-24 23:53:42.000000000 +0200
++++ sys/conf/kern.mk 2008-03-14 14:37:47.216420518 +0100
+@@ -12,7 +12,7 @@
+ .else
+ CWARNFLAGS?= -Wall -Wredundant-decls -Wnested-externs -Wstrict-prototypes \
+ -Wmissing-prototypes -Wpointer-arith -Winline -Wcast-qual \
+- ${_wundef} ${_Wno_pointer_sign} -fformat-extensions
++ ${_wundef} ${_Wno_pointer_sign}
+ .if !defined(WITH_GCC3)
+ _Wno_pointer_sign=-Wno-pointer-sign
+ .endif
+@@ -36,7 +36,7 @@
+ # reserved for user applications.
+ #
+ .if ${MACHINE_ARCH} == "i386" && ${CC} != "icc"
+-CFLAGS+= -mno-align-long-strings -mpreferred-stack-boundary=2 \
++CFLAGS+= -mpreferred-stack-boundary=2 \
+ -mno-mmx -mno-3dnow -mno-sse -mno-sse2 -mno-sse3
+ INLINE_LIMIT?= 8000
+ .endif
+Only in ./sys/conf: kern.mk.rej
+Only in ./sys/conf: kern.mk~
+--- sys/dev/aic7xxx/aicasm/Makefile.old 2010-03-10 14:01:50 +0100
++++ sys/dev/aic7xxx/aicasm/Makefile 2010-03-10 14:01:56 +0100
+@@ -14,7 +14,7 @@
+ SRCS= ${GENHDRS} ${CSRCS} ${YSRCS} ${LSRCS}
+ CLEANFILES+= ${GENHDRS} ${YSRCS:R:C/(.*)/\1.output/g}
+ DPADD= ${LIBL}
+-LDADD= -ll
++LDADD= -lfl
+ WARNS?= 6
+
+ # Correct path for kernel builds
diff --git a/sys-freebsd/freebsd-sources/files/freebsd-sources-8.0-sparc64.patch b/sys-freebsd/freebsd-sources/files/freebsd-sources-8.0-sparc64.patch
new file mode 100644
index 000000000000..1729beb4c6ed
--- /dev/null
+++ b/sys-freebsd/freebsd-sources/files/freebsd-sources-8.0-sparc64.patch
@@ -0,0 +1,11 @@
+--- sys/conf/ldscript.sparc64.old 2010-03-10 14:42:03 +0100
++++ sys/conf/ldscript.sparc64 2010-03-10 14:42:30 +0100
+@@ -1,6 +1,6 @@
+ /* $FreeBSD: src/sys/conf/ldscript.sparc64,v 1.4.32.1.2.1 2009/10/25 01:10:29 kensmith Exp $ */
+-OUTPUT_FORMAT("elf64-sparc", "elf64-sparc",
+- "elf64-sparc")
++OUTPUT_FORMAT("elf64-sparc-freebsd", "elf64-sparc-freebsd",
++ "elf64-sparc-freebsd")
+ OUTPUT_ARCH(sparc:v9)
+ ENTRY(_start)
+ SEARCH_DIR(/usr/lib);
diff --git a/sys-freebsd/freebsd-sources/files/freebsd-sources-8.0-subnet-route-pr40133.patch b/sys-freebsd/freebsd-sources/files/freebsd-sources-8.0-subnet-route-pr40133.patch
new file mode 100644
index 000000000000..a7335f6d427f
--- /dev/null
+++ b/sys-freebsd/freebsd-sources/files/freebsd-sources-8.0-subnet-route-pr40133.patch
@@ -0,0 +1,21 @@
+Fixes changing the default subnet route after removing an ip address.
+
+See: http://www.netbsd.org/cgi-bin/query-pr-single.pl?number=40133
+and http://mail-index.netbsd.org/tech-net/2008/12/03/msg000896.html
+
+Thanks to Roy Marples.
+--- sys/netinet/in.c.orig
++++ sys/netinet/in.c
+@@ -858,6 +858,12 @@
+ error = rtinit(&target->ia_ifa, (int)RTM_ADD, flags);
+ if (!error)
+ target->ia_flags |= IFA_ROUTE;
++ else if (error == EEXIST) {
++ /*
++ * the fact that the route already exists is not an error.
++ */
++ error = 0;
++ }
+ return (error);
+ }
+
diff --git a/sys-freebsd/freebsd-sources/files/freebsd-sources-8.0-werror.patch b/sys-freebsd/freebsd-sources/files/freebsd-sources-8.0-werror.patch
new file mode 100644
index 000000000000..2d2e028d10c0
--- /dev/null
+++ b/sys-freebsd/freebsd-sources/files/freebsd-sources-8.0-werror.patch
@@ -0,0 +1,22 @@
+--- sys/conf/kern.pre.mk.old 2010-03-10 14:20:43 +0100
++++ sys/conf/kern.pre.mk 2010-03-10 14:20:56 +0100
+@@ -93,7 +93,7 @@
+ CFLAGS+= -fno-common -finline-limit=${INLINE_LIMIT}
+ CFLAGS+= --param inline-unit-growth=100
+ CFLAGS+= --param large-function-growth=1000
+-WERROR?= -Werror
++WERROR?= -Wno-error
+ .endif
+
+ # XXX LOCORE means "don't declare C stuff" not "for locore.s".
+--- sys/conf/kmod.mk.old 2010-03-10 14:21:06 +0100
++++ sys/conf/kmod.mk 2010-03-10 14:21:16 +0100
+@@ -79,7 +79,7 @@
+ . if !empty(CFLAGS:M-O[23s]) && empty(CFLAGS:M-fno-strict-aliasing)
+ CFLAGS+= -fno-strict-aliasing
+ . endif
+-WERROR?= -Werror
++WERROR?= -Wno-error
+ .endif
+ CFLAGS+= ${WERROR}
+ CFLAGS+= -D_KERNEL -D__FreeBSD_cc_version=700004
diff --git a/sys-freebsd/freebsd-sources/files/freebsd-sources-8.0-zfs.patch b/sys-freebsd/freebsd-sources/files/freebsd-sources-8.0-zfs.patch
new file mode 100644
index 000000000000..f81b2b5bed07
--- /dev/null
+++ b/sys-freebsd/freebsd-sources/files/freebsd-sources-8.0-zfs.patch
@@ -0,0 +1,23 @@
+Index: sys/cddl/contrib/opensolaris/uts/common/fs/zfs/zfs_replay.c
+===================================================================
+--- sys/cddl/contrib/opensolaris/uts/common/fs/zfs/zfs_replay.c (revision 200583)
++++ sys/cddl/contrib/opensolaris/uts/common/fs/zfs/zfs_replay.c (working copy)
+@@ -60,10 +60,14 @@ zfs_init_vattr(vattr_t *vap, uint64_t mask, uint64
+ {
+ VATTR_NULL(vap);
+ vap->va_mask = (uint_t)mask;
+- vap->va_type = IFTOVT(mode);
+- vap->va_mode = mode & MODEMASK;
+- vap->va_uid = (uid_t)(IS_EPHEMERAL(uid)) ? -1 : uid;
+- vap->va_gid = (gid_t)(IS_EPHEMERAL(gid)) ? -1 : gid;
++ if (mask & AT_TYPE)
++ vap->va_type = IFTOVT(mode);
++ if (mask & AT_MODE)
++ vap->va_mode = mode & MODEMASK;
++ if (mask & AT_UID)
++ vap->va_uid = (uid_t)(IS_EPHEMERAL(uid)) ? -1 : uid;
++ if (mask & AT_GID)
++ vap->va_gid = (gid_t)(IS_EPHEMERAL(gid)) ? -1 : gid;
+ vap->va_rdev = zfs_cmpldev(rdev);
+ vap->va_nodeid = nodeid;
+ }