summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-26 21:17:04 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-26 21:17:04 +0000
commitbe600ffaca2469313cd677552df18856f145d2f8 (patch)
tree338c09b6e4e89f5e4861e2a825b82be4481b8fbc /sys-freebsd/freebsd-libexec
parentVersion bump. (diff)
downloadgentoo-2-be600ffaca2469313cd677552df18856f145d2f8.tar.gz
gentoo-2-be600ffaca2469313cd677552df18856f145d2f8.tar.bz2
gentoo-2-be600ffaca2469313cd677552df18856f145d2f8.zip
Use LD_* variables for 32bits too instead of the FreeBSD invention LD_32_*. We use LD_* everywhere on Gentoo and things like libtool wrappers have no clue
about LD_32_* and thus fail to run from the build directory. (Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sys-freebsd/freebsd-libexec')
-rw-r--r--sys-freebsd/freebsd-libexec/ChangeLog10
-rw-r--r--sys-freebsd/freebsd-libexec/files/freebsd-libexec-9.2-no_ld32.patch15
-rw-r--r--sys-freebsd/freebsd-libexec/freebsd-libexec-9.2_rc3.ebuild4
3 files changed, 27 insertions, 2 deletions
diff --git a/sys-freebsd/freebsd-libexec/ChangeLog b/sys-freebsd/freebsd-libexec/ChangeLog
index b02f9cf98d2c..c4c1d727f731 100644
--- a/sys-freebsd/freebsd-libexec/ChangeLog
+++ b/sys-freebsd/freebsd-libexec/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-freebsd/freebsd-libexec
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-libexec/ChangeLog,v 1.60 2013/08/26 20:42:35 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-libexec/ChangeLog,v 1.61 2013/08/26 21:17:04 aballier Exp $
+
+ 26 Aug 2013; Alexis Ballier <aballier@gentoo.org>
+ freebsd-libexec-9.2_rc3.ebuild, +files/freebsd-libexec-9.2-no_ld32.patch:
+ Use LD_* variables for 32bits too instead of the FreeBSD invention LD_32_*.
+ We use LD_* everywhere on Gentoo and things like libtool wrappers have no
+ clue
+ about LD_32_* and thus fail to run from the build directory.
+
*freebsd-libexec-9.2_rc3 (26 Aug 2013)
diff --git a/sys-freebsd/freebsd-libexec/files/freebsd-libexec-9.2-no_ld32.patch b/sys-freebsd/freebsd-libexec/files/freebsd-libexec-9.2-no_ld32.patch
new file mode 100644
index 000000000000..d33000927424
--- /dev/null
+++ b/sys-freebsd/freebsd-libexec/files/freebsd-libexec-9.2-no_ld32.patch
@@ -0,0 +1,15 @@
+Use LD_* variables for 32bits too instead of the FreeBSD invention LD_32_*.
+We use LD_* everywhere on Gentoo and things like libtool wrappers have no clue
+about LD_32_* and thus fail to run from the build directory.
+
+diff -uNr libexec.old/rtld-elf/rtld.h libexec/rtld-elf/rtld.h
+--- libexec.old/rtld-elf/rtld.h 2013-08-24 12:30:26.000000000 -0400
++++ libexec/rtld-elf/rtld.h 2013-08-26 17:10:19.000000000 -0400
+@@ -47,7 +47,6 @@
+ #define _PATH_ELF_HINTS "/var/run/ld-elf32.so.hints"
+ /* For running 32 bit binaries */
+ #define STANDARD_LIBRARY_PATH "/lib32:/usr/lib32"
+-#define LD_ "LD_32_"
+ #endif
+
+ #ifndef STANDARD_LIBRARY_PATH
diff --git a/sys-freebsd/freebsd-libexec/freebsd-libexec-9.2_rc3.ebuild b/sys-freebsd/freebsd-libexec/freebsd-libexec-9.2_rc3.ebuild
index 6a82aded3663..285fb69bdb55 100644
--- a/sys-freebsd/freebsd-libexec/freebsd-libexec-9.2_rc3.ebuild
+++ b/sys-freebsd/freebsd-libexec/freebsd-libexec-9.2_rc3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-libexec/freebsd-libexec-9.2_rc3.ebuild,v 1.1 2013/08/26 20:42:35 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-libexec/freebsd-libexec-9.2_rc3.ebuild,v 1.2 2013/08/26 21:17:04 aballier Exp $
EAPI=5
@@ -36,6 +36,8 @@ REMOVE_SUBDIRS="smrsh mail.local tcpd telnetd rshd rlogind lukemftpd ftpd"
IUSE="pam ssl kerberos ipv6 nis xinetd"
+PATCHES=( "${FILESDIR}/${PN}-9.2-no_ld32.patch" )
+
pkg_setup() {
use ipv6 || mymakeopts="${mymakeopts} WITHOUT_INET6= WITHOUT_INET6_SUPPORT= "
use kerberos || mymakeopts="${mymakeopts} WITHOUT_KERBEROS_SUPPORT= "